locked
GPOs started 5 minutes after log in RRS feed

  • Question

  • Hello,

    I have an Active Directory Domain controler.

    I have defined GPOs, and among them there are start up scripts. I have noticed that those scripts start only about 5 minutes after being logged in.

    Does any one have this issue ?

    My build is 9879

    Thank you

    Friday, January 23, 2015 1:44 PM

Answers

  • Hi,

    that's not a problem, it's by design, and it has been since Windows 8.1 Update 1 and Windows Server 2012 R2 Update.

    There's a new GPO setting, "Configure Logon Script Delay", which you can set to 0 or Disable to execute logon scripts immediately (and return to the behavior of previous Windows versions).

    You'll find it by opening GPEDIT, then in Computer Configuration, Administrative Templates, System, Group Policy.

    The corresponding Registry key is:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\EnableLogonScriptDelay (set it to DWORD = 0)

    The geniuses at Microsoft thought this was a good idea.... go figure.



    • Proposed as answer by Zillion_ Monday, January 26, 2015 12:28 PM
    • Edited by Zillion_ Monday, January 26, 2015 12:35 PM
    • Marked as answer by Will799114 Wednesday, January 28, 2015 8:55 AM
    Monday, January 26, 2015 12:28 PM

All replies

  • Hello

    Has anybody experienced same issue ? I have just installed 9926 build, and same problem occurs.

    Will

    Monday, January 26, 2015 9:42 AM
  • Hi,

    that's not a problem, it's by design, and it has been since Windows 8.1 Update 1 and Windows Server 2012 R2 Update.

    There's a new GPO setting, "Configure Logon Script Delay", which you can set to 0 or Disable to execute logon scripts immediately (and return to the behavior of previous Windows versions).

    You'll find it by opening GPEDIT, then in Computer Configuration, Administrative Templates, System, Group Policy.

    The corresponding Registry key is:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\EnableLogonScriptDelay (set it to DWORD = 0)

    The geniuses at Microsoft thought this was a good idea.... go figure.



    • Proposed as answer by Zillion_ Monday, January 26, 2015 12:28 PM
    • Edited by Zillion_ Monday, January 26, 2015 12:35 PM
    • Marked as answer by Will799114 Wednesday, January 28, 2015 8:55 AM
    Monday, January 26, 2015 12:28 PM
  • Hello Zillon_ and thank you

    I was sent this article by the way ; if it could help any body else :

    http://blogs.technet.com/b/platformspfe/archive/2014/03/08/windows-8-1-logon-script-delay-group-policy-setting.aspx

    Wednesday, January 28, 2015 8:56 AM