Remote desktop not working after uninstalling remote desktop Session Host Server


  • Hello, 

    I'm having a problem with my Windows Server 2008 R2. After uninstalling the Remote Desktop Session Host Server Role, I can't connect to the machine from remote anymore. I've tried with clients both from Windows 8 and other Windows Server 2008 R2 but with no luck.

    When I try to connect, I get the error message that the Remote Desktop client can't connect to the remote compute for one of these reasons:

    1) remote access to the server is not enabled.

    2) the remote computer is turned off.

    3) the remote computer is not available on the network.

    On the Server Manager, Remote Desktop is flagged as Enabled. In the System Properties - Remote tab, the option "Allow connections from computers running any version of Remote Desktop (less secure)" is checked.

    The computer is ON and it is connected to the network. I can browse the Internet and the server can be pinged from remote. The Firewall is completely OFF (public, private and domain profile).

    I ran the Remote Desktop client both with the IP address and the domain name....same result. 

    Is there anything else I should check? I am honestly clueless about the cause of this issue.

    Thank you,


    Sunday, November 17, 2013 1:53 AM


All replies

  • Hi,

    As per your comment, I can understand that you cannot able to remote desktop in your environment after uninstalling RDSH server role.

    It may be possible that your issue occurs due to conflicting in port assignment. For this you can check the remote desktop server listener availability by running below command in command prompt and look for an entry for TCP port 3389 (or the assigned RDP port) with a status of Listening. Please refer this article for more information.

    netstat -a –o

    In addition, you can enable remote desktop remotely by registry as per below path:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

    Under “fDenyTSConnections”, edit DWORD Value box in Value data, type 0, and then click OK. Refer this article for more information.

    Also there is setting available for NLA for RD Service connection under GPO under below mention path:

    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security

    Meanwhile sharing “Configure Network Level Authentication for Remote Desktop Services Connections” article with you for more information.

    Hope it helps!

    Monday, November 18, 2013 8:12 AM
  • Hi Dharmesh,

    Thanks a lot for your reply. Unfortunately I was not able to solve the issue.

    I ran the netstat -a -o command, and no process using port 3389 showed up. 

    I went into the registry at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server, and the fDenyTSConnections was correctly set to 0 already.

    I then checked whether there was a different port assigned to RDP. It came out that there was no PortNumber key set in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server/WinStations or in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server/WinStations/RDP-Tcp.  

    So, I added a PortNumber = 3389 (DWORD) in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server/WinStations/RDP-Tcp, restarted the RDP service, but with no luck.

    I also checked the Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security: all the policies settings are marked as not configured.

    Is there anything else I could try to solve this issue?

    Thank you!

    • Edited by fs82 Monday, November 18, 2013 7:37 PM
    Monday, November 18, 2013 7:34 PM
  • Hi,

    Does this issue occur for all users?
    Can you check the event log\ID on both Server and client side?

    As you have stated that you have added RDP Port 3389, so after adding port number did you confirm that the RDP port has added? You can check that by netstat command. Apart from these, there 3 different methods to verify that the listener on the Remote Desktop server is working properly. Refer the article provided in my earlier comment for more information.

    Might be possible that on client side firewall is on and you have not open Remote desktop service (port 3389) on that side. If that try check with firewall off or allow RDS port. Also for a try by you can check by enabling firewall and allow Remote Desktop service (Port 3389) through it. Please refer this thread for more information.

    In addition to that, check below service whether it’s started on both sides.
    Remote Desktop service; Remote Desktop Configuration & Remote Access connection manager services

    Hope it helps to resolve your issue.

    Saturday, November 23, 2013 11:20 AM
  • hi,

    no, I don't see any listener to the port 3389 even after I added it to the registry. Where is the right location to add it? Maybe I'm adding the key in the wrong location. 

    The firewall is completely off, so I believe that is not the case. I tried to connect from multiple clients and it doesn't work with any of them. 

    I restarted all those services but still no luck. 

    I looked for relevant events on the registry (following this thread ) but I could not see anything important.

    Tuesday, November 26, 2013 11:31 PM
  • Hi,

    In RD Session Host Configuration (tsconfig.msc), please delete the RDP-Tcp listener and then re-create it.  After creating the listener please verify that the server is listening on tcp 3389 using netstat.



    Tuesday, November 26, 2013 11:37 PM
  • YES!!!

    It worked! It doesn't let me delete the existing RDP-Tcp, but I created a new one and it worked! Now I  see a port 3389 listening too.

    Thank you so much!

    Tuesday, November 26, 2013 11:43 PM
  • Hi,

    In RD Session Host Configuration (tsconfig.msc), please delete the RDP-Tcp listener and then re-create it.  After creating the listener please verify that the server is listening on tcp 3389 using netstat.



    Any idea how to fix this same issue for 2012 R2

    • Edited by gbentz Wednesday, April 13, 2016 2:47 PM
    Wednesday, April 13, 2016 2:46 PM
  • To fix this issue for 2012 R2 this link has the registry key that needs to be added to restore the RDP listener back to normal. You may need to delete the existing entry for an RDP lister first.

    Saturday, July 09, 2016 6:47 PM