none
Why do I have different data in Power BI than the Google Analytics web interface? RRS feed

  • Question

  • Hi there!

    I'm importing Google Analytics data into Power BI using the GA connector. I created 3 queries:

    1. All sessions by date (All sessions - green)
    2. All sessions by device category and date (Sessions - black)
    3. All sessions by device category, user type and date (Sessions - red)

    [Ok this is terribly frustrating it doesnt let me place the graph image because it says that my account needs to be verified which it is?? I spent way too long trying to figure out how i can re-verify but i gave up.

    Anyway, imagine 2 lines (green and black) that are identical and one red line that fluctuates, sometimes a bit higher, sometimes a bit lower than the other lines but never the same. ]

    As you can see (were supposed to) the 1st (green) and the second one (black) have exactly the same numbers and form identical lines. They also match to the graph in the GA web interface. But for the data that is queried to include the user type numbers as well, the total session numbers are off in a way I can't explain (red).

    Anyone an idea why this is?

    Cheers, Ruben



    • Edited by Rrux Tuesday, November 1, 2016 12:17 AM
    Tuesday, November 1, 2016 12:16 AM

Answers

  • Hi Ruben. Here are some suggestions I received from some of my fellow team members.

    • Are you trying to do the aggregation locally? This isn’t suggested as PBI isn't able to de-dup the same way Google Analytics does.
    • It’s also possible that you've run into the (known) issue that we’re apparently using sampled data and not the full data.

    Please let us know if either of these seems to be the issue.

    Ehren


    Tuesday, November 8, 2016 7:58 PM
    Owner