locked
Wow6432Node\... nested instances of this registry key RRS feed

  • Question

  • On a new installation of Vista 64 Ultimate, after required applications installed, multiple nested instances of Wow6432Node are on the HKLM hive...

     

    HKLM\Software\Wow6432Node\Wow6432Node\... out to 19 times

     

    In all of the MSDN articles concerning this node there does not seem to be anything that indicates this node should have multiple, nested instances. Furthermore, there is only one instance of this in the HKCU hive.

     

    The farther out on the tree the older the data in these nested instances. Removing all restore points has no effect, the nested nodes remain after a reboot.

     

    Whether this is a bug in Vista 64 or in the way some applications handle the registry during installation is not apparent from the data I have avaliable.

     

    Other people have reported this on the Web but there does not seem to be a knowledgable response. One respondent found that deleting all but the first node did not have any adverse effects. Most of these comments resulted from issues with Registry cleaners. Since my Vista 64 installation has never had a registry cleaner installed or used on its registry the problem is not with the Registry cleaners but with Vista's Registry.

     

    The additional nested nodes add to the size of the HKLM hive and increase the time it takes to search the Registry for anything. If my installation has 19 now, how many will it have in the coming weeks?

     

    So, does anyone know what is going on and what needs to happen to fix this situation?

    Monday, July 23, 2007 8:50 PM

All replies

  • After starting from a clean install (formatted HD by Vista 64 Installer) I checked after each step for this issue. I can state categorically that one of the following Microsoft updates added all of these Wow6432Node entries. I can't say which one because the automatic update process performed all of this in one go.

     

    Prior to the appearance of these Registry entries the following had been done...

     

    1) Vista 64 performed a clean install from the DVD

    2) Intel motherboard chipset INF installed

    3) Intel motherboard audio/lan/Marvell RAID drivers installed

    4) nVIDIA Drivers vs 158.24 installed for a GeForce 8800 GTS adapter

    5) Wacom Intuos3 tablet drivers installed, vs 604.4

     

    At this point there were no Wow6432Node folders in the HKLM\Software hive. Up to this point I have checked for this with RegEdit after each installation and after each reboot.

     

    6) Via the MS Update web page the following KBs were installed, all at one time, the order was retrieved from the log files...

     

    01) KB929399 Music Services fix
    02) KB925902 El of Priv in EMF, Remote Exec in CVE, Local El of Priv in GDI
    03) KB935280 Set of app compatibility issues: DNE, Justsystems, Age of Emp III, Small Bus Svr, Speedbit, WinRaR, Yahoo AutoUpdater
    04) KB932471 Changed time zones
    05) KB936825 Enables new features: SDHC cards, Dual Voltage SD/MMC cards, SDIO cards
    06) KB931836 Time Zone Changes
    07) KB931213 Security Issues, Gain Access to Data and Passwords within Registry
    08) KB931099 Windows Defender malware sample submission defect
    09) KB930857 Windows Error Reporting, insures user notification when errors reported to MS
    10) KB928089 Performance issue with IE7 Phishing Filter
    11) KB936824 Corrupted iPod - safely remove hardware issue
    12) KB931573 Reactivate pre-installed Vista OS issue
    13) KB935807 Windows Firewall vulnerability
    14) KB930178 Code Ex in MsgBox, Local El of Priv in CVE, DoS in Client/Server Runtime
    15) KB933928 Improve messaging, reducing steps resolving product activation/validation
    16) KB933566 Gain control via IE7
    17) [KB928089] // Installed 2nd time
    18) KB929916 Access Restricted Data in .NET 2 and IE7
    19) ?KB929916? nVIDIA driver update failed, error: 0x80070103 [newer driver already installed]
    20) KB935652 Bundles: 929011, 932753, 932818, 931967...
          929011 - Media Center configuration of TV tuner
          932753 - Media Center Resize issue w/ video playback
          931967 - Media Center no playing sound after waking the computer
          932818 - Media Center Cumulative Update for Media Center...
            929011 - Media Center Correctly configuring TV tuner
            932753 - Media Center Resize Media Center stops video playback
    21) KB905866 Junk email and Phishing Filter updates
    22) KB929777 Fix for IRQL_NOT_LESS_OR_EQUAL when installing Vista w/ > 2 GB RAM
    23) KB936357 Reliability update for multi-core CPU platforms
    24) KB929123 Outlook Express, Windows Mail
    25) KB937077 HDA audio device fix for not work after waking computer

     

    7) Reboot required by the installation process, after the reboot all 19 nested Wow6432Node folders were in the Registry.

     

    So it is one of the Microsoft KB updates that is installing all of these nodes, not some errant 3rd party application.

     

    Now, how can we get this situation fixed?

     

    PS: Simply deleting the extra nodes is not an answer -- I tried that, it really garbaged things, going back to a restore point got the system working well enough to recover all my notes before completely reinstalling Vista 64.

     

     

     

     

    Friday, July 27, 2007 2:18 AM
  • As of now all of the 'nested' instances of Wow6432Node are gone.

     

    MS continues to install KBs and Vista continues to build its own profiles while I work on porting all my work to the new computer/OS. At some point after the last post 'something' cleaned up all the redundant/nested instances of this node on the HKLM. At least that is what appears to have happened, see the last paragraph below for a possible alternative scenario.

     

    There is one additional instance of this node on the base instance of this node but it does not replicate the full tree as it did before.

     

    I'm wondering: Is it possible that RegEdit's navigation of the Registry (using the API I assume) was misinterpreted by Vista and when it came to the instance of HKLM\Software\Wow6432\Wow6432 such that Vista recursively returned to the first instance of this node for each time the node was encountered? How would the system know to stop, it would be an endless loop otherwise. That might explain why RegEdit was taking so long to do a search though.

    Sunday, July 29, 2007 4:12 PM
  • Any news on this ridiculously silly bug ?

    I mean honestly, such idiocay belongs in some kind of early alpha release, not in a full-blown MS OS.

    My current vista install has about 32 nested Wow6432Node folders in the registry. When I run Registry Repair (a third party tool), it takes hours to get past this nested ***.
    Wednesday, August 13, 2008 10:07 PM
  • jultus said:

    Any news on this ridiculously silly bug ?

    I mean honestly, such idiocay belongs in some kind of early alpha release, not in a full-blown MS OS.

    My current vista install has about 32 nested Wow6432Node folders in the registry. When I run Registry Repair (a third party tool), it takes hours to get past this nested ***.


    If Registry Repair an x86 app - that itself is most likely the cause of apparant nested WOW6432Node folders.




    Wednesday, December 17, 2008 5:34 PM