none
PWA Administrator Rights Removed from Users every 24 hrs RRS feed

  • Question

  • I've set up one of my Project Online instances with PWA Security (Traditional) mode (as opposed to Simple / SharePoint security mode).

    If I add the "Adminitrators" security group to a user, this group gets removed from that user every 24 hours (seems to happen at around midnight Seattle time).

    I can re-add the group to the user and it all works fine until it hits midnight again the next day.

    The one user this behaviour doesn't happen to, is the user who created the tenant and instance, and is an Office 365 Administrator, otherwise it happens to every other user where the group is applied.

    Anyone else seen this behaviour? Have I spotted a bug?

    Thursday, December 6, 2012 10:32 PM

Answers

  • Do you have the AD Sync turned on for that group?  I just tested this out
    by converting my online tenant to classic mode, and it seems to provision
    the Admin group with a default sync to an AD group.
     
     

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky
    • Marked as answer by Dave Wells Friday, December 7, 2012 5:04 AM
    Friday, December 7, 2012 4:01 AM
    Moderator

All replies

  • Do you have the AD Sync turned on for that group?  I just tested this out
    by converting my online tenant to classic mode, and it seems to provision
    the Admin group with a default sync to an AD group.
     
     

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky
    • Marked as answer by Dave Wells Friday, December 7, 2012 5:04 AM
    Friday, December 7, 2012 4:01 AM
    Moderator
  • Well spotted, I didn't even consider this as I hadn't set up AD Sync, but you're right by default it synchronises PWA "Administrators" with the "Company Administrator" AD group. Wonder if this is a good thing to have happen by Default?
    Friday, December 7, 2012 5:04 AM