locked
Launch Failed -and- Access Denied on Q:\ RRS feed

  • Question

  •  

    Hi,

     

    I’m very interested in (and new to) SoftGrid. I’ve made a clear test environment with a DC, TS and a SofGrid Application server.

     

    Version: 4.1 for Terminal Server.

    Reference: for now I used the Quick Start Guide.

     

    I’ve installed the VAS and the client on TS.

    Then I proceed ‘Testing the Default Application’ on page 14.

    Everything looks great. I see the icon published on the TS, but when I double click I see a notification on the notification area: “Launch Failed”.

     

    I bet it has to do with security rights. I’ve checked the AD group and the user is member of the group “SoftGrid Users”.

    When I access the content share via: \\VAS\APPS\content I’m able to access the share.

    When I double click the Q:\  I get “Access Denied”.

    (Q:\ is the default drive letter for the content I’ve used)

     

    When I double click the OSD file from the share I also get “Launch Failed”.

     

    In the  sftlog.txt  I see two lines:

    I: the softgrid client could not connect to stream URL: …

    II: the client was unable to connect to a softgrid server (rc 1690150A-20000194)

     

    I: this is mostly because of an missing SFT file; this is not the case it’s in the same location.

    II: this has probably something to so with a security setting.

     

    What can I check now?

    It would be great if somebody could push me into the right direction. I’m stuck for the moment.

     

    Best regards,

    Yuri

    Thursday, July 17, 2008 12:58 PM

Answers

  • Hi everybody,

     

    The problem is solved.

     

    I’ve copied the files in the shared content directory to the original location:

    C:\Program Files\Softricity\SoftGrid Server\content

    and now I’m able to launch the default application.

     

     

     

    I’m still a bit confused though. On the SoftGrid Server in the Management Console.

    I go to: softgrid systems\localhost\applications

    In the properties of the application the OSD Path and the Icon Path refers to the shared directory and not to the default “C:\Program Files\Softricity\SoftGrid Server\content“ directory.

     

    Where should I change the content directory?

    I configured the default content path over here:

    right click localhost | system options | general tab | default content path

     

    And still I had to copy the content to “C:\Program Files\Softricity\SoftGrid Server\content“ to get it work.

     

     

    Thanks,

    Yuri

     

    Tuesday, July 29, 2008 11:56 AM

All replies

  • Hi Yuri,

     

    Check the OSD file for the HREF path.

    is it set to %SFT_SOFTGRIDSERVER% (default)?  did you create the environment variable on the App-V client's Workstation? if you haven't, the APP-V client is not able to connect to the VAS server (which is the problem according to the error message)

     

    You cannot access the Q drive via the windows explorer. if you want to do so, you can add a script to the OSD file that launches cmd.exe. which can be easily done with the OSD editor. You can find the OSD editor on www.loginconsultants.com

     

    Kind Regards,

     

    Jan van der Elst

    Login Consultants

     

     

    Thursday, July 17, 2008 6:12 PM
  • Hi Jan,

     

    Thank you for your quick reply.

     

    The HREF path is   rtsp://VAS:554/DefaultApp.sft

    (so this will work without the environment variable I guess)

     

    When I try this path in IE it say: "Page can not be displayed." (logical I think)

    When I ping VAS (servername): I  get a reply <1ms

     

    [It's not necessarily for me to access the Q: I thought it might have something to so with the Launch Failed.]

     

    What are the next steps for me to check?

    Friday, July 18, 2008 7:12 AM
  • Hi Yuri,

     

    A SoftGrid-enabled application will not load if the Server’s SoftGrid Virtual Application Server service Log On account does not have Read File Permissions to the .sft files. Normally this is for the SYSTEM account. Verify that it has the proper permissions by right-clicking on the /content folder with the .sft files

     

    Best regards,

    Reto

     

    Friday, July 18, 2008 9:10 PM
  • Hi Reto,
    Thank you for your reply.
    I've checked the permissions and they are OK.
    I've also double checked the service and it is still controlled by the local system account.
    What is the next logical step?
    Regards,
    Yuri
    Sunday, July 20, 2008 4:18 PM
  • Hi everybody,

     

    The problem is solved.

     

    I’ve copied the files in the shared content directory to the original location:

    C:\Program Files\Softricity\SoftGrid Server\content

    and now I’m able to launch the default application.

     

     

     

    I’m still a bit confused though. On the SoftGrid Server in the Management Console.

    I go to: softgrid systems\localhost\applications

    In the properties of the application the OSD Path and the Icon Path refers to the shared directory and not to the default “C:\Program Files\Softricity\SoftGrid Server\content“ directory.

     

    Where should I change the content directory?

    I configured the default content path over here:

    right click localhost | system options | general tab | default content path

     

    And still I had to copy the content to “C:\Program Files\Softricity\SoftGrid Server\content“ to get it work.

     

     

    Thanks,

    Yuri

     

    Tuesday, July 29, 2008 11:56 AM
  •  Yuri NLD wrote:

    I’m still a bit confused though. On the SoftGrid Server in the Management Console.

    I go to: softgrid systems\localhost\applications

    In the properties of the application the OSD Path and the Icon Path refers to the shared directory and not to the default “C:\Program Files\Softricity\SoftGrid Server\content“ directory.

     

    Where should I change the content directory?

    I configured the default content path over here:

    right click localhost | system options | general tab | default content path

     

    And still I had to copy the content to “C:\Program Files\Softricity\SoftGrid Server\content“ to get it work.

     

    Yuri,

     

    The paths in OSD and ICO field should point to files in the form that is valid for the client, not server (i.e. C:\Program Files\.. etc. is valid on the server for finding out SFTs as it's running locally on that system, but client would try to look inside it's own Program Files, which of course do not include said path). Two canonical path-formats in those fields are either UNC or HTTP. In other words, something that is valid for all the clients trying to access those files as they are ones interpreting OSD and ICO fields' contents.

     

    Default content path refers to path that Management Console, and only it, uses when importing new packages. Without it, you (OSD and ICO reference) would end up with whatever path you used when browsing for SPRJ file, path that most likely isn't valid for the client.

     

    Here's how access to files goes:

     

    SFT (for streaming): server accesses the file according the relative path found under Packages -node in Management Console. The full path is formed with server's local knowledge of it's own content path (stored in registry) concatenated with this relative path. E.g. C:\Program Files\Softricity\Softgrid Server\content is added to mypackage\myapp.sft, forming the full path.

     

    OSD & ICO (for application records and metainformation at client): client gets the list of applications with associated OSD and ICO paths (as defined in Management Console's Application -node) and then goes and fetches these ICO and OSD files one-by-one using the path provided. If it cannot have OSD for some reason (invalid path etc.), it cannot display the application as OSD = application's EXE for SoftGrid (roughly).

     

    br,

    Kalle

    Tuesday, August 5, 2008 2:24 PM
    Moderator