none
DPM 2010 Client re-sync RRS feed

  • Question

  • Had some problems with disks on DPM server and had to remove and add disks.

    I have a 20+ clients on a Protection groups; After changes disk, the clients show Volume missing;

    I stop protection the clients, then re-added them.  - Now I can't get the clients to sync with server ?

    How can I get my existing clients re-sync?

    Friday, September 24, 2010 6:52 PM

Answers

All replies

  • Hi

    Try use the DmpSync -Sync command.

     

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Friday, September 24, 2010 7:21 PM
    Moderator
  • I have try that, -   Consistency check failed to trigger  - Client initialization is pending   ,

    How can I start a initialization again on the client.? 

    Friday, September 24, 2010 7:33 PM
  • Have you removed disks from the DPM diskpool?


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Friday, September 24, 2010 8:05 PM
    Moderator
  • Yes - had to remove some and added others.
    Friday, September 24, 2010 8:22 PM
  • Ok. Regarding the error it seems that you haven't done a migration of the data from the old disks in the disk pool to the new once. It seems that the relica or recovery point volume can't be found in DPM because of that.

    To be really sure that the volumes is missing use the DpmSync -ReallocateReplica CMDLET from a DOS prompt and try to sync again.

    If it doesn't work you can stop the protection of the protected memeber choose not to retain the data. This will delete all the data associated with that Protected Member. Enable the protection again and you should be home free.

    Get back with info.

     

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Friday, September 24, 2010 8:40 PM
    Moderator
  • OK - running Dpmsync -ReallocateReplica now...

    Here is what happen-  Disk in storage pool have been remove, and change differenct controler.

    DPM found the Protected Members Volume missing;

    I stop the protection, and choose not to retain the data;

    Then I added the client back into protection group; When I try to run a sync; I get:

    The consistency check failed to trigger for client datasource as client initilization is pending

    This will happen automatically when the client computer connects to the DPM server (ID 32521)

    I now have tried Removing the client, then adding it back in, with same result.

     

    Friday, September 24, 2010 9:29 PM
  • More info: testing - I move one of the clients to a New Client protection group, and now the client will sync...

    So old data is being keep within the PG - and will not clean out ...

    Friday, September 24, 2010 9:38 PM
  • More testing: Remove another client for PG, and Remove Agent; Reinstalled Agent and added back into Old PG and it is now sync..

    Look like something on the client side agent keeps some data that can't get cleared without a re-install......

    I don't want to remove & reinstall all my clients - anything that could be done to clear and reset the client agents?

    Friday, September 24, 2010 10:07 PM
  • Hi guys,

     

    I wanted to know if this issue has been solved, because I have a similar issue and I can't figure it out.

    Time ago I had a disk in the storage pool which went bad and I had to replace it. After the replacement I reallocated the replicas and synced all the protection groups but the protection groups for clients start having problems.

    The problem is that most of my clients don't trigger the synchronization (setup every hour) and then when the recovery point occurs I get the following error:

    "The job completed successfully with the following warning:

    No recovery point was created, either because synchronization has not occurred since the last recovery point was created, or because no changes were found during synchronization. (ID 208)"

    I tried almost everything: removing the client from the PG either retaining the data or not, removing the agent and reconfiguring it on a new PG, running the DpmSync -Sync every time I add a client (or more). I going crazy! There is no logical explanation why it's not working, some of them just work (3 on 15). The first clients I add to the new PG work, once I keep adding clients they never sync... I can manually run consistency checks, recovery points... but the automatic sync doesn't occur! I tried to move one client to one group to another and it's now magically syncing... but others that used to work, now don't...

    I installed the March 2011 hotfix where it's supposed to solve this issue and others like consistency checks ran on the PG do not trigger the actual consistency check on the single clients, which it seemed to be solved once I installed the hotfix, but the problem came back the next day.

     

    I'm stuck, I need to find a solution otherwise I will need to switch to a different backup system solution. I need some help please.

     

    Thank you so much for your time

    Angelo 

    Wednesday, April 27, 2011 8:53 PM
  • Does anybody have any idea?

     

    Thanks,

    Angelo

    Friday, April 29, 2011 11:42 PM
  • housekeeping - closing old post.  Open a new post if you still have a need.
    Wednesday, November 30, 2011 1:31 PM
    Moderator
  • We had a similar issue where we lost a hard drive and then after replacing the hard drive we lost automatic syncing on all protected servers/computers.  Using the information above, we tried to disable the agent on one of the protected servers. When we were unable to re-enable the agent, we went to the server in question and removed the protection agent (Control Panel) and then reinstalled the agent.  We then ran SetDPMServer on the server in question and it was re-enabled.

    At that point, ALL servers started syncing automatically again.  We did not have to reinstall the agent on all servers, just one.

    HTH,

    David Lloyd
    Lemington Consulting


    David Lloyd Lemington Consulting http://LemingtonIT.com

    Saturday, March 21, 2015 9:18 PM