locked
Problem with Vista Installation on ata-raid RRS feed

  • Question

  • hi all!

    finaly i have recived the DVD of windows vista. But i have some problems with the installation on the ata-raid.

    my ata-raid card is an adaptec 1200A...with windowsXP the drivers works, but not on vista.

    when i try to load the drivers, vista say "no device drivers were found. Make sure that the installation media conteins the correct drivers...".

    But i remember that the win XP drivers on the beta of longhorn works!

    i have looked for the drivers for vista but there aren't.

    is possible to install vista on raid with the win XP drivers?

     

    Sunday, July 2, 2006 10:45 AM

Answers

  • Hi, to solve this problem you have to put all the drivers for windows xp in the root folder of a floppy disk or USB drive and the installer will recognize it without any problem. bye
    Sunday, July 2, 2006 1:06 PM

All replies

  • Hi, to solve this problem you have to put all the drivers for windows xp in the root folder of a floppy disk or USB drive and the installer will recognize it without any problem. bye
    Sunday, July 2, 2006 1:06 PM
  • Hi I have the same problem with the same card.

    I tried coping the xp drivers to a memory key, and floppy disk with no joy. I get the same "no device drivers were found. Make sure that the installation media conteins the correct drivers..."message

    I even tried the 2003 server drivers but they were the same.

    When I was trying it on the floppy disk I didnt even hear the pc trying to access the disk so im not sure whats going on as the installer dosnt let you browse for the drivers... 

    Monday, July 10, 2006 12:53 PM
  • Hi,

    you have to use the lastest driver from the Adaptec website.

    I can upload my drivers if i can, but i dont find any place in this forum where i can upload files. So, try with that drivers, it worked fine for me.

    Bye.

    Monday, July 10, 2006 12:59 PM
  • Monday, July 10, 2006 1:15 PM
  • Hi,

    remember that i'm speaking about an ATA Raid card, not a Serial Ata Raid card.

    I'm sure that you may use another dirver, so i cannt help you. The only thing that i can tell you is to put all the drivers in the root folder of the usb storage key. That was my stupid problem with the vista driver load, i hope this will help you too.

     

    Bye!

    Monday, July 10, 2006 1:21 PM
  • No, no joy....

    Thanks anyway matey

    I might just bung in an ide drive to try it out on, just seems a shame to have xp flying on the sata and vista crawling on the old school....

    Monday, July 10, 2006 1:25 PM
  • Question.  Are you trying to do a full install, or update the drivers for an unknowen device?  When you look at the floppy/USB drive, etc, do you see a setup.inf or oemsetup.inf there?

    Glenn
    Monday, July 10, 2006 3:54 PM
  • Installing driver for a previous version from a floopy also leads to an installation faliure. A blue screen apears saying memory is dumped to prevent further hazard to the computer.
    Tuesday, July 11, 2006 5:38 AM
  • Full install from sratch, the installer dosnt give you a browse option...
    Tuesday, July 11, 2006 8:46 AM
  • I have read about removing the Oemsetup.inf from the driver disk/directory and then Vista installed them.

    Glenn
    Monday, July 24, 2006 6:24 PM
  • Solution: (I Think)

    I had the exact same problem with my Adaptec 1200a.  I want to install it on my existing system dual-booting XP MCE2005.  I could NOT get Vista Beta2 Release 5472 to see my partitions, or let me use the Adaptec drivers.

    I researched the card, and found it was actually made by HighPoint.  It uses their HPT370 controller.  HighPoint also makes the exact same card with their name on it, it's the RocketRaid 100 PCI.  I downloaded the drivers for this, and I have so far only tested to make sure they are going to work.  I booted from the DVD, and used those drivers.  Finally it recognized my 2 existing raid arrays and was willing to let me continue.  I canceled the setup because I have some partitioning to do to make room for Vista first.

    The drivers I found are at: http://www.highpoint-tech.com/BIOS%20%2B%20Driver/rr100/Win/hpt3xx-win64-0620.zip
    Sunday, August 13, 2006 3:51 AM
  • I installed Vista successfully to a second primary partition after loading those drivers, I know the drivers are working in vista setup (32bit) because I can access all of the drives connected to the Adaptec RAID controller after I load these drivers during setup.  However,

    I'm in the same boat as many MANY other people trying to run Vista in a Dual-Boot configuration.  I get...

    Boot Manager failed to find OS Loader
    Windows\System32\Winload.exe
    0xc00000e9

    NOW, I thought it was due to several different complications about my hardware setup.

    (Asus A8R-MVP, Athlon64 3200+, 2gb (4x512mb) Kingston HyperX, 2x WD 80gb PATA in Raid 0 for my Primary Windows XP MCE2005. 2x WD 30gb in Raid0 for Data Backup.  1 WD 250gb for TV Recordings, MSI Radeon X1600 pro 256mb PCIX, LiteON DVDRW 8x, LiteON CDRW 52x, LiteON DVDROM 16x.  9-in-one Memory Card Reader (Pulled from an HP and painted to match my case). 

    All of my hardware passes diagnostics (PC-Check and PC-Doctor) and runs completely stable in XP Media Center.  I have NO complaints about performance or stability.

    I thought the issue was at first, the wrong driver for the Adaptec card.  But it couldn't be because it works in the 32-bit environment for Vista setup.  However, I cannot launch any EXE files, including Notepad, from the vista hard drive while running XP.  This I believe would be an issue with the EXE's being compiled for a 64-bit os kernel.

    I thought, Maybe my exe files are corrupted on my install from a bad disc.  I cannot verify that this is the case, because I CAN launch the 64-bit versions of these programs from the Command Prompt in the Vista recovery option when booting from DVD.

    I wondered if the Boot Loader was not loading the RAID drivers early enough and drive letters are changing after these drivers load.  So I ran the Vista MS-Dos Prompt in the recovery WITHOUT loading any of the drivers for my raid controller (I installed vista on a 20gb partition on the 250gb TV Recording drive, not on the RAID array).  I could access this, and the drive letter for Vista was D: with and without the RAID drivers being loaded.

    Maybe the RAID Drivers do NOT support a 64-bit kernel?

    This "hpt3xxamd64 = "HighPoint HPT3xx Controller for Windows x64", hpt3xx" is in the TXTSETUP.OEM of the folder for the drivers I posted.  However, there is only a hpt3xx.sys, no hpt3xxamd64.sys.  Does anyone think this is a problem?

    Let me know if any of you can get past this, i'm stuck at this point.

    ~Ron (rjsoderlund_at_hotmail.com) (put FORUM in caps in the subject line to prevent from being junk-mail filtered)
    Full Time PC Technician, Microsoft and A+ Certified (and stumped).
    Monday, August 14, 2006 2:48 AM