none
Compatibility problem when installing Remote desktop services role on 2012 "Unable to connect to the server by using Windows Powershell Remoting"

    Question

  • Trying to install RDS on 2012 I get the following error.

    "Unable to connect to the server by using Windows Powershell Remoting" On the "Checking Compatibility" window. I'm just trying to install the "Quick Start: option

    I did the "Enable-PSRemoting -force" on the server and still have the error.

    enabled "allow remote server management through WinRM" in group policy also, still same problem.

    Thanks ahead of time.

    Monday, October 15, 2012 4:26 PM

Answers

  • Hi,

    I would like to know how did you install the role, by Windows Powershell remoting or use Server manager to manage remote Server?

    After enable both server's psremoting, please restart them and try again.

    Regards,

    Yan Li


    Yan Li

    TechNet Community Support

    Wednesday, October 17, 2012 7:15 AM
    Moderator

All replies

  • Hi,

    I would like to know how did you install the role, by Windows Powershell remoting or use Server manager to manage remote Server?

    After enable both server's psremoting, please restart them and try again.

    Regards,

    Yan Li


    Yan Li

    TechNet Community Support

    Wednesday, October 17, 2012 7:15 AM
    Moderator
  • Used the server manager

    Clint Morrow

    Tuesday, October 23, 2012 1:18 PM
  • I am having the exact same issue.  Any fixes?
    Thursday, October 25, 2012 9:24 PM
  • Same issue here, installed via server manager. I can run enter-pssession servername and it works with no issues in a PS prompt.
    • Proposed as answer by KL_2017 Wednesday, February 11, 2015 12:20 PM
    • Unproposed as answer by KL_2017 Wednesday, February 11, 2015 12:20 PM
    Wednesday, November 07, 2012 10:51 PM
  • Hey there, did you ever get an answer to this?

    I am having the same issue.

    psremoting IS already enabled on this server.

    I am using server manager to install roles.

    Add Roles and Features Wizard > Remote Desktop Services Installation > Quick Start > Session-based desktop deployment, Select my server > click next > "Unable to connect to the server by using windows powershell remoting"


    Andrew Huddleston | Hillsong Church | Sydney

    Thursday, November 22, 2012 4:05 AM
  • After working for weeks with M$ Support level 2 and higher on this issue below is the fix and reason for the issue.

    In a PS Shell

    Set-Item WSMan:\localhost\Shell\MaxMemoryPerShellMB 1000

    then reboot

    The default remote shell is allotted 150MB of memory. If we have Sharepoint/IIS App pool on the server then this memory is not sufficient to create a remote session (This is used mostly while installing any roles on windows server 2012) . Therefore by running that command we have enabled the remote shell to use 1000mb which will  provide more memory  to windows powershell to make remote sessions and resolve the issue.

    • Proposed as answer by Firestormo Wednesday, November 28, 2012 10:50 PM
    Wednesday, November 28, 2012 10:49 PM
  • Check windows firewall.  I had the same issue until I disabled it.
    Saturday, January 19, 2013 8:06 PM
  • I added the 'Windows Remote Management' rule to my firewall and that fixed the problem.

    • Proposed as answer by localhost81 Friday, April 04, 2014 7:37 PM
    Friday, February 15, 2013 12:22 AM
  • Hello,

    Although I disabled the FW, allowed WinRM and Remote Powershell, I used two different NT accounts: one from a trusted forest and a 3nd one from the same forest as the server, gpupdate the policy to allow Remote Management, Set-Item WSMan:\localhost\Shell\MaxMemoryPerShellMB I was trying to configure with RDS I still got the:

    "Unable to connect to the server by using Windows Powershell Remoting" On the "Checking Compatibility"

    In my case the solution was to "Shift" click on "Server Manager" and select "Run as administrator" .

    It is a little bit silly that for "Server Manager" the elevation is not proposed even.

    I hope it helps.

    Best Regards,

    Tiberiu Baraboi

    • Proposed as answer by Pootie-Tang Wednesday, November 27, 2013 5:36 PM
    Friday, February 22, 2013 3:48 PM
  • Still not working for me

    tried services and PS enable and PS expand Shell size....nothing

    here's my other issue - I'm following the MS MOC - trainer guide for MCSE Desktop Infrastructure

    Testing it out so I can teach this component - lol - hard to teach if it don't work

    any ideas??

    Saturday, March 16, 2013 5:08 PM
  • had same issue fixed it by
    clearing the proxy

    netsh winhttp reset proxy

    worked for me

    • Proposed as answer by rkettles Friday, April 19, 2013 4:41 AM
    Monday, March 25, 2013 4:19 AM
  • None of this worked for me :(

    I'm Trying in W Azure Scenario with 1subnet.

    http://s7.postimg.org/e45xr7t07/w2012rds_fail.jpg


    • Edited by Gabriel RG Wednesday, May 15, 2013 12:54 PM img
    Wednesday, May 15, 2013 12:48 PM
  • I had the same issue, none of the above worked for me.

    I decided to see what my FQDN was resolving to and it was using the IPV6 address FE80 etc, I disabled IPV6 and retried and it worked for me.

    • Proposed as answer by Stephan Swart Saturday, July 27, 2013 10:15 AM
    Tuesday, June 18, 2013 12:16 AM
  • Tuesday, June 18, 2013 3:48 AM
  • This worked for. Had to turn off IPv6.
    • Proposed as answer by Stephan Swart Saturday, July 27, 2013 10:15 AM
    Thursday, June 27, 2013 11:57 PM
  • In case you're using a Hyper-V based scenario: for me it helped to disable "Integration Services > Time Synchronization" within the Hyper-V settings for the virtual machine I tried to deploy remote desktop services on.

    The problem was that the virtual machine was somehow out of sync with the domain controller and thus was not trusted to use remote management/powershell ...

    • Proposed as answer by Georg Eichhorn Thursday, November 02, 2017 4:59 PM
    Monday, July 22, 2013 6:28 PM
  • Here's what I've found. Adding RDS with the "Quick Start" option, followed at some point later removing RDS, seemed to give me the "Unable to connect to the server by using Windows Powershell Remoting".

    I did the powershell fix. "Set-Item WSMan:\localhost\Shell\MaxMemoryPerShellMB 1000", reboot and retry didn't do it for me.

    Also the Server Manager SHIFT runas Administrator (not sure how it's even possible NOT to run as Administrator really?) didn't do it for me.

    I had my firewall turned off, so no issues there. I did reset it and turn it off again. Still nothing.

    Re-adding back IIS along with RPC for HTTP Proxy, rebooted. Was able to add the RDS and Quick Start role again.

    Not 100% sure how that's the case. But I removed them. Got the same error. Readded them (rebooting between add and removal) it worked again.

    Hope this saves someone some frustration.

    Wednesday, August 14, 2013 8:24 PM
  • I tried all the above but did not succeed. But after I had changed my network from public to domain network it worked.

    How I did this?

    I have a separate domain controller server in my network and also a NAT/Firewall. This NAT/Firewall is setup as DHCP server so I have set my DNS towards this server. 10.0.0.1 As a secondary server I have set my Domain controller's IP 10.0.0.10 and now the network changed to Domain-Network and I am able to install RDP services.

    Hope this helps you guys.

    The link from Anonymous2992 helped me to this solution. Thanks!

    Thursday, October 31, 2013 10:02 PM
  • Hi Guys,

    This silly error wasted my 1 precious day

    In my case i restarted the DC and RDS server to resolve this issue.

    Hope this may help someone.

    Goodluck !!

    Friday, December 20, 2013 11:13 AM
  • Is this a bug in 2012? I've ried all of the above and still the issue remains.
    Saturday, December 21, 2013 10:21 PM
  • Same here.
    Friday, December 27, 2013 9:32 PM
  • After trying all the hard stuff, resetting the proxy with netsh winhttp reset proxy was what finally fixed the problem. Thanks, RKettles!
    Tuesday, January 14, 2014 10:19 PM
  • had same issue fixed it by
    clearing the proxy

    netsh winhttp reset proxy

    worked for me


    x2, it would have been helpful if MS put a reference to this possibility in the list
    Thursday, January 16, 2014 8:36 PM
  • Hi Tibi,

    Ur solution worked in my case...

    Friday, January 17, 2014 6:43 PM
  • I tried everything listed above - none worked.

    Using server 2012 with exchange 2010 so something has gone awry with permissions. Domain admin can't seem to do anything so added another admin account (with local admin rights) then running the RDS Deployment from an elevated Server Manager session did the trick for me.

    Hope this helps someone!
    Monday, March 03, 2014 10:10 PM
  • Have tried all the above and none have worked for me on Windows 2012 R2 RDS.

    On Windows 2012 RDS servers it works fine without any problem

    • Edited by 1rf4N Thursday, March 06, 2014 3:51 PM
    Thursday, March 06, 2014 2:59 PM
  • Same here - have tried everything mentioned above. Still getting the same error. Anything else to check?
    Wednesday, March 12, 2014 3:31 PM
  • @joshhoff

    Have you managed to resolve the issue yet?

    Tuesday, March 18, 2014 4:27 PM
  • I was able to resolve the issue on Windows 2012 R2 - by clicking server manager.. local server and enabling "remote management"
    • Proposed as answer by Tami Jones Thursday, May 01, 2014 6:24 PM
    Thursday, May 01, 2014 6:23 PM
  • All the solutions mentioned before didn't solve our problems. Finnaly we decided to uninstall Powershell completely from our newly installed RDS Server...the site affect of this is that the GUI also will be unistalled. After te uninstall of powershell we rebooted the server. Via our DC's Server Manager we installed Powershell remotely again along with the GUI and this solved our problem. Because the other newly installed servers didn't have this problem I guess that this problem is introduced after installing a feature (my guess is the Desktop Experience Feature, but i'm not sure and will test this later this week).


    Saturday, May 10, 2014 7:50 PM
  • I have tried all the above and it's still not working.
    Monday, May 12, 2014 3:49 PM
  • Removing SPN HTTP/myserver.mydomain.org from service account for sharepoint solved my problem.


    • Edited by zvdf Thursday, May 15, 2014 10:44 AM
    • Proposed as answer by Vitiris Tuesday, April 28, 2015 12:28 PM
    Thursday, May 15, 2014 10:42 AM
  • i found another possible reason, this solution worked for me:

    http://oyvindnilsen.com/solution-for-powershell-remoting-error-it-cannot-determine-the-content-type-of-the-http-response-from-the-destination-computer/

    I tried to set up powershell remoting on a server and kept getting this error:

    Enter-PSSession : Connecting to remote server failed with the following error message : The WinRM client cann
    ot process the request. It cannot determine the content type of the HTTP response from the destination comput
    er. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help to
    pic.

    After a bit of troubleshooting I discovered that the problem was that the authentication packets was to big (over 16k), this will cause WinRM to reject the request. The reason for authentication packets getting too big can be because the user is member of very many security groups or in my case because of the SidHistory attribute.

    The solution was to increase the MaxFieldLength and MaxRequestBytes keys in the registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP\Parameters

    If the keys does not exists you can create them, be sure to use the DWORD type.

    I sat MaxFieldLength to DEC value 40000 and MaxRequestBytes to DEC value 32768 and rebooted the server. Problem solved.

    • Proposed as answer by amentma Friday, June 27, 2014 6:52 AM
    Friday, June 27, 2014 6:50 AM
  • Solved the issue - DC and RDS server had 3 hour time difference.  Syncing time worked.
    Sunday, July 20, 2014 2:50 PM
  • This one seems to be all over the place with what's worked for whom, but in my case, "Enable-PSRemoting -force" worked for me. Thanks! I did this on a server running in Azure.
    Thursday, August 28, 2014 4:03 PM
  • Same problem, but what worked for me was deleting stored credentials for the RDVH via cmdkey.

    Monday, September 01, 2014 8:46 PM
  • Thanks rkettles, your solution worked for me !
    Tuesday, September 30, 2014 12:54 PM
  • Same here, tried everything else. Turning IPv6 off finally worked. 

    Stupid.

    Monday, October 06, 2014 11:41 PM
  • I tried everything above..."Enable-PSRemoting -force", "Set-Item WSMan:\localhost\Shell\MaxMemoryPerShellMB 1000", resetting the proxy, elevating rights, running as a domain admin rather than just local admin, I already had RD Licensing Manager & RD Session Host roles installed, I uninstalled them figuring maybe that was the issue. Still the same error message over and over again no matter what I tried.

    Despite the error text I was able to connect fine using Enter-PSSession [servername] from a remote host. What FINALLY fixed it for me, was pulling the server out of it's OU, putting it in the default "Computers" OU so almost no GPOs would apply to it, did a gpupdate /force, rebooted, and I was able to run the install without issue, so there's something wonky with one of my GP settings that breaks the RDS install.

    Tuesday, October 07, 2014 7:47 PM
  • Matthias Heinsius

    your solution worked for me!

    Thank you!

    Wednesday, October 08, 2014 8:47 AM
  • Disabling IPv6 worked for me in an Azure 2012 R2 VM.
    Wednesday, October 15, 2014 3:12 PM
  • I realize this is old, but I'd like to add my solution since I came across this just as frustrated as many others.

    Very simply, disabling IPv6 resolved the problem for me as well.
    Tuesday, November 04, 2014 1:38 PM
  • Hello,

    I did the Set-Item WSMan:\localhost\Shell\MaxMemoryPerShellMB 1000.

    But now i cant logon the server annymore.

    Can you help me?

    Wednesday, November 19, 2014 12:03 PM
  • Tami Jones solution worked for me Windows server 2012 Datacenter Edition in Windows Azure:

     - by clicking server manager.. local server and enabling "remote management"

    Wednesday, November 19, 2014 9:19 PM
  • Tried everything.

    Finally, disable IPv6 work for me.

    Wednesday, December 17, 2014 6:38 AM
  • Thanks, this worked for me too!
    Wednesday, February 25, 2015 12:29 AM
  • Try this command.

    Enable-PSRemoting -force in Powershell

    This resolves the issue on my Windows Azure Server

    Regards,

    Nandha


    Nandha Kumar J Techincal Consultant Chennai, India

    Friday, February 27, 2015 3:11 PM
  • Worked for me.  However you decided to try this solution, I gotta hand it to you.  Who woulda thought to clear the Internet proxy...??
    Friday, February 27, 2015 9:31 PM
  • After I followed all the recommendations here, I had to put the User that I used when installing the role into the group of Domain Admins first. Then things started to deploy...
    Monday, March 02, 2015 8:04 PM
  • I tried running server manager as administrator (nope), disabling Windows firewall (nope), Enable-psremoting -force (was already enabled). None of these items fixed my issue.

    Disabling IPV6 via the hotfix found here: https://support.microsoft.com/en-us/kb/929852

    ^ that resolved my issue. 

    Windows Server 2012 R2 Standard on VMWare 5.1

    Friday, April 10, 2015 7:34 PM
  • I was also installing RDP on SharePoint; temporarily removing the SPN's resolved the issue for me.
    Tuesday, April 28, 2015 12:29 PM
  • In our case it was IPv6.  A little digging revealed that we applied a GPO using Computer -> Policies -> Administrative Templates -> Windows Components -> Windows Remove Management -> WinRM Service -> Allow remote server management through WinRM

    Because we were not using IPv6 we did not add an IPv6 Filter so it simply blocked everything on that protocol.  It, of course, was working for everything else because we were using IPv4.


    Joshua Shaw

    • Proposed as answer by jchomyn Tuesday, September 22, 2015 10:18 PM
    Tuesday, May 19, 2015 9:00 PM
  • Yes. Thanks. Worked for me.
    Wednesday, June 03, 2015 8:27 PM
  • Yes. Thanks. Worked for me.
    Wednesday, June 03, 2015 8:29 PM
  • That particular item fixed it for me. 
    Monday, June 15, 2015 10:18 PM
  • I wish there was a way to move this to the top to save others trying the 100 other things first like I did! Worked great thanks

    Anthony Griggs

    Tuesday, June 16, 2015 4:19 AM
  • Hi, in my case the problem was that our DC is based on Samba 3.

    Upgrading to Samba latest version this error does not come up.

    Wednesday, June 24, 2015 3:14 PM
  • Tried all of the above - Enabling remote management under server manager/local server and a reboot and everything works without a problem
    • Edited by JL0027 Wednesday, July 15, 2015 3:39 PM
    • Proposed as answer by DWill23 Thursday, November 26, 2015 8:16 PM
    Monday, July 13, 2015 6:52 PM
  • My systems engineer found that my issue was caused by a System variable that was set incorrectly. The Path variable had been cleared, which was keeping Powershell Remoting from working correctly. He copied the variables from another server, and it is now working correctly. 
    Tuesday, August 25, 2015 5:20 PM
  • Tried everything else on this page but none worked except this.

    Thanks amentma !

    Tuesday, September 01, 2015 6:57 AM
  • In our case it was IPv6.  A little digging revealed that we applied a GPO using Computer -> Policies -> Administrative Templates -> Windows Components -> Windows Remove Management -> WinRM Service -> Allow remote server management through WinRM

    Because we were not using IPv6 we did not add an IPv6 Filter so it simply blocked everything on that protocol.  It, of course, was working for everything else because we were using IPv4.


    Joshua Shaw

    I can validate this solution. I was having the issue with a site RDS deployment, I went in and put an IPv6 wildcard filter in place and the problem cleared up following a GPUpdate.  At least in my circumstance it was directly related to this.
    Monday, October 05, 2015 1:51 PM
  • If there is a GPO setting on the network that affects the server you are trying to install RDS on and that GPO controls WinRM listening ports and is incorrectly configured then you will get this error.

    Run winrm enumerate winrm/config/listener on the target server and if ListeningOn = null is returned then check GPO on this box with gpresult /h result.html & result.html. Search this GPO output for Windows Components/Windows Remote Management (WinRM)/WinRM Service and IPv4 Filter and IPv6 Filter need to contain * or an IP range that includes this server. If the value is blank or wrong IP range then you will get the original posters error message!

    This took a long time to find and fix!


    Brian Reid C7 Solutions Ltd (www.c7solutions.com)

    • Proposed as answer by MQUAL Tuesday, December 29, 2015 9:46 PM
    Tuesday, November 17, 2015 2:34 PM
  • Thank you!!

    It's always the simplest thing :/

    • Edited by snowbot85 Wednesday, November 25, 2015 12:17 PM
    Wednesday, November 25, 2015 12:16 PM
  • My server was in the incorrect OU.  Changing the policy fixed the issue.  Did not track down which settings caused the problem but it may have been software restriction policy being enabled.
    PSRemoting was not the problem.  I could remote PS. 
    Tuesday, December 29, 2015 9:51 PM
  • Disabling IPv6 on ALL network adapters worked for me.

    Tuesday, January 12, 2016 9:45 AM
  • Hi, 

    im wonderering how you did youre hyperv scenario because when i try evrything in hyper v then i get an error 

    hardware virtualization is not suported.

    Sunday, February 07, 2016 10:37 AM
  • In Server Manager/Remote Management was already enabled.  My fix was to disable and then re-enable Remote Management.  I was then able to reinstall RDS.

    • Edited by morriskr Wednesday, February 10, 2016 7:15 PM
    Wednesday, February 10, 2016 7:13 PM
  • Tami Jones solution worked for me Windows server 2012 Datacenter Edition in Windows Azure:

     - by clicking server manager.. local server and enabling "remote management"

    This worked for me, thank you!
    Monday, March 07, 2016 11:07 PM
  • Same for me.  Disabling ipv6 did the trick.
    Tuesday, March 08, 2016 10:34 PM
  • All the Gibber Jabber and Speculations in this Thread and your Resolution was the Correct One.

    Just thought you should know that.

    Sunday, May 22, 2016 5:50 PM
  • use "net time /domain:*** /set" and problem fixed
    • Proposed as answer by BaDZoB Wednesday, August 31, 2016 1:04 PM
    Tuesday, June 07, 2016 10:05 AM
  • I tried all of the suggestions above with no success.  I was trying to use New-RDSessionDeployment against a remote Server 2012 R2 instance, from a Win10 or Win8 client.  The exact error I got was:

    New-PSSession : [localhost] Connecting to remote server localhost failed with the 
    following error message : The client cannot connect to the destination specified in 
    the request. Verify that the service on the destination is running and is accepting 
    requests. Consult the logs and documentation for the WS-Management service running 
    on the destination, most commonly IIS or WinRM. If the destination is the WinRM 
    service, run the following command on the destination to analyze and configure the 
    WinRM service: "winrm quickconfig". For more information, see the 
    about_Remote_Troubleshooting Help topic.
    At line:1 char:23
    +         $M3PSession = New-PSSession -ConfigurationName Microsoft.Windows.ServerM 
    ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRu 
       nspace) [New-PSSession], PSRemotingTransportException
        + FullyQualifiedErrorId : CannotConnect,PSSessionOpenFailed
    I finally used a test Server 2012 R2 instance as my client and it succeeded.  Evidently the New-RDSessionDeployment cmdlet invokes the module Windows\System32\WindowsPowerShell\v1.0\Modules\RemoteDesktop\Deployment.psm1 behind the scenes, which initiates a New-PSSession, but somehow it is incompatible with at least Win8 and Win10 clients.


    Wednesday, July 13, 2016 2:55 PM
  • Turning IPV6 Off on the NIC worked for me:

    https://rlevchenko.com/2015/05/22/rds-unable-to-connect-to-the-server-by-using-windows-powershell-remoting/

    Bjorn

    Tuesday, August 09, 2016 8:18 AM
  • This worked for me. Thank you MrezaRrad.
    Wednesday, August 31, 2016 1:04 PM
  • that worked for me partially.

    the other way I did, is too add localhost, and 127.0.0.1, and FQDN of the server to Internet explorer proxy bypass list

    then: netsh winhttp import proxy source=ie

    and wizard accepted that.

    Wednesday, September 21, 2016 7:35 PM
  • had same issue fixed it by
    clearing the proxy

    netsh winhttp reset proxy

    worked for me

    Thanks you Very Much this resolved my problem.  wow.

    Monday, November 07, 2016 7:08 PM
  • I just had this same issue. I couldn't understand why it was giving me this error as it was being installed onto the local host.

    When I ran new-pssession from powershell it told me there was a time difference between the client (rds server) and the server (dc).

    Corrected the time and it worked!

    • Proposed as answer by salaberrios Saturday, January 14, 2017 3:44 AM
    Friday, November 11, 2016 2:09 PM
  • My HyperV server somehow dropped the static IP I set up to communication with AD/DC. I input the correct IP and it worked. The server that could not be connected to was off the grid and could not be resolved by the host.
    Saturday, January 14, 2017 3:46 AM
  • Thank you so much for this answer.  I have wasted 2 days trying to find a solution, this worked perfectly.

    Wednesday, January 18, 2017 9:31 PM
  • Old topic but I had the same issue on a fresh 2016 install and managed to resolve my problems by disabling the management nick during the install. So add that to the list of possible solutions.
    Tuesday, February 14, 2017 3:21 PM
  • Ran into this today, if KB3000850 was installed it was causing "Object reference not set to an instance of an object" errors when executing remote PS commands. Installing KB3062960 and rebooting resolved it and allowed me to install RDS role.
    Monday, March 27, 2017 4:30 PM
  • I had this problem too.  The solution for me was to update the DNS servers.  On this particular machine they were set to public DNS servers.  Once I updated them to use the Active Directory domain DNS servers, the wizard finished without this error.

    -Chad

    Thursday, September 14, 2017 12:14 AM
  • Having the same issue on Server 2016 and worked through each of the ideas in this thread. The  item that has this working now on my server was a change to Policy to allow through Win RM. Note that I did implement most of the suggestions here in this thread before getting to the below fix. Firewall turned off, IPv6 disabled, memory settings.

    Registry settings: 

    HKLM\Software\Policies\Microsoft\Windows\WinRM\Service!AllowAutoConfig = 1

    HKLM\Software\Policies\Microsoft\Windows\WinRM\Service!IPv4Filter = *

    HKLM\Software\Policies\Microsoft\Windows\WinRM\Service!IPv6Filter= *

    Reboot

    On my server the IPv4Filter contained subnets that the Server was not in at that time.




    • Edited by Tehxion Friday, September 29, 2017 5:45 PM
    Friday, September 29, 2017 5:40 PM
  • I had tried all above, However we are still facing issue while installing RD connection broker on server 2016 . Kindly guide me on this ..

    Thanks, Sajjan T

    Tuesday, October 10, 2017 2:39 PM
  • We Did not found below.

    Registry settings: 

    HKLM\Software\Policies\Microsoft\Windows\WinRM\Service!AllowAutoConfig = 1

    HKLM\Software\Policies\Microsoft\Windows\WinRM\Service!IPv4Filter = *

    HKLM\Software\Policies\Microsoft\Windows\WinRM\Service!IPv6Filter= *



    Thanks, Sajjan T

    Tuesday, October 10, 2017 2:40 PM
  • That worked for me 2

    Justin

    Tuesday, December 12, 2017 5:54 PM
  • Same error in Windows 2016 for me, in my case it seems to be a hostname problem at some point:

    I reinstalled Windows 2016 and only configured a vmxnet 3 interface by installing VMWare Tools and giving it an IPv4 address, nothing else. Rebooted. The RDS installation wizard passes the compatibility check. I didn't install the RDS services and just renamed the host to what I want it to be. Restarted. The RDS installation wizard does NOT pass compatibility check anymore: "Unable to connect to the server by using Windows Powershell Remoting". Seems to be a problem there.

    Friday, February 23, 2018 1:16 PM
  • THANKS!!!! @Tami Jones you saved my day.

    In my case I had to disable remote management and then re-enable it.

    Thanks MS for keeping all of us employed with these silly bugs  


    Tuesday, April 17, 2018 10:29 AM
  • had same issue fixed it by
    clearing the proxy

    netsh winhttp reset proxy

    worked for me

    Nice solution for few hour struggle! Thank you!
    Tuesday, April 17, 2018 12:14 PM
  • Hey Guys,

    I'm quite stuck here, and hopefully you can come up with some nice ideas on this matter. I've got a VM deployed in MS Azure (Type: D2_V2) and I'd like to deploy Remote Desktop Services onto it.

    All 3 components - Connection Broker, Session Host, Web access would be the very same server as it would be enough for us.

    When I try to run the deployment from the server manager, it gives the well known "Unable to connect to the server by using Windows Powershell Remoting" after selecting the connection broker server.

    I've set up literally everything as it was mentioned in this thread (actually this thread helped a lot in my previous attempt on RDS and it worked, although that server was not in Azure but our company on-prem DC.)

    The funniest thing is, that I am able to connect to the server with PS Remoting from my laptop, and running the PS command for "New-SessionDeployment...." gives the same error as doing it from the server manager..

    Do you have any idea why this can happen? For me it seems PS remoting is obviously  working on the server and this is driving me crazy..:\

    Thursday, April 19, 2018 4:34 PM
  • I am actually having the exact same issue.

    Running Hyper-V on hostmachine.
    Then running the server as VM on the Hyper-V, installing RDS fails, over and over again....

    Getting pretty angry here... I wanna throw stuff now.


    Retail Systems Specialist

    Tuesday, April 24, 2018 12:54 PM
  • I've been struggling with this issue on a 2016 server.

    In my case, I was using a Hyper-V Server host with a 2016 Server running as a guest.  The problem was being caused by the time on the 2016 Server being out by an hour compared to the DC.  This was happening because the Hyper-V Server is not part of the domain and had an incorrect time.

    I guess this could be fixed by adding the Hyper-V server to the domain to sync its time from the main DC, or by setting the time manually.

    However, I ended up disabling the Time Syncronization Intergration for the 2016 VM using Powershell.

    Disable-VMIntegrationService –Name "Time Syncronization" -VMName <VM Name>

    This then allowed the 2016 Server VM to get its time from the DC instead.

    • Proposed as answer by HyperS61 Wednesday, May 30, 2018 2:28 PM
    • Unproposed as answer by HyperS61 Wednesday, May 30, 2018 2:32 PM
    Wednesday, May 30, 2018 2:27 PM