locked
Error 1020 on some Public Folders during replication RRS feed

  • Question

  • Slowly going through our Public Folder hierarchy adding our new Exchange 2010 server to the replica list of our current Exchange 2003 servers Public Folders.

     

    I have around half a dozen instances of:

     

    The store driver couldn't deliver the public folder replication message "Folder Content Backfill Response (MAIL01-IS@domain.com" because the following error occurred: Property: [0x6751000b] , PropertyErrorCode: AccessDenied, PropertyErrorDescription: ..

     

    The store driver couldn't deliver the public folder replication message "Folder Content Backfill Response (MAIL01-IS@domain.com)" because the following error occurred: Property validation failed. Property = [{00020329-0000-0000-c000-000000000046}:'Keywords'] Categories

    Error = Element 0 in the multivalue property is invalid...

     

    Where mail01 is the Exchange 2003 server.

     

    I don’t see any way of telling which, if any, folder/item the issue is with – and Google isn’t turning up many instances of that 0x6751000b error.

     

    Just wondered if anyone has any suggestions?

     

    I’ve used ExFolder to add the replicas, I did wonder if it’s worth doing a DACL/ACL check too?

     

    Thanks,

    Paul

    Wednesday, June 1, 2011 5:42 PM

Answers

  • Use the article below to enable pipeline tracing. Property validation is done to ensure corrupted items are not replicated such as leading or trailing white spaces which is a common one.

     

    For instance, in a few cases we've seen this output in the TXT file:

     

    Microsoft.Exchange.Data.Storage.PropertyValidationException: Property validation failed. Property = [{00020329-0000-0000-c000-000000000046}:'Keywords'] Categories
    Error = Element 0 in the multivalue property is invalid..

     

    In this case it's complaining about the Categories property. This will happen if the public folder in question contains items on which the Categories property is set to be blank - such as with a single space - instead of truly being empty. You can see this by going into Outlook and choosing to view items by Category. You should find that there are two different sets of items with "None". To correct the problem, simply clear the Category on all of the "None" items using Outlook. You may have to set them to some other category and then set them back to None. Once the Categories property is truly clear, you'll only have one set of items that show "None", and the items will replicate successfully.

     

    Public Folder Replication Troubleshooting - Part 4: Exchange Server 2007 tips

    http://blogs.technet.com/b/exchange/archive/2008/01/10/3404629.aspx


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by Novak Wu Monday, June 13, 2011 1:33 AM
    Wednesday, June 1, 2011 7:11 PM