Remote Desktop fails to connect after upgrade to Windows 8.1


  • Remote Desktop from home to office using RD Gateway does not work after upgrade from Windows 8.  When attempting to connect, the small Remote Desktop Connection progress window appears for about 1 second, then disappears without error message.  No information in Event Viewer other than Security log indicating "A logon was atempted using explicit credentials".
    Friday, November 22, 2013 1:18 AM


All replies

  • Hi,

    Sorry for my dilatory reply.  Can you ping through home PC to Office? Here are some reasons you may encounter and Remote Desktop failed.


    1. Not enough memory.

    2. Network  failure.

    3. The remote computer can not be found.

    I would like to suggest you follow the solution of the links below to fix your problem for test.

    Roger Lu
    TechNet Community Support

    Thursday, November 28, 2013 3:58 PM
  • The problem computer has 16 GB of memory installed on a desktop computer with an Intel Core i7-3770 cpu running Windows 8.1 Pro with Media Center.  I have tried running RDC after a fresh reboot without success.  I have no special programs installed that use significant memory and Task Manager shows 12% memory usage (after starting email and web browser, which weren't running when RDC was unsuccessfully).

    The problem computer has no other Internet (email, web access) or local network issues; connectivity is fine.  I have just verified that I can successfully connect to the remote office computer using RDC on another home computer that runs Windows XP. 

    RDC worked fine under Windows 8.0 Pro with Media Center before I updated to Windows 8.1 Pro with Media Center .  Nothing else has changed on my network firewall or the office firewall.  The only variable is the upgrade from Windows 8.0 to Windows 8.1.

    Thursday, December 05, 2013 6:07 PM
  • I have the same problem with an 8.1 remote machine using Remote Web Access followed by RDP to logon to an office desktop behind an SBS server. This is a bug in the remote desktop login system. Try the following work around...

    When the username and password dialogue appears, click the tickbox to remember your credentials. Then enter your credentials and click to login. Your login will fail again but when you get it back it will have your username pre-entered and will accept your password and connect. Next time you try to connect your username and password will both have been remembered and you will be connected automatically. 

    This is not an acceptable solution: remembered credentials mean that a thief gets access to your office system when he nicks your remote machine. Sort this out Microsft.

    Ed Form

    • Marked as answer by dclou Thursday, September 11, 2014 1:16 AM
    • Unmarked as answer by dclou Thursday, September 11, 2014 1:16 AM
    Tuesday, September 09, 2014 10:03 PM
  • I finally discovered a solution a few weeks ago.

    The issue can be fixed by editing the registry key:
    HKEY_CURRENT_USER\ Software\ Microsoft\ Terminal Server Gateway\ Messages\ <Domain>\ <USERNAME>\ UserPreferenceOption.
    Change value to 0

    The solution is discussed at this link:


    • Marked as answer by dclou Thursday, September 11, 2014 1:20 AM
    Thursday, September 11, 2014 1:20 AM