none
Project 2010: Node Consistency Error in ULS logs when trying to change a resource's base calendar RRS feed

  • Question

  • This is happening with three enterprise resources within a project instance: When the resource is edited in Project Web App, it seems like I can change the resource base calendar.  The related queue jobs process without any error.  However, when I view the resources in the Resource Center, the Base Calendar attribute is blank.

    When I check out the resources in Project Professional, the error message "An internal error occurred" appears after I try to save the base calendar change.

    The ULS error for each resource is:  "Node Consistency Error: Failed to load Calendar. Uid=<resource_uid>"

    Any suggestions to fix this would be greatly appreciated.  Thanks.

    Wednesday, October 15, 2014 3:34 PM

All replies

  • Hi,

    Maybe you already tried this but ... have you looked into doing an administrative restore of your Enterprise Resources and Calendars? If not I would take an administrative backup and then try a restore (maybe try that initially that in a test environment?)

    Hope this helps

    Paul

    Friday, October 17, 2014 2:04 PM
  • Hello Paul,

    Thanks for your reply.  I did try an Administrative Backup/Restore of the Enterprise Resources and Calendars.  That did not solve the problem. 

    --Adrienne

    Friday, October 17, 2014 5:10 PM
  • Silly question:

    Have you tried just flat out deleting the 3 resources, and re-adding them?  It could be the GUID that is associated with them.  Since its only affecting a small number of resources this should be possible...

    OR - add resources with the same name - unless the 3 resources you reference are utilized in several projects, and then use the new resources with the same name, then delete the old resources.

    Are there any other errors in the queue manager at the time of the successes?

    Friday, October 17, 2014 6:21 PM
  • I am not 100% sure what the error message means. But i would try and delete all Calendar Exceptions from the resources.

    It sounds like there could be an overlapping exception between the calendar and the resource calendar (PS should of cause be able to handle this, but you never know).


    http://technicaltrix.blogspot.dk/

    Sunday, October 19, 2014 1:27 AM
  • Are you using an type of load balancing?  Can you turn of load balancing or use the specific node name when loading calendars?A

    Also check your AMA settings if using load balancing and the show session state services are working properly

    Cheers!


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries


    Sunday, October 19, 2014 3:56 PM
    Moderator
  • The resources in question are used in several projects.  There are no other error messages in the queue manager.
    Tuesday, October 21, 2014 1:40 PM
  • I tried deleting all the calendar exceptions (in a backed up copy of the Production site) and that didn't solve the problem.
    Tuesday, October 21, 2014 1:41 PM
  • How do you use the specific node name while loading calendars?

    Session state services are working properly.

    Tuesday, October 21, 2014 1:42 PM
  • Hi

    we have the same problem with four resources (Project Server 2010), by saving in Professional 2010 I get Internal Error.

    the same thing with the callender, in the settings there is Basic one, but if I query the resource table, the callender is NULL. How did you solve the problem? deleting the resources would require reopening and republishing many projects.

    Thanx! It would be great to find out! 


    From Project Techcenter


    Saturday, April 23, 2016 5:20 PM