none
Auto-Proxy GPO setting not working on Windows 8.1 systems

    Question

  • I've got an Auto-Proxy GPO setting that points my clients to use a proxy PAC file that is located on an internal server. I have both Windows 7 and Windows 8.1 systems that use IE11 and both types of systems use the same GPO for this setting. The Windows 7 systems are getting the PAC location but the Windows 8.1 systems do not.  Any idea on what I might be missing to get the Windows 8.1 systems to see it? 
    Tuesday, November 29, 2016 8:36 PM

Answers

  • I disabled the fast startup in the power settings but no difference in the GPO. We finally pegged it down to faulty WMI processing. Got rid of that and the machines are getting the policy now. Interesting thing though is that the proxy URL starts with https but when I run GPRESULT it shows the URL at http.  I'm thinking that I haven't allowed enough time for DC replication so I'm going to monitor it.  Right now http redirects to https so no problems.   
    Thursday, December 08, 2016 10:19 PM

All replies

  • Hi,
    Before we go further, let us check if the GPO is applied to windows 8.1 client, you could run gpresult /h command to view the report and see the details.
    In addition, you could validate if the gpo is working via registry which is located under: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings and verify the AutoConfigURL entry exist and have the defined PAC file on the windows 8.1 client. Even, you could manually set this registry and see if it works.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, November 30, 2016 6:40 AM
    Moderator
  • The setting is in the registry but is not showing up in GPRESULT.  Trying to run GPRESULT reveals several errors in the computer and user policy that don't appear on the Windows 7 systems.  A hard restart and then a GPRESULT again will show that these errors have disappeared.  I say "hard restart" because restarting the Win8.1 system when it is this state will take a few hours to overnight to complete.  Below are the errors in computer policy.  There is one in user policy and it is Event ID 7320, Error: Bandwidth estimation failure: Failed to query Intranet capability. Error code 0x15.


    Wednesday, November 30, 2016 4:57 PM
  • # for hex 0x54b / decimal 1355 :
      ERROR_NO_SUCH_DOMAIN                                          winerror.h
    # The specified domain either does not exist or could not be
    # contacted.
    # 1 matches found for "0x54b"
     
    # for hex 0x6ba / decimal 1722 :
      ecLockTimedOut                                                ec.h
      RPC_S_SERVER_UNAVAILABLE                                      winerror.h
    # The RPC server is unavailable.
    # 2 matches found for "0x6ba"
     
    Disable the hybrid shutdown feature in Windows - the computer is up and running tooo fast, even before network connectivity is established. Tons of threads about that issue here...
     
     
    Thursday, December 01, 2016 9:22 AM
  • Hi,

    I am checking how the issue going, if you still have any questions, please feel free to contact us.

    And if the replies as above are helpful, we would appreciate you to mark them as answers, and if you resolve it using your own solution, please share your experience and solution here. It will be greatly helpful to others who have the same question.

    Appreciate for your feedback.

    Best regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, December 06, 2016 9:33 AM
    Moderator
  • I disabled the fast startup in the power settings but no difference in the GPO. We finally pegged it down to faulty WMI processing. Got rid of that and the machines are getting the policy now. Interesting thing though is that the proxy URL starts with https but when I run GPRESULT it shows the URL at http.  I'm thinking that I haven't allowed enough time for DC replication so I'm going to monitor it.  Right now http redirects to https so no problems.   
    Thursday, December 08, 2016 10:19 PM
  • Hi,
    Appreciate for your share and it will be greatly helpful to others who have the same question. If you still have any questions, please feel free to contact us.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, December 12, 2016 1:56 AM
    Moderator