Oracle just broke UAG 2010 with Java 7u51


  • Oracle made a security update to the Java client that effectively breaks all existing Java web apps. This includes the UAG client applets for non-IE browsers. I have been trying to get UAG working on a MacBook Pro in Safari and getting a Java error.

    security: Missing Codebase manifest attribute for:
    security: Missing Application-Library-Allowable-Codebase manifest attribute for:

    Looking into this error I came upon: New security requirements for RIAs in 7u51 (January 2014)

    You are required to sign all RIAs (Applets and Web Start applications).
    You are required to set the "Permissions" attribute within the Manifest.
    Your application will be affected if it uses Java started through a web browser. Your application will not be affected if it runs anywhere outside of a web browser.

    Is there current a patch or workaround to address this?

    Wednesday, January 29, 2014 8:36 PM

All replies

  • We are getting the same error with our Mac clients.

    Is there a fix for this?

    Thursday, January 30, 2014 8:12 AM
  • For some additional information, I've tried using old versions of Java 1.7 and run into additional errors:

    7u45 and 7u20 gave:

    security: LiveConnect (JavaScript) blocked due to security settings.
    security: LiveConnect (JavaScript) blocked due to security settings.
    security: LiveConnect (JavaScript) blocked due to security settings.
    security: LiveConnect (JavaScript) blocked due to security settings.

    This describes the cause of that error

    Setting security to Medium in Java, with Safari running in 32-bit, I get the following Java console error:

    Verifying agent signature. 
    Fatal error: signature does not exist!

    This is described, with a proposed solution in one of Ben Ari's blog posts.

    The solution doesn't work though, as it appears even 32-bit Safari launches a 64-bit version of the Java applet. It doesn't even appear there is a 32-bit version of Java 7 available for OSX.

    Not sure if this will help anyone, but at least you can find some information and what I've tried. Maybe we'll discover a work around. If I could find a 32-bit version of Java for OSX I think I could get it working.

    • Edited by AHC Admin Thursday, January 30, 2014 3:08 PM
    Thursday, January 30, 2014 2:44 PM
  • The only version of Java SE 6 for Mac that appears to exist on the entire Internet is: 32-bit Java SE 6 for OSX

    Unfortunately, that explicitly disables the web plugin. I think we're hopeless unless Microsoft updates the applet to adhere to current Java security standards, and releases a 64-bit client while they're at it.

    Not sure if MS is even going to continue supporting UAG though.

    • Edited by AHC Admin Thursday, January 30, 2014 3:09 PM
    Thursday, January 30, 2014 3:01 PM
  • I have logged a support call with Microsoft regarding this issue.

    They will look into it and get back to me.

    Meanwhile, I found this possible workaround on the Oracle website.

    Thursday, January 30, 2014 3:17 PM
  • The workaround appears to be Windows specific, I don't see any equivalent way to do this on OSX.
    Friday, January 31, 2014 7:56 PM
  • Hi Martin,

    We also experiencing exact same issue without a resolution.

    Do you got any positive feedback from Microsoft Support for this problem? any fix?

    the work around given in Java site is not helpful.



    Monday, August 04, 2014 1:50 PM