locked
Word 2010 is updating fields before printing when option is not checked RRS feed

  • Question

  • When I go to File tab and then choose Print, the fields are updating even though I have that option unchecked under Display, and some of the page numbers are updating incorrectly. It seems the "update fields" it is running here is different than the one when I select everything and then press F9.
    Friday, November 2, 2012 1:20 PM

Answers

  • Thanks Stefan...actually that's what I had to do. I found the locking advice somewhere when I was searching for a solution. I accepted all changes, saved, Ctrl+A to select all, Ctrl+F11 to lock all fields, then I printed to PDF and exited the document without saving again, so the fields were not saved as locked.
    • Marked as answer by Jaynet Zhang Tuesday, November 6, 2012 6:02 AM
    Sunday, November 4, 2012 12:28 AM

All replies

  • Some fields update when Word repaginates, which happens when you print. For the rules that apply, take a look at http://support.microsoft.com/kb/211629/en-us/ (Which fields are updated when you open, repaginate, or print document).
     
    By the way, what is the specific problem you are seeing with page numbering? What are the symptoms?

    Stefan Blom, Microsoft Word MVP
    Friday, November 2, 2012 7:05 PM
  • Before I go to print (I'm planning to print to PDF), I update all fields by selecting all and then using F9. Then I accept all change tracking. When I go to File and then choose Print on the left side, I can see that there are now tracked changes in the preview area on the right. When I go back to Home to look at the document and step through the newly tracked changes, I can see that some of my cross-referenced page numbers (as well as one TOC page number) are now changed to the wrong pages.

    So there seem like two bugs. First, that these fields updated at all when I've unchecked File, Options, Display, Update fields before printing. Second, that some page numbers are updated to incorrect values.

    Friday, November 2, 2012 10:17 PM
  • If you have track changes 'on' when you update fields, the updated fields will constitute changes. And, as Stefan said, repagination will cause PAGE fields and the like to update, regardless of the 'update fields' setting.


    Cheers
    Paul Edstein
    [MS MVP - Word]

    Saturday, November 3, 2012 3:57 AM
  • "macropod [MVP]" wrote in message news:5373dc2b-4634-46d1-b571-8b30bd966f6f@communitybridge.codeplex.com...
    If you have track changes 'on' when you update fields, the updated fields will constitute changes.
    [---]
     
     
    Indeed, fields won’t “behave” until you have accepted (or rejected) all changes and turned off Track Changes.

    Stefan Blom, Microsoft Word MVP
    Saturday, November 3, 2012 1:35 PM
  • I did accept all changes before I went to Print. I didn't turn off Track Changes because I didn't want or expect any changes in between accepting all of them and going to the Print page. Is there any way to prevent repagination at that point? And why would it switch to a completely different (and wrong) page rather than the one that F9 produces?
    Saturday, November 3, 2012 2:58 PM
  • "Tiffany Bracco" wrote in message news:2872009c-ef20-431a-bdf9-8024895efcbd@communitybridge.codeplex.com...
    I did accept all changes before I went to Print. I didn't turn off Track Changes because I didn't want or expect any changes in between accepting all of them and going to the Print page. Is there any way to prevent repagination at that point? And why would it switch to a completely different (and wrong) page rather than the one that F9 produces?

           
                 
    No, repagination can’t be prevented when you print.
                 
    You may find locking (some) fields to be helpful. To lock fields in the selection, use Ctrl+F11. To unlock selected fields, press Shift+Ctrl+F11.

    Stefan Blom, Microsoft Word MVP
    Saturday, November 3, 2012 5:17 PM
  • Thanks Stefan...actually that's what I had to do. I found the locking advice somewhere when I was searching for a solution. I accepted all changes, saved, Ctrl+A to select all, Ctrl+F11 to lock all fields, then I printed to PDF and exited the document without saving again, so the fields were not saved as locked.
    • Marked as answer by Jaynet Zhang Tuesday, November 6, 2012 6:02 AM
    Sunday, November 4, 2012 12:28 AM
  • Thanks Stefan...actually that's what I had to do. I found the locking advice somewhere when I was searching for a solution. I accepted all changes, saved, Ctrl+A to select all, Ctrl+F11 to lock all fields, then I printed to PDF and exited the document without saving again, so the fields were not saved as locked.


    You are welcome. Thanks for the follow-up.


    Stefan Blom, Microsoft Word MVP

    Sunday, November 4, 2012 11:01 AM