locked
"A program is trying to access e-mail addresses you have stored in Outlook” message" Need a workaround that doesn’t depend on third-party applications or components. RRS feed

  • Question

  •  

    Application ‘A’ communicates with outlook to get hold of email addresses and book appointments in shared calendars.

    Every time the application tries to communicate with outlook the user gets the “A program is trying to access e-mail addresses you have stored in Outlook” message.

    Leaving this mechanism in place is not an option, as most users will automatically press no. Even if they don’t, they can only allow for a very short period of time.

     

    I am looking for some way to disable or bypass this security feature completely, without using exchange or group policies.

    The application is running inside a virtual bubble together with outlook 2003 (The bubble is reacreated every time the user starts the application and the user is only able to see Application A which is running in seamless mode).

    I can feed registry files to the virtual environment as its starts, and it would therefore be preferable if I can solve this problem in the registry somewhere.

    The bubble is in a secure environment and downgrading the security inside it will have no impact on security.

     

    Several people suggest disableing the security prompt by setting/creating a REG_DWORD registry entry CheckAdminSettings = 1 located at HKEY_CURRENT_USER\Software\Policies\Microsoft\Security.

    I have tried this but it had absolutely no effect. I am rather new to this, so I really don’t know how these security features are managed.

     

     

    Anyone know of a way I can sniff the GUID of the process trying to communicate with outlook?

    I am not certain, but I believe it is Windows scripting host.

     

    Monday, July 4, 2011 11:55 AM

Answers

All replies

  • 1. If you dont want to use Exch, which you can't use anyway then you should try to ask in the Outlook forum - http://social.technet.microsoft.com/Forums/en-US/outlook/threads

    2. If a GPO can be used and you dont want to then I guess you will have to use a reg key or a 3rd party Util - here is a free one which you can use http://www.mapilab.com/outlook/security/

    3. You havent mentioned which Outlook version but the point 2 shoyuld work. Failing that post in the Outlook forum.


    Sukh
    • Marked as answer by Gavin-Zhang Monday, July 18, 2011 2:47 AM
    Monday, July 4, 2011 12:54 PM
  • I've created a seperate thread in the forum you suggested. Thanks for that.

    We are using outlook 2003, and using thirdparty applications is not an option. I need to find some way to fix this inside the bubble.

    Monday, July 4, 2011 1:29 PM
  • Try executing the same piece of code from OUTLOOK 2007 and verify.

    i believe the OUTLOOK OBJECT MODEL GUARD is throwing the popup.


    Sumanth G
    Monday, July 4, 2011 1:30 PM
  • See: http://www.slipstick.com/outlook/esecup/admin.htm

     

    When you use that registry setting and set it to 1, it tells Outlook to look for the Security Settings public folder. You can use that folder to disable those prompts.

     

     

    Monday, July 4, 2011 1:58 PM