locked
ServiceLevel Dashboard 2.0 managment pack import fails on SCOM 2007 R2 RRS feed

  • Question

  • Microsoft.EnterpriseServiceMonitoring.ServiceLevelDashboard.R2.mp importing failes on SCOM 2007 R2 with the error "The dependencies for this management pack cannot be located". 

    Missing dependent managment pack "Microsoft.SystemCenter.Library Version 6.1.7043.0". I could not find this managment pack in the microsoft downlaod site. Please help

    Sajan 
    Tuesday, September 15, 2009 11:22 AM

Answers

  • Sajan,

    looks to me like your upgrade to R2 didn't complete succesfully? In my environment I can see that (almost) all core libraries are at version 6.1.7221.0 (about 20 of them). I upgraded from SCOM 2007 SP1 to R2. These core packs are not available seperately as far as I know, since the changes to the SCOM environment from SP1 to R2 are quite extensive, and just importing these packs seperately wouldnt change your DB's as much as would be needed.

    If need be I can provide you with the core .mp files which are in my installation folder, but as said before, I don't know if just the importing of these mps wont bring your entire SCOM environment come crashing down...

    Let me know if you want these .7221 mps from me!

    regards,
    Pieter
    Wednesday, September 16, 2009 8:56 AM

All replies

  • Sajan,

    I just succesfully installed SLDv2. (after some issues, but that aside).

    I don't have this MP in my installed list. If I check the dependencies on my installed SLD mp, it only mentions the System Center Core Library, with version  6.1.7221.0 (this is the default version of all R2 release mp's.).

    What version is your Core library, is it at R2 level indeed?

    I have the unsealed version of the mp (needed it for my own problems, see my thread) and it indeed mentions this dependency:

    <Name>Service Level Dashboard for System Center Operations Manager 2007 R2</Name>
        <References>
          <Reference Alias="SystemCenter">
            <ID>Microsoft.SystemCenter.Library</ID>
            <Version>6.1.7043.0</Version>
            <PublicKeyToken>31bf3856ad364e35</PublicKeyToken>
          </Reference>
        </References>

    but otherwise it didn't cause any troubles when installing on my environment. You can try to install it by unsealing the pack, removing the dependency and resealing the pack... just as a test of course.

    As far as I can see, the mp tries to run several SQL queries and registers itself with SCOM, both can be done manually if need be.

    I hope this helps!

    with kind regards, Pieter


    Tuesday, September 15, 2009 2:16 PM
  • Hi Pieter,

    Thank for the reply.

    Version of the core library installed is 6.1.6407.0. I am not able to find the MP version 6.1.7221.0 in my SCOM 2007 R2. If the problem is happening because of the managment pack, how do I get the latest MP.

    Regards,
    Sajan
    Wednesday, September 16, 2009 8:45 AM
  • Sajan,

    looks to me like your upgrade to R2 didn't complete succesfully? In my environment I can see that (almost) all core libraries are at version 6.1.7221.0 (about 20 of them). I upgraded from SCOM 2007 SP1 to R2. These core packs are not available seperately as far as I know, since the changes to the SCOM environment from SP1 to R2 are quite extensive, and just importing these packs seperately wouldnt change your DB's as much as would be needed.

    If need be I can provide you with the core .mp files which are in my installation folder, but as said before, I don't know if just the importing of these mps wont bring your entire SCOM environment come crashing down...

    Let me know if you want these .7221 mps from me!

    regards,
    Pieter
    Wednesday, September 16, 2009 8:56 AM
  • Hi Pieter,

    Sorry for the late reply.. I was on leave.

    I was using SCOM R2 Beta version.  The problem resolved after imprting the MP of SCOM R2 evaluation version.

    Thank you for your help...

    Regards,
    Sajan
    Wednesday, September 30, 2009 11:50 AM