Cannot download certificate because domain is not accessible RRS feed

  • Question

  • Dear All & Jeff,

    If anyone face this problem please let me know. Environment has Polycom CX with win2008 Environment but they have a Branch which is running as an ADC (DNS, DHCP) but it is win2003 32bit, Lync client connecting properly. but CX600 not connecting its says "Cannot download certificate because domain is not accessible" . 

    How can i solve this.


    Madushka Dias : MCITP(Lync Server 2010 Administrator) & MCTS - Active Directory) - | Live - | If got your answer don't forget to Rate as an Answer
    • Moved by Noya LauModerator Saturday, February 4, 2012 5:53 AM (From:Enterprise Voice and Telephony)
    Monday, January 23, 2012 2:17 PM

All replies

  • Connect the CX600 to a PC, with the Lync client installed, using a USB cable. All the authentication and server discovery will happen via the Lync client on the PC.

    If this is not possible then I would check that if you are Voice VLANs for the CX600 that you do not have a configuration error.

    Tuesday, January 24, 2012 6:28 PM
  • How about if you use domain FQDN instead of NETBIOS name? i.e. enter user name domain.local\username instead of domain\username

    Does that work?

    If FQDN works, then you might need to check and search for "domain fqdn" keyword for the NETBIOS configuration
    Tuesday, January 24, 2012 8:37 PM
  • Dear Friends,

    i tried by adding to through USB, and also domain\username , but have to try domain.local\username.

    Madushka Dias : MCITP(Lync Server 2010 Administrator) & MCTS - Active Directory) - | Live - | If got your answer don't forget to Rate as an Answer
    Wednesday, January 25, 2012 3:49 AM
  • Hi Madushka,

    Here is another similar post for reference.

    And please also check if there is any missing during your deployment. You can follow Jeff’s steps.

    Hope helps.

    Noya Liu

    TechNet Community Support

    Saturday, February 4, 2012 5:56 AM
  • Using domain.local instead of just domain fixed the issue for me: Lync 2013 with Exchange 2010.

    Monday, July 15, 2013 4:15 PM
  • Hello,

    We 5 sites and head office. Three sites Lync phone works fine but one site showing error message " Cannot download certificate because domain is not accessible".

    Is it DNS issue or we have to change somethings in Lync Server itself? 


    Hanif Reza

    Thursday, November 21, 2013 5:17 AM
  • Machan Madusanka,

    I was having the same issue with my Polycom CX3000 and fixed by connecting the CX3000 to pc via USB connection and type the user name as "FQDN\username" from Lync 2013 client.

    Tuesday, June 24, 2014 7:18 AM
  • Madushka,

    I have seen the same problem with CX3000. in my case, i logged in successfully by specifying the UPN ( instead of the domain\Username



    Tuesday, June 24, 2014 7:38 AM
  • Anyone know how make the client default to the AD fqdn or to make it look up the netbios name sucessfully (without resorting to a wins server, if that even works) when the phone needs a new certificate?
    Tuesday, April 12, 2016 5:49 PM
  • Dude this actually worked! but makes no sense, i was trying domain\username which was getting the above error but by manually popping in the domain.local\username worked! arent they both the same thing though?
    Wednesday, May 17, 2017 11:35 AM
  • I've had the same issue with a CX600 "Cannot download certificate because domain is not accessible", and I fixed this using domain\username. 

    However, it has been necessary to maintain the USB cable plugged to the PC to keep the Polycom phone working.

    • Edited by M_Lopes Wednesday, October 16, 2019 5:46 AM
    Wednesday, October 16, 2019 5:43 AM