none
Error msg while creating a data source in Dashboard designer RRS feed

  • Question

  • I'm trying to create a data source in performance point dashboard designer. I get an error 'The requested item cannot be found.Verify that it exists and that you have permissions'. I have access to the database and can connect thru Management studio to the analysis service database. Anyone has come across such error or any insight on this is greatly appreciated. Thanks
    Tuesday, August 11, 2009 9:33 PM

Answers

All replies

  • If you would search the threads you should find numerous postings about this.  Very common issue and it is because the default security uses the identity of the application pool running the PPS Web Service.  Make sure that this account has access to the data source.  Otherwise go in the web.config file and setup the PerUser connection setting so that it is true (and this could possibly require you to configure Kerberos depending on your server configuration).

    Nick Barclay has a great posting on this topic to for additional reference - PerformancePoint Monitoring Data Source Connection Problems
    Dan English's BI Blog
    _____________________________________________________
    Please mark posts as answer or helpful when they are.
    Wednesday, August 12, 2009 2:06 AM
  • To clarify some SSRSuser's post:

    When SSRSuser logs in and tries to create a data source, she gets the error message posted.  However, when another user logs in to the same machine and goes through the same steps, that other user has no problems and is able to create a data source and report based on it.  To me that would signify that things are set up correctly with the app pool account, and that the problem is somehow isolated to SSRSuser.  Does that make any sense?

    We have checked, and all app pool accounts for PPS have access to the databases.

    Thanks.

    Wednesday, August 12, 2009 4:47 PM
  • Hello,

    Are you using Kerberos?  Like Dan mentioned look in the web.config is set to True for Connect PerUser?  IF you are in this type of enviornment then PPS would not be using the Applicaiton Pool to connect.  It will be using the credentials of the user.  This is most likely why it works for one user and not the other.

    Thank you,

    Aseem Nayar - MSFT
    This posting is provided "AS IS" with no warranties, and confers no rights
    • Edited by AseemN Wednesday, August 12, 2009 5:29 PM edit my typo
    Wednesday, August 12, 2009 5:07 PM
  • We are not currently using Kerberos, and would like to avoid if we can.  Will check on the web.config Connect PerUser settings.

    Thanks!
    Wednesday, August 12, 2009 6:17 PM
  • Have you verified the PerformancePoint Server permissions.  I believe this is the issue with the user.  In order to create a data source the user would need to be an Administrator or Data Source Manager within the PerforamncePoint Server security.  Not sure if you have looked at this or configured this yet - http://technet.microsoft.com/en-us/library/bb821194.aspx.

    Take a look at this posting here - Setting up PerformancePoint Monitoring Design Role Security

    Or as a workaround if you are unable to do that you can go into the PPSMonitoring database and get your UserID from the BsmUsers table and add yourself into the Roles table with the UserID and specifying Admin in the Roles section.  This will give you or the user the necessary permissions to create a data source.
    Dan English's BI Blog
    _____________________________________________________
    Please mark posts as answer or helpful when they are.
    • Proposed as answer by Dan English Wednesday, August 12, 2009 9:07 PM
    Wednesday, August 12, 2009 6:29 PM
  • To add to what dan is saying you can look at this thread: 

    http://social.technet.microsoft.com/Forums/en-US/ppsmonitoringandanalytics/thread/fc08f34a-476b-4873-97ea-416f2ad11549/ 

    Thanks,

    Aseem Nayar - MSFT

    This posting is provided "AS IS" with no warranties, and confers no rights
    Wednesday, August 12, 2009 6:32 PM
  • Hi Thanks for all your assistance. I added my userid as a creator and data source manager in the monitoring server and that helped resolve my issue and I can now create a datasource in the dashboard designer.

    http://blogs.adatis.co.uk/blogs/timkent/archive/2007/11/01/performancepoint-monitoring-server-security.aspx
    • Marked as answer by AmbikaSowmyan Wednesday, August 12, 2009 9:05 PM
    Wednesday, August 12, 2009 9:04 PM