none
Project Server 2010 + SP1 - Project Resource cannot access Project Schedule and PDP RRS feed

  • Question

  • Hi,

    We just migrated from Project Server 2007 to 2010. On 2007, the security management settings have been done in order to allow a project's resource to access the project details view (project schedule).

    After the migration, resources cannot access anymore to the project schedule (and the project detail page) except if they are the project owner. They have a "Error: access denied" page.

    I checked all the security management settings (groups, category and so on) and everything seem ok. The settings are the same than in 2007, but it doesn't work anymore.

    The resource have been granted to the project in Project Professional, build team from enterprise, and the schedule have been published. The resources have access to the Project Site (or Project workspace in 2007) but the access to the PWA schedule is denied.

    Thank you for your help


    • Edited by YvesZ Thursday, November 22, 2012 5:41 AM
    Thursday, November 22, 2012 5:41 AM

Answers

  • Hi,

    Rob, you were right, the "Open Project" permission was not selected. I did select it, and it works now. Team members are now able to see the schedule, my issue is fixed. I don't understand why this permission has not been selected during the upgrade. Thanks a lot.

    I just have one additional question: what do you mean by "Is the project detail page for the Enterprise Project Type set to "Schedule" as the top most option". In "Project Detail Pages", I have the list of all the documents available in PDP, Schedule included, but I don't see the way to set the Schedule as top most option... But it doesn't matter my issue is fixed.

    Avinash, thank you for your time. The two permissions you mentioned were already selected.

    • Marked as answer by YvesZ Friday, January 4, 2013 6:31 AM
    Wednesday, November 28, 2012 12:31 AM

All replies

  • Is the project detail page for the Enterprise Project Type set to "Schedule" as the top most option e.g. default one that loads?

    If so, the user will need the "Open Project" permission - which can be set on the category (for example, "My Tasks" category is set against the "Team Members" group by default - and this category doesn't have the "Open Project" permission by default).

    Thursday, November 22, 2012 7:48 PM
  • Hi YvesZ,

    Check these two permission for your team members group.

    1. View Project Schedule in Project Web App.

    2. View Project Summary in Project Center.

    Apply above changes and let us know, hope it will help.

    Regards,


    Avinash kumar | e2eProjects Pvt. Ltd | Blog:http://om-avinash.blogspot.com

    Saturday, November 24, 2012 9:10 AM
  • Hi,

    Rob, you were right, the "Open Project" permission was not selected. I did select it, and it works now. Team members are now able to see the schedule, my issue is fixed. I don't understand why this permission has not been selected during the upgrade. Thanks a lot.

    I just have one additional question: what do you mean by "Is the project detail page for the Enterprise Project Type set to "Schedule" as the top most option". In "Project Detail Pages", I have the list of all the documents available in PDP, Schedule included, but I don't see the way to set the Schedule as top most option... But it doesn't matter my issue is fixed.

    Avinash, thank you for your time. The two permissions you mentioned were already selected.

    • Marked as answer by YvesZ Friday, January 4, 2013 6:31 AM
    Wednesday, November 28, 2012 12:31 AM
  • Hi YvesZ,

    congrats dear. :)

    @2nd question: you need to reorder the PDPs at the stage lavel to order it in the workflow (if workflow assigned), if workflow is not there then directoly you need to reorder in the EPT.

    Regards,


    Avinash kumar | e2eProjects Pvt. Ltd | Blog:http://om-avinash.blogspot.com


    Wednesday, November 28, 2012 3:25 AM
  • If problem solved then mark the answer. don't let it be open.


    Avinash kumar | e2eProjects Pvt. Ltd | Blog:http://om-avinash.blogspot.com

    Thursday, November 29, 2012 6:49 AM