locked
Repeating Table: Default number of rows RRS feed

  • Question

  •  

    Hi,

     

    I am working with InfoPath 2003 SP2

     

    In my form one of the Repeating Tables always shows by default 5 rows when openning to fill out a new form.

     

    I assume this happens because formerly the related section in the DataSource schema had a constant number of 5 occurances .

    Now, this is changed to: 1 - unbound, but still the form shows always 5 rows, instead of 1.

     

    I tried the following to fix it :

    - Converted the Main DataSource

    - Changed Binding of the Repeating table

    - Removed the whole Repeating table, and re-created it

     

    What can fix this ?

     

    Thanx,

    dmldml

    Wednesday, November 14, 2007 8:02 AM

Answers

  • I may be WAY of basis on this answer, but it's a shot in the dark.  Please don't think I am talking down to you, because I am not.  Sometimes I overlook things, and I just want to make sure you haven't overlooked this one.

     

    Try going to the Tools Menu, Default Values, and see if there are any extra groups listed for that repeating table?  The reason I ask, is because this happened to me and frustrated me until I found this.  I felt stupid for not looking there sooner.  Somehow, extra default value groups had been added.  Once I removed the extas, it stopped happening.

     

    I hope I helped, and that it isn't something else.

     

    Bryant

     

    Saturday, November 17, 2007 11:34 PM

All replies

  • I may be WAY of basis on this answer, but it's a shot in the dark.  Please don't think I am talking down to you, because I am not.  Sometimes I overlook things, and I just want to make sure you haven't overlooked this one.

     

    Try going to the Tools Menu, Default Values, and see if there are any extra groups listed for that repeating table?  The reason I ask, is because this happened to me and frustrated me until I found this.  I felt stupid for not looking there sooner.  Somehow, extra default value groups had been added.  Once I removed the extas, it stopped happening.

     

    I hope I helped, and that it isn't something else.

     

    Bryant

     

    Saturday, November 17, 2007 11:34 PM
  •  

    Thanks a lot , Bryant

     

    That fixed the problem !!!

     

    And since I'm new with InfoPath, it was NOT too down at all...

     

    Thanks again,

    dmldml

    (just have a new user name, since I couldn't sign-in with my previous one )

    Monday, November 19, 2007 12:49 PM
  • Not a problem at all.  If I had a dollar for everytime I overlooked something.......

     

    Best of luck

     

    Bryant

     

    Monday, November 19, 2007 5:30 PM
    1. Open the form in design mode
    2. Click Default Values on the Tools menu
    3. In the data source, select the group that's bound to the row of the repeating table
    4. Click the down arrow next to the group name
    5. Select "Remove"
    Monday, October 10, 2011 9:00 AM