locked
"Run another program" not working for Windows 7 clients RRS feed

  • Question

  • Does anyone have any information on "Run another program" not working for Windows 7 clients?  Only the programs that have this option checked are failing on Windows 7 clients.  The same advertisements work fine on Windows XP clients.  The advertisement gets to the client, but the program goes into a state of "WaitingRetry".  It never runs the dependent program and thus never runs the orginal program.  We are running SCCM 2007 R2 SP2 and have the updated SCCM client loaded (4.00.6487.2111 is the version).  In execmgr.log, I find "Could not find the policy in WMI for package <pkgname> program <progname> DeletedPolicy object is not found.(0x80002004)"

    Tuesday, May 4, 2010 5:48 PM

Answers

  • Have you examined the dependent program? Have you verified that it runs successfully on your Windows 7 systems by advertising it individually to a test client?

    Perhaps the dependent program is restricted to only run on XP clients?


    Jason | http://myitforum.com/cs2/blogs/jsandys | http://blogs.catapultsystems.com/jsandys/default.aspx | Twitter @JasonSandys
    Tuesday, May 4, 2010 10:36 PM
  • Another thought might be that if the dependent program's either not advertised or its advertisement has been corrupted in some way.

    Tuesday, May 4, 2010 10:43 PM

All replies

  • Have you examined the dependent program? Have you verified that it runs successfully on your Windows 7 systems by advertising it individually to a test client?

    Perhaps the dependent program is restricted to only run on XP clients?


    Jason | http://myitforum.com/cs2/blogs/jsandys | http://blogs.catapultsystems.com/jsandys/default.aspx | Twitter @JasonSandys
    Tuesday, May 4, 2010 10:36 PM
  • Another thought might be that if the dependent program's either not advertised or its advertisement has been corrupted in some way.

    Tuesday, May 4, 2010 10:43 PM