locked
Unable to change email alias into distribution group RRS feed

  • Question

  • I am trying to have an email address service@mydomain.com go to three users.  service@mydomain.com is currently an alias for one of those users.

    When I remove the alias from the one user, wait one hour and then try to create the distribution group email I get this error...

    -----------------------------------------------------------------------------------------------

    Summary: 1 item(s). 0 succeeded, 1 failed.
    Elapsed time: 00:00:01


    service
    Failed

    Error:
    Active Directory operation failed on dc2.mydomain.local. The object 'CN=service,CN=Users,DC=mydomain,DC=local' already exists.

    The object exists.

    Exchange Management Shell command attempted:
    new-DistributionGroup -Name 'service' -Type 'Distribution' -OrganizationalUnit 'mydomain.local/Users' -SamAccountName 'service' -Alias 'service'

    Elapsed Time: 00:00:00

    -----------------------------------------------------------------------------------------------

    I am running Exchange Server 2007 on Windows Server 2008 and have one Server 2008 DC and one Server 2003 DC.  I got the same error when I only had the single Server 2008 DC.

    I am assuming there is a reference to the deleted alias somewhere that needs to be deleted but I have no idea where to look.

    Any help would be greatly appreciated.

    Friday, March 6, 2009 5:59 AM

Answers

  • Yes, I can also reproduce in the lab (Exchange 2007 SP1)

    The account “Service” is reserved, actually it has been already used. Please see the posts from mine and Amit in the thread below, it will help:

    Cannot create a user account or mailbox

    • Proposed as answer by Alan.Gim Monday, March 9, 2009 9:32 AM
    • Marked as answer by Alan.Gim Thursday, March 12, 2009 1:25 AM
    Monday, March 9, 2009 3:36 AM

All replies

  • Hi,

    1. Change the email address of current user from service@domain.com to service1@domain.com and uncheck "Automatically update e-mail addresses based on recipient policy", wait for some time to replicate it to allDCs. Create a DL and assign/add the email address service@domain.com to this DL and uncheck "Automatically update e-mail addresses based on recipient policy".

    2. If 1. doesn't help then you may need to delete the service user account and create a new user accountService1 with different sam account and alias. Attach the disconnected "service" mailbox, which was connected to previous user, to this new service1 account. Then try to create new DL with name Service.

    Amit Tank | MVP - Exchange | MCITP:EMA MCSA:M | http://ExchangeShare.WordPress.com
    Saturday, March 7, 2009 10:21 AM
  • The user account is not "service"  it is john.doe with an additional SMTP address of service@mydomain.com.  I tried renaming and the forcing replication and waiting and still no luck.

    -Stephen
    Saturday, March 7, 2009 10:56 AM
  • Yes, I can also reproduce in the lab (Exchange 2007 SP1)

    The account “Service” is reserved, actually it has been already used. Please see the posts from mine and Amit in the thread below, it will help:

    Cannot create a user account or mailbox

    • Proposed as answer by Alan.Gim Monday, March 9, 2009 9:32 AM
    • Marked as answer by Alan.Gim Thursday, March 12, 2009 1:25 AM
    Monday, March 9, 2009 3:36 AM
  • You have a good memory James!!! J


    Amit Tank | MVP - Exchange | MCITP:EMA MCSA:M | http://ExchangeShare.WordPress.com
    Monday, March 9, 2009 3:43 AM
  •  J
    Monday, March 9, 2009 3:46 AM