none
Disable certificate checking in IE9 RRS feed

  • Question

  • Is there a way to disable certificate checking in IE9? I have tons of internal applications that keep giving me the typical cert warning, it's annoying and I don't need that.  And no, it's not a time sync issue, and I'm not asking how to install a cert, and changing the Advanced options don't work.

    I just want to completely and permanently disable cert checking.

    Wednesday, March 27, 2013 7:18 PM

All replies


  • Hi,

    Please refer to the methods in the following KB article:

    "There is a problem with this website's security certificate" when you try to visit a secured website in Internet Explorer
    http://support.microsoft.com/kb/931850

    Thanks.


    Nicholas Li
    TechNet Community Support

    Friday, March 29, 2013 10:02 AM
    Moderator
  • Please read my post before throwing me generic canned answers.  I am not looking to fix an issue with general browsing.  I am asking how to disable Internet Explorer's behavior of warning and blocking SSL sites with any type of cert error.

    Friday, March 29, 2013 3:29 PM

  • As we all know the certificate checking could not be changed:

    About certificate errors
    http://windows.microsoft.com/en-us/windows7/about-certificate-errors

    “Can I turn off certificate checking?
    No, you can't turn off certificate checking in Internet Explorer. If you're receiving certificate errors, it means the website you're visiting is having certificate problems and it doesn't indicate a problem with Internet Explorer.”

    Therefore, I think we need to check the server or certificate side. As you mentioned the "internal applications", please check them on design and see if this will be helpful on the issue.

    Thanks.


    Nicholas Li
    TechNet Community Support





    Tuesday, April 2, 2013 7:37 AM
    Moderator
  • I get the certificate error on this web page. Asking Nicholas Li to answer the original question, how do you disable the message.
    Saturday, September 28, 2013 6:48 PM
  • To disable all of the potential certification errors, open Internet Explorer 9 and click on 'tools' > ‘Internet Options’ > ‘Advanced’ button. Uncheck the boxes ‘warn about certificate mismatch,’ ‘warn about invalid site certificates’ and ‘Enable SmartScreen Filter.’

    This will stop any certificate verification issues you have. HOWEVER, it will make IE9 more vulnerable to viruses and attacks.

    Proceed with caution and good luck.


    Tuesday, October 7, 2014 2:10 PM
  • Hello,

    Please refer to http://www.anvisoft.com/resources/how-to-stop-certificate-error-in-internet-explorer/ . I hope it will solve your problem.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Edited by Fahadking07 Tuesday, October 7, 2014 10:36 PM
    Tuesday, October 7, 2014 10:36 PM