none
Microsoft-HTTPAPI/2.0 listening on port 80 in new windows 10 installation. Why?

    Question

  • I have a junk pc in the corner of my office whose only task is to run a "candidate" web server as part of my QA process for my web site. This server has worked correctly for several years, but it was recently updated to Windows 10 using the free migration. 

    Now when I start the web server (nginx) I get the message "10013 An attempt was made to access a socket ...". I found a post on social.msdn.microsoft.com which supposedly answers this.  Sure enough, "Microsoft-HTTPAPI/2.0" is listening on port 80.  The post tells me to disable the "web deployment service agent" but my system does not have a service running of that name.

    Is there another way, or has the service been renamed in Windows 10?



    • Edited by clairmatin Friday, October 9, 2015 5:47 PM
    Friday, October 9, 2015 5:44 PM

All replies

  • You can stop it by running this command:

    sc stop "MsDepSvc"

    MsDepSvc.exe is process of the Web Deployment Agent Service. You can control it's startup mode from the Services console (services.msc)

    -

    Hessam
    Windows Outreach Team- IT Pro
    Windows for IT Pros on TechNet

    • Proposed as answer by Karen HuModerator Tuesday, October 13, 2015 8:13 AM
    • Unproposed as answer by clairmatin Thursday, October 15, 2015 2:57 AM
    Sunday, October 11, 2015 2:44 AM
    Moderator
  • I said in my initial post that I knew about that, and that I do not have a "Web Deployment Agent Service" running.

    I ran the command 'sc stop "MsDepSvc"' and it returns a message "The specified service does not exist as an installed service."

    The machine is an antique, Lenovo Intel Core 2 Quad 6600 with 8GB memory.  Otherwise Windows 10 appears to run well on it, and the boot time is significantly less.

    Thursday, October 15, 2015 3:09 AM
  • A socket error 10013 can be caused by the antivirus or firewall software. As a test, disable your antivirus and firewall temporarily to see if you are able to connect. Also check Services and see if you have any other service using port 80 like a SQL Server.

    You can check to see what process is listening on that port by running the command:

    netstat -aon | more

    Port 80 will show under Local Address and to the right you'll see the PID, or Process Identifiers. Open Task Manager and find the PID in the list. You can use the End Process or Go to Service(s) options to control the process or stop it.

    -

    Hessam
    Windows Outreach Team- IT Pro
    Windows for IT Pros on TechNet

    Thursday, October 15, 2015 3:43 AM
    Moderator
  • I cannot understand how you can give that answer if you have actually read my original post.  Read it again, where it says (copied and pasted) "Microsoft-HTTPAPI/2.0" is listening on port 80.  So from that you can assume that I already know what is listening, so I do not need to do any of what you suggest.  I need to know which part of Windows 10 identifies itself that way when I do an HTTP GET to it using telnet.  Previous posts have identified it as "Web Deployment Agent Service" but this service is not running.  Nor is MsDepSvc running.  I don't know how to say it more clearly.

    The additional software I have on my primary PC includes Office 2010, Eclipse Mars, Java 8, Omnipage Ultimate, Beyond Compare 4, WinSCP, Regexbuddy, Adobe Reader --- what you might expect for someone who builds web sites from bare metal like I do.

    I do not have any database software installed.

    I have four PCs in my office, all running Windows 10, three upgraded and one installed from a retail CD. All four are listening on port 80 after bootup.  This means I cannot run a standard web server on any of them.  I would have to go back to Windows 7 to get my work done.  Eventually I will do so if I need to, or use a fifth machine I have sitting on a shelf with Windows XP on it.

    Thursday, October 15, 2015 4:37 PM
  • Another possible solution I can suggest is to try resetting the network adapter (win socket reset) by running the following in an elevated Command Prompt:

    netsh winsock reset

    It doesn't hurt to manually reset TCP/IP by running the following command:

    netsh int ip reset c:\resetlog.txt

    Note If you don't want to specify a directory path for the log file, run the following command instead:

    netsh int ip reset

    Lastly you can try completely removing your network adapter drivers via Device Manager and reinstalling with the latest from the manufacturer. Best of luck.

    -

    Hessam
    Windows Outreach Team- IT Pro
    Windows for IT Pros on TechNet

    Friday, October 16, 2015 6:12 AM
    Moderator
  • Moderators, I know you like to see clean endings, but please don't tell me one of these posts is the answer. Let me decide if it answers my question.

    Why is it so difficult to give the real answer?

    Saturday, October 24, 2015 4:13 AM
  • Clairmartin has asked a simple question. Why is it necessary for the Microsoft staff to beat around the bush and not answer the question properly? Actually, I have the same question. Windows 8 says that port 80 is used by "Microsoft-HTTPAPI/2.0". How do I locate this service and stop it? Please cut all the BS and post your true answer. After all, it's your product and I have paid for it.
    Thursday, November 5, 2015 4:10 AM
  • Hi, clarimatin.

    I guess that is BranchCache service.

    Let's try to disable BranchCache.

    (But, I don't know reason why it's invoking...)

    • Proposed as answer by Brett Carroll Tuesday, May 23, 2017 12:31 AM
    Tuesday, December 22, 2015 7:42 AM
  • Hi,

      Also encountered this issue. Web development service agent, IIS, SQL Reporting Services is not running also on my computer  but still got this error Server: Microsoft-HTTPAPI/2.0 is using port 80. To troubleshoot this I manually stop one by one the services and start and restart my wamp server. I found out that Windows Remote Management (WinRM) causing this problem. 

    You can stop this service and see if its works.



    • Edited by dhelvenc Tuesday, December 29, 2015 2:34 PM
    Tuesday, December 29, 2015 2:29 PM
  • Hi,

    I know the reply is late but just wanted you to know what worked for me on Windows 10.

    1. Go to Control Panel -> Programs -> Turn Windows features on or off

    2. Enable Internet Information Services

    3. After its enabled, try to access localhost in your browser and you should see the the default IIS page.

    4. Now go back to step 2 and disable the IIS feature and restart if you are asked to.

    5. Start your server services and this should probably work.

    Always works for Apache (Wamp Server) on my Windows 10

    • Proposed as answer by schnubbel59 Friday, April 7, 2017 12:51 PM
    Friday, January 15, 2016 2:09 AM
  • In Windows 10 it looks like Web Deployment Agent Service was renamed to to World Wide Web Publishing Service. I stopped this service and port 80 was no longer in use.
    • Proposed as answer by Jan Tošovský Wednesday, January 27, 2016 8:30 PM
    Saturday, January 23, 2016 2:31 AM
  • Try the World Wide Web Publishing Service. In my case, that was the service that was running and using port 80.
    Sunday, August 28, 2016 10:28 PM
  • Just for sake of other google wonders, In my case "Microsoft-HTTPAPI/2.0" was identifier of SQL Server Reporting Services. 
    • Proposed as answer by GEB Service Thursday, November 24, 2016 5:45 PM
    Saturday, September 17, 2016 8:20 AM
  • Just for sake of other google wonders, In my case "Microsoft-HTTPAPI/2.0" was identifier of SQL Server Reporting Services. 
    You are correct! :) Thanks
    Tuesday, February 7, 2017 1:50 PM
  • Just for sake of other google wonders, In my case "Microsoft-HTTPAPI/2.0" was identifier of SQL Server Reporting Services. 

    In My Case it was the same ! thank you !
    Wednesday, March 8, 2017 11:52 PM
  • Just for sake of other google wonders, In my case "Microsoft-HTTPAPI/2.0" was identifier of SQL Server Reporting Services. 
    Same for me. Thanks to you I resolved it!
    Sunday, March 12, 2017 3:14 PM
  • In my case it was Razer Chroma SDK Server service. 
    It is installed with Razer Synapse software when you have Razer Chroma keyboard or mouse.
    Friday, May 12, 2017 10:18 AM
  • Same, Razer Chroma SDK Server was the culprit. What is Razer thinking?
    Wednesday, May 17, 2017 3:01 PM
  • The PeerDistSvc (BranchCache) was listening on TCP port 80 on my Windows 7 machine.   Stopping the PeerDistSvc Service removed the port 80 listener.
    Tuesday, May 23, 2017 12:32 AM
  • In my case it was Razer Chroma SDK Server service. 
    It is installed with Razer Synapse software when you have Razer Chroma keyboard or mouse.

    This solved my problem ! Thank you 
    Saturday, May 27, 2017 5:47 PM
  • In Windows 10 .. the Service "World Wide Web Publishing Service" will listen on port 80.

    In a command prompt, this service will be reported as "Microsoft-HTTPAPI/2.0"

    If you're installing your own http server (e.g. Apache via Xampp or Wamp) you can either configure Apache to listen on a different port, or stop the World Wide Web Publishing service.

    To stop the service follow these steps;

    1)In ur Windows Search Panel type "Services" to launch the  Windows Services navigator.

    Scroll down the list of services and locate the "World Wide Web Publishing" service (this should be marked as 'running')

    Right click the service and select 'Stop'

    Start Apache.

    • Proposed as answer by Peter Gloor Thursday, October 5, 2017 1:18 PM
    Monday, September 11, 2017 5:51 PM
  • In Windows 10 .. the Service "World Wide Web Publishing Service" will listen on port 80.

    In a command prompt, this service will be reported as "Microsoft-HTTPAPI/2.0"

    If you're installing your own http server (e.g. Apache via Xampp or Wamp) you can either configure Apache to listen on a different port, or stop the World Wide Web Publishing service.

    In my case I was unable to run a simple web server app I've written in Go (golang). Disabling the "World Wide Web Publishing Service" (spelled "WWW-Publishingdienst" in German) solved my problem. 
    Thursday, October 5, 2017 1:27 PM
  • in my case is a W3SVC service. After stopping 80 port was released.
    Saturday, December 30, 2017 10:10 AM
  • W3SVC service is the same as "IIS World Wide Web Publishing Service"
    Saturday, December 30, 2017 3:45 PM
  • I read through this entire post and the answer for me is none of the above.

    I did: netstat -aon | more

    AND what I found was ultimately surprising!

    PID: 4.

    process: "System", Described NT Kernel & System

    file: C:\Windows\System32\ntoskrnl.exe

    1. Is this the OS Kernel?

    2. Why is it listening to port 80?

    Tuesday, January 9, 2018 5:16 AM
  • Hi!

    I had this exact problem too!

    of course in my case I had Sql server 2012 installed, after uninstalling it Port 80 was released.

    Saturday, October 13, 2018 5:23 AM
  • SQL server itself is not listening on port 8080.
    As others in this thread already posted: its the  SQL Server Reporting Services.
    Saturday, October 13, 2018 7:36 AM