locked
SMTP Slow Repsonse Times

    Question

  • Hello.  I've just setup an Exchange 2007 Transport hub server, but I'm having several issues with SMTP.  I'm getting very slow transaction times (tests from external sources show 10-15 seconds).  There is nothing in the queue.  I've got another Exchange 2007 mailbox server and an Exchange 2003 back end server in the domain.  Any suggestions would be greatly appreciated.  Thanks.

    Sunday, May 27, 2007 7:42 PM

All replies

  • Hello,

    I was wondering if there was any update on this as it seems we are having the same problem now. We installed our Exchange server 2007 2 weeks ago and the email times were very quick. However this week we have been having some routing problems between our exchange 2007 and 2003 servers, but this has now been resolved. We are now having a problem where, with only about 5 users using email, it can still take approx 30 secs to send an internal mail to another mailbox on the same server. Sending to an external account (just a small 4/5kb email) can take upto 2 minutes. When there are approx 200 users online the time obviously multiplies quite heavily.

    I was just wondering if there is any reason for this? We have tried multiple reboots and message tracking but have found no information.

    Thanks

    Carl
    Thursday, March 27, 2008 6:42 PM
  • I had the same problem during a migration from Ex2k3 to Ex2k7 Transport hub.  I noticed a connection between the SMTP response time and whether or not Recipient Filtering was enabled or disabled and the option to "Block messages sent to recipients not listed in the Global Address List" was checked..  The problem only cropped up during the enabled state.  It ended up being an issue with the tarpit setting which is enabled at 00:00:05 by default whenever Recipient Filtering is enabled. 

    You can use this cmdlet from the Management Shell
    get-ReceiveConnector | select name,tarpitinterval    ---To view your connectors and tarpit settings on each


    More details at: http://www.exchangepedia.com/blog/2007/01/enabled-by-default-smtp-tarpit-in.html

    I disabled the tarpit on my receive connectors since I only receive from a trusted ISP and I have other anti-spam settings in place.  My SMTP response time went from 10-12 seconds down to <1 second.
    Tuesday, May 13, 2008 8:16 PM
  • I noticed this slowdown immediately in testing 2k7 thanks for this post.  For some reason, even thought the get command would work the set command would give me error of that connector not being found on the domain controller.

     

    Thanks to the below post from the link above, I was able to set my connectors to 0 which is what I want for my transport hub which uses a smtp relay other than the Edge. 

     

    July 5, 2007 12:08 PM

     Bharat Suneja said...

     

    You can also pipe it using the following commands:

    Get-ReceiveConnector | Set-ReceiveConnector -tarpitinterval 00:00:10

    Wednesday, July 23, 2008 7:04 PM