none
Why does Outlook keep prompting for password RRS feed

  • General discussion

  • We have seen our community members ask questions about Outlook keeps prompting for credentials many times. This issue could be caused by numerous reasons. Below is a list of the most common reasons for this problem:

    • Outlook is configured to prompt you for credentials
    • Incorrect password cached in credential storage
    • Required Authentication Settings for outgoing server and incoming server
    • Outlook Anywhere is not configured to use NTLM Authentication
    • Corrupt Outlook profile
    • Slow or unstable network connection
    • Antivirus programs
    • Shared calendars

    Outlook is configured to prompt you for credentials

    If you are using an Exchange account, there is a setting in your Outlook profile to always prompt for logon credentials. To find the setting, please follow:

    1. In Outlook 213, go to File tab > Info > Account Settings > Account Settings…

    2. Highlight your Exchange account and click Change button.

    3. Click on More Settings button.

    4. Select the Security tab.

    5. Under the User Identification, make sure the “Always prompt for logon credentials” option is not selected.

    If you are using other types of email, please make sure you have ticked the option “Remember password”.

    Incorrect credential cached in Credential Manager

    Your Windows system stores user credentials on your computer. If the cached credentials are incorrect, you will be prompted for password. This issue usually happens after the password for your domain user account is changed. Before your password changed, you saved your credentials. The stored credentials are not overwritten when Outlook triggers the authentication prompt even if you enable the Remember my credentials option.

    To fix this issue, you need to remove the corrupted credentials, follow these steps:

    1. Click Start, click Control Panel, and then click Credential Manager.

    Note If View by is set to Category, click User Accounts first, and then click Credential Manager.

    2. Locate  the set of credentials that has Outlook in the name.

    3. Click the name to expand the set of credentials, and then click Remove from Vault.

    Repeat step 3 for any additional sets of credentials that have the word Outlook in the name.

    Required Authentication Settings for outgoing server and incoming server

    Different email provider may need different authentication settings. Please make sure you have set the server settings correctly. You can contact your email provider to gather the information.

    In general, we select the “My outgoing server (SMTP) requires authentication” option and the first bullet “Use same settings as my incoming mail server”.

    In addition, click on the Advanced tab and check if you have enter the correct Server Port Number and select the correct encrypt type. Below is a screenshot for an IMAP account:


    Outlook Anywhere is not configured to use NTLM Authentication

    The Outlook Anywhere feature allows you to access your Exchange account remotely from the Internet when you are working outside your organization's firewall.

    When using Outlook Anywhere to connect to your Exchange server, we need to choose the authentication method among Basic Authentication, NTLM Authentication and Negotiate Authentication. The difference among them is the way that the passwords are sent when connecting to the server. With Basic Authentication, the password is sent in clear text. Using NTLM Authenticationcan significantly reduce the number of password prompts.

    To check the authentication setting, please go to File > Account Settings > Account Settings, select the Exchange account, and then click Change. In the Change Account wizard, click More Settings, and then click the Connection tab. Click the Exchange Proxy Settings button and now, you can see the settings under Proxy authentication settings. Try to change the authentication to NTLM Authentication and then check the issue again.

    Slow or unstable network connection

    If your network connection is slow or unstable, Outlook may lose connection to the mail server. When Outlook try to reconnect, it will prompt for the credentials. To verify this, please switch to a stable network environment and then check if this issue persists.

    Corrupt Outlook Profile

    Corrupt profile may cause Outlook to no longer remember your password. Please try to create a new mail profile in Control Panel and reconfigure your email account in the new profile to fix the issue. To create a new mail profile, you can refer:

    http://support.microsoft.com/kb/829918

    Antivirus software

    Antivirus software usually integrates into your Outlook and it may cause some conflicts. Try to temporarily turn off your antivirus software to check if the issue will be gone.

    Shared Calendar

    Shared calendars can impact the user credentials, this issue may also occur if you have shared calendars opened in Outlook. You can try to unselect the shared calendar to check the result. It’s recommended to not open the shared calendar unless you want to view them.

    If you have any comments, welcome to post in the forum. Thank you.


    Please click to vote if the post helps you. This can be beneficial to other community members reading the thread.

    Wednesday, July 9, 2014 7:20 AM

All replies

  • Nope...

    I went through point by point by point, top to bottom, checking and verifying every single item as a possible cause for why my system (Outlook 2013 running on Windows 8.1 and connecting to Exchange 2010) insists on prompting me for my password every single time I start Outlook.  None of the solutions worked, my system still prompts me.  I don't even have to supply a password.  When the prompt dialog appears, I just cancel it.  Within a few seconds, the bottom Outlook status bar changes to "Need Password" with a key icon to the left.  Then I just click on that message and immediately Outlook connects to Exchange.

    The freaking software is BROKEN!  Period.

    Friday, January 30, 2015 9:10 PM
  • Nope...

    I went through point by point by point, top to bottom, checking and verifying every single item as a possible cause for why my system (Outlook 2013 running on Windows 8.1 and connecting to Exchange 2010) insists on prompting me for my password every single time I start Outlook. 

    The logon creds you are being asked for are likely your Domain credentials (as opposed to your EX email account creds) so you may want to start by contacting your system administrator.

    Karl Timmermans [Outlook MVP] "Outlook Contact Import/Export/Data Mgmt" http://www.contactgenie.com

    Friday, January 30, 2015 10:57 PM
  • out look keeps asking me to log into one of my hotmail accounts constantly every time i run it i get the small internet e-mail box thing that asks me to log in even if i give the right details a second later it will appear again and i cant do anything with it or try any of the above as it keeps coming up and prevents me from clicking anything but it on outlook and it prevents my computer from shutting down normally i have uninstalled office with the hopes that i would have to re add my emails again but they just get re added and the problem happens again i cant use my computer properly as i cant shut down outlook with out shutting of my computer and the log in box appears over everything else i can see it right now even over chrome and i cant get rid of it as it just keep repapering i would appreciate some help and advice

    Thursday, March 31, 2016 12:35 AM
  •  i have uninstalled office with the hopes that i would have to re add my emails again but they just get re added and the problem happens again 

    Simply un-installing/re-installing Office for this type of issue is generally a complete waste of time since the email account info is contained in the Outlook profile which survives an u/re-install process.

    With Outlook closed, go to the Control Panel <Mail> app and create a <new> profile (where <new> = starting from scratch, not copying an existing profile and making changes to it). Configure your email account(s) and when done, make sure you set this new profile as the default for Outlook the next time you open it. 

    How to create profile and set up an e-mail account in Outlook
    http://support.microsoft.com/kb/829918 

     

    In addition - make sure you're entering the correct password in the event that you are using 2 step authentication 

    Two-step verification: FAQ
    http://windows.microsoft.com/en-us/windows/two-step-verification-faq
     
    App passwords and two-step verification
    http://windows.microsoft.com/en-us/windows/app-passwords-two-step-verification


    Karl Timmermans [Outlook MVP] "Outlook Contact Import/Export/Data Mgmt" http://www.contactgenie.com


    Thursday, March 31, 2016 12:54 AM

  • Simply un-installing/re-installing Office for this type of issue is generally a complete waste of time since the email account info is contained in the Outlook profile which survives an u/re-install process.

    With Outlook closed, go to the Control Panel <Mail> app and create a <new> profile (where <new> = starting from scratch, not copying an existing profile and making changes to it). Configure your email account(s) and when done, make sure you set this new profile as the default for Outlook the next time you open it. 

    thank you i will try this i also changed my password for said email account (7th time i have done so) and used that password and it has worked for now (didnt for the last 6 passwords -_-) if it does this again when i open it next time i will use your method and not add that account again 

    again thank you for your help 

    Thursday, March 31, 2016 1:38 AM
  • I was having the same issue and it was getting annoying.  I would click the "remember my logon credentials" box every time and it wasn't working.  I verified all of the above settings adjustments and none of them seemed to be incorrect to begin with so, after searching for a while I still didn't find a solution so I tried my own and this fixed my problem.  

    1. Open Control Panel -> Credential Manager

    2. Click the Windows Credentials Icon

    3. Remove all Outlook Credentials shown in this window (MS.Outlook.15:username@domain.***)

    4. Open Outlook, Type in your password, click remember my password.

    5. The credentials that are needed will be resupplied to the Windows Credentials area

    6. Voila! Close Outlook and reopen.  No password required and im logged in perfectly.  

    I hope this works for you.

    Saturday, July 30, 2016 3:54 PM
  • I had this issue for a few weeks after enabling Outlook Anywhere.  Some network captures were showing permission errors with autodiscover.  Remembering back to my days implementing ADFS, I remembered that NTLM passthru only works with sites in the Intranet zone. I added the split brain exchange URLs (autodiscover / webmail) to intranet zone and those prompts are gone.
    Monday, October 10, 2016 1:06 AM
  • I found that once I'd changed my Outlook.com / Hotmail password I had to obtain a new App Password from Security and Privacy Settings section on Outlook.com. Once I entered the App Password it worked. In my case, though, I had already deleted by originally working email account setup in Outlook 2016 app and so I was actually setting up the account again at this point.
    Monday, October 10, 2016 3:39 AM
  • I have the same issue.  If for any reason my ad password becomes invalid, outlook requests the login information every time outlook is opened.  I can cancel and click the need password to restore outlook's functionality.  The only work around I have found is to delete the outlook profile and create.
    Thursday, October 20, 2016 1:42 PM
  • I've started evaluating Office 2016 Home&Business for my environment, and ran into an issue with Outlook 2016.

    If a mail profile already exists, Outlook 2016 starts up fine and connects to Exchange (2010 On-Premise). If no mail profile exists however, like in the case of a newly imaged PC, Outlook 2016 prompts the end user with the Add Account wizard, and when it gets to the point of "Searching for user@domain.com settings" a Windows Security dialog appears which won't accept any credentials provided.

    This issue is only reproducible with Outlook 2016. Outlook 2010 and 2013 both setup new mail profiles without a problem. Anyone have any ideas what would be causing Outlook 2016 issues?

    But on other hand when i try to configure account settings through outlook anywhere it will work fine without any issue.

    Please help to resolve this issue.

    Regards

    Irshad ahmed

    irshad.mirza@outlook.com

    Friday, November 25, 2016 12:05 PM
  • Our problem was that our Exchange deployment pointed to the published site in TMG for some reason! So
    • Edited by Gareth.T Tuesday, December 13, 2016 12:13 AM
    Monday, November 28, 2016 12:49 AM
  • Nope, none of these are ever the issue.  My Outlook works fine and then all of a sudden this starts to happen.  Over the past 5-10 years it probably has occurred about 5-10 times.  Once ATT had changed the settings.  I'll figure it out again after researching it for a day.  I think it is a registry change or something I always forget.  MS Tech support is real lousy at setting this type of issue straight, I usually go to other Tech Support sites to get the low down on this one.

    Tuesday, November 29, 2016 3:41 AM
  • I face the same problem even after doing everything you have advised.
    Tuesday, December 13, 2016 10:14 AM
  • recently I removed old Domain Secondary SMTP addresses from all the user mailboxes and now I am getting tickets on Outlook prompt credentials. the weird thing is that its asking for credential to a user for a different user like

    USER A is a using outlook (USER-A@NewDomain.com). Suddenly it prompt for credentials to User A where it shows Connecting to B@oldDomain.com.

    any idea what could be wrong causing this prompt?

    Note: there is no trust with old and new domain. Autodiscovery is removed and organization sharing disabled.

    thanks,

    zak


    ZakBhai

    Friday, January 13, 2017 3:07 PM
  • Irshad, the problem you are experiencing is because of the change of Outlook 2016 searching for autodiscover information.  It first tries to go to your domain realm (ie: domain.com) to get mailbox information.  I fixed by putting this value in the registry

    In location HKCU\Software\Microsoft\Office\16\Outlook\Autodiscover

    New REG_DWORD ExcludeHttpsRootDomain with a value of 1

    Outlook will then go to autodiscover.domain.com for information which hopefully you have set up.

    This solved my problem.

    Thursday, January 19, 2017 8:06 PM
  • Irshad, the problem you are experiencing is because of the change of Outlook 2016 searching for autodiscover information.  It first tries to go to your domain realm (ie: domain.com) to get mailbox information.  I fixed by putting this value in the registry

    In location HKCU\Software\Microsoft\Office\16\Outlook\Autodiscover

    New REG_DWORD ExcludeHttpsRootDomain with a value of 1

    Outlook will then go to autodiscover.domain.com for information which hopefully you have set up.

    This solved my problem.

    Tried each and all single suggestions !!! 
    Nothing Worked, Except - 

    In location HKCU\Software\Microsoft\Office\16\Outlook\Autodiscover
    Add New REG_DWORD ExcludeHttpsRootDomain with a value of 1

    Thanks rmr1r. Kudoos. Full marks to you.

    *My Environment - MSO-2016-Standard + Windows 10 Pro
    Tuesday, April 25, 2017 8:00 AM
  • I don't know who thought it was a good idea to have Outlook ask for log in detail when the network connection is on the blink, but it isn't!  Less savvy users then waste time entering log in details, when that isn't going to make the slightest difference.

    Radical suggestion: how about a subtle notification stating the connectivity status....

    Thursday, May 11, 2017 12:30 PM
  • I have the same issue with Outlook 2016 and a MS 2013 exchange server
    Wednesday, May 24, 2017 5:48 PM
  • Hello Longshot

    Your description worked perfectly for me. I had 2 x 3 entries of stored credentials relating to Outlook (and only one account). I deleted all credentials related to Outlook.

    Restarted outlook entered credentials and ticked "remember". This time it worked.

    Thank You!

    Monday, June 12, 2017 4:58 PM
  • this worked for me!, thanks
    Wednesday, June 14, 2017 8:21 PM
  • Outlook was not mentioned in any of the credentials, but still am asked for the password repeatedly for my iCloud (me.com) mail account.  All other email accounts work just fine and this one did too, until last week.  Now it never connects, though the account still works just fine on other, non-windows, devices.
    Monday, June 19, 2017 3:25 AM
  • Your Credential Manager suggestion fixed this problem for me!  Thank you!
    Wednesday, June 28, 2017 2:17 PM
  • Out of nowhere Outlook started asking password. I cannot use any email address other than my hotmail. Neither my gmail nor my corporate exchange 365 domain. 

    I format my computer, and installed everything from the scratch, even I have a licensed office, I used the remove tool to uninstall, and installed one month 365 trial, still nothing. 

    How possibly this could happen? 

    Sunday, October 15, 2017 9:37 AM
  • I got the same Problem a couple days ago!

    Using Server 2012 R2 (all Updates so far)

    Installed Office 2016 new

    Created a new Server Profile

    Deleted Windows Credentials

    Exchange Online keeps asking for the password and is not connecting to the mailbox and shared mailboxes.


    • Edited by TechnikOnkel Wednesday, October 25, 2017 1:40 PM
    Wednesday, October 25, 2017 1:40 PM
  • This worked beautifully. I'm ashamed I didn't think of it myself. Thank you.
    Wednesday, November 8, 2017 4:49 AM
  • Servus,

    I've similar problems, we are now installing Outlook 2013 on Windows 10EE an get the password prompt each time the system wake up from standy mode. During normal operations or system start we get no password prompt at all. We have many Windows 7 systems with outlook 2007 and there the problem does never appear.

    We have an Exchange 2010 DAG running and there the authentication mode is set to basic:

    Our external clients (Mac and Outlook 2007; 2010; 2013; 2016) are connected over a TMG 2010 Sever, where the authentication mode also is set to basic. As far as I remember we configured the authentication mode to basic because of password prompts in Outlook 2007 but I'm not sure.

    Where exactly do I have to change the authentication mode in Exchnage and TMG to use NTLM?

    Is there a possibility to provoíde more authentication modes, to test the behavior on a single client, instead of affecting the complete infrastructure at once? Is there another possibility what ca cause our particular fault pattern?

    Thx in advance & Bye Tom

    Monday, December 11, 2017 2:29 PM
  • SOLVED FOR OFFICE 365

    For me this was a major issue.  For future info (knowledge sharing and all that!), just been on to Office this morning  via Tech call USA for the second time – this guy knew his stuff it appears (I’d tried everything before – reinstalling, deleting credentials from Credential Manager, changing passwords you name it).  He started a remote session and basically said it is because on a lot of machines there are two versions of office (if you google the issue it’s a widespread issue) – using add remove programs won’t fix the issue so Microsoft have created a specific tool to remove all versions of Office 365 which can be found here:

    https://support.office.com/en-us/article/Uninstall-Office-from-a-PC-9dd49b83-264a-477a-8fcc-2fdf5dbf61d8

    Just click on the blue download link and let it work its stuff. 

    Then download the correct version of Office from the users account online – advise clicking on advanced so the user can select the correct version (32 bit or 64 bit) – it defaults to 32 if you just click on download as you probably know.

    https://portal.office.com/OLS/MySoftware.aspx?source=ohp-ib

    A
    ll sorted.  You can buy me a beer if you are ever in Manchester!

    Thursday, December 21, 2017 9:59 AM
  • Irshad, the problem you are experiencing is because of the change of Outlook 2016 searching for autodiscover information.  It first tries to go to your domain realm (ie: domain.com) to get mailbox information.  I fixed by putting this value in the registry

    In location HKCU\Software\Microsoft\Office\16\Outlook\Autodiscover

    New REG_DWORD ExcludeHttpsRootDomain with a value of 1

    Outlook will then go to autodiscover.domain.com for information which hopefully you have set up.

    This solved my problem.

    For me, this did the trick and solved the issue.

    No more promping for password. No more "Need Password".

    You can also (almost) deduct this solution from this article:
    https://support.microsoft.com/en-us/help/2212902/unexpected-autodiscover-behavior-when-you-have-registry-settings-under
    It makes a great difference when I perform the Autodiscover test in that article without the ExcludeHttpsRootDomain Key and then with it.

    I now have only these three Keys under AutoDiscover in the Registry:
    ExcludeHttpsAutoDiscoverDomain
    ExcludeHttpsRootDomain
    ExcludeScpLookup

    Saturday, January 27, 2018 7:31 PM
  • Irshad, the problem you are experiencing is because of the change of Outlook 2016 searching for autodiscover information.  It first tries to go to your domain realm (ie: domain.com) to get mailbox information.  I fixed by putting this value in the registry

    In location HKCU\Software\Microsoft\Office\16\Outlook\Autodiscover

    New REG_DWORD ExcludeHttpsRootDomain with a value of 1

    Outlook will then go to autodiscover.domain.com for information which hopefully you have set up.

    This solved my problem.

    I was having this issue in one machine and this solution worked well. What is scaring why is happening! Nothing was changed in the DNS and all other machines are not affected!
    Tuesday, January 30, 2018 11:07 AM
  • tried regedit - HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook then no Autodiscover

    Windows 10 outlook 2016

    Friday, March 30, 2018 7:11 PM
  • how about cheking your nic(s) authentication modes- 

    netsh lan show profile   <- displays the mode of authentication-  if its value is null, you'll physically be connected but not able to access network resources, outlook will prompt for credentials

    Profile on interface Ethernet
    ======================================================================= 
    Applied: User Profile

        Profile Version        : 1
        Type                   : Wired LAN
        AutoConfig Version     : 1
        802.1x                 : Enabled
        802.1x                 : Not Enforced
        EAP type               : Microsoft: Protected EAP (PEAP)
        802.1X auth credential : Machine or user credential
        Cache user information : Yes 

    note: the above results have the proper values-  to change the 802.1x auth credent field value:

    netsh lan set profileparameter authmode=machineoruser

    [needs to be done via administrative rights]

    • Edited by dave.mb1 Thursday, April 12, 2018 6:14 PM
    Thursday, April 12, 2018 6:10 PM
  • Irshad, the problem you are experiencing is because of the change of Outlook 2016 searching for autodiscover information.  It first tries to go to your domain realm (ie: domain.com) to get mailbox information.  I fixed by putting this value in the registry

    In location HKCU\Software\Microsoft\Office\16\Outlook\Autodiscover

    New REG_DWORD ExcludeHttpsRootDomain with a value of 1

    Outlook will then go to autodiscover.domain.com for information which hopefully you have set up.

    This solved my problem.

    + 1000 for this one. Took me a while to understand what you were talking about (I'm a total noob) but got there in the end and so far so good. 

    long may it last

    Thursday, April 12, 2018 10:31 PM
  • In the registry location you provide above I found numerous entries from former experiments and mail accounts. I deleted all according entries and only kept the one needed for the current mail account / mailprovider - and it worked! I don't get the account prompt anymore when I start Outlook. Thanks for this indirect help!
    Monday, April 30, 2018 4:29 PM
    1. Why does your question say "Outlook 213"?  Do you mean " Outlook 2013", but can't fix the typo?  Why isn't there an answer for Outlook 2016?
    2. Is this a bug, or is this a question of wrong settings?
    3. When will it be fixed?
    4. I am asking that, since my ISP (Internet Service Provider) is "Time Warner Cable TWC", which is now "Spectrum".  They say  "We at Spectrum do not handle any 3rd party programs except webmail (which does not have search), and you should go to Microsoft -- we can provide you with Microsoft's phone number."
    Wednesday, December 19, 2018 3:44 PM
  • Are you a nitwit like me? Here is the solution from a non-tech Microsoft 10 user (HP laptop):

    Since the tech guys always assume we know the introduction and follow and only tell you the core, I will help you out.

    First of all you rightclick the windows icon on the left button and choose Search. Then you type Credenti... and you find the credential manager. In Dutch: Referentiebeheer. Start it up.

    Click the tab 'Windows credentials'.

    Delete all Outlook references. (This is where the Microsoft tutorial stops and then the problem remains)

    Now you ADD a new credential. It's a light blue link top right.

    When you have the same problem as me, an exchange account kept prompting for the password and the Microsoft tool that should stop the asking for a password did not work because that tool itself kept asking for a password...sigh) then you make a new entry like:

    exchange.server.com (something like the entry you made when adding the exchange account)

    user can be just david of or in my case dtd\david

    Fill in password and save.

    Now restart Outlook and the problem is solved.

    Please, Microsoft, hire a dumb end user like me to write the help texts on this forum.

    Wednesday, January 2, 2019 11:16 AM
  • I've tried everything in this article as well except for unchecking shared calendars. We're using Office 365 for the Office suite, but our email is Exchange 2016 on prem with no hybrid. We have no shortage of user complaints about Outlook (and Skype) prompting for credentials.

    What's weird is that I can hit Cancel on the Outlook prompt, and in the task bar Outlook says 'Need Password'. If I click on 'Need Password' it magically goes away and I'm not prompted again for creds...until the next time.

    Wednesday, January 23, 2019 7:13 PM
  • Are you a nitwit like me? Here is the solution from a non-tech Microsoft 10 user (HP laptop):

    <snip>

    Please, Microsoft, hire a dumb end user like me to write the help texts on this forum.

    Yes, because SMS Messages (texts) are exactly what we need.
    Tuesday, February 5, 2019 3:04 AM
  • Yes, I had changed PW and have 2FA enabled. When I made the change I was given a "app" password as well. I am so glad I kept note of the app password, because when I read your comment above it sparked memory of said password. I found it and entered in place of the new password I thought I needed and BAM! it worked instantly...feel like fool working over and over with the other password that works everywhere but with Outlook desktop app.
    Tuesday, February 26, 2019 1:17 AM
  • I’ve been through all of the suggestions but to date I have not been able to resolve the problem.

    Maybe my problem is slightly different.

    I have an Exch 2016 recently migrated from 2010 and the Troublesome Outlook is 2016 with 2 exch mailbox accounts and 2 E3 accounts (each a different domain).

    I also have a machine with Outlook 2016 and the 2 exchange mailboxes which works fine.

    The issue I have is the screen requesting the account password is for a Microsoft (live) Account but it is requesting for a .local Domain which of course can not exist as a Microsoft account.

    I tried to attach a screenshot but it did not seem to work

    I have tried 2 registry changes which have not worked.

    I’m not sure that this addresses a setup like this Outlook has!

    Any assistance would be much appreciated


    • Edited by Bill Hind Friday, March 22, 2019 11:53 AM misprint
    Friday, March 22, 2019 11:52 AM
  • 4 Years later and its still broken!

    Why can't I just use my freakin @outlook.com account with the Outlook app?? The website work fine! Why the loop password reentry request? This is flawed and the entire programing team needs to get fired. It's frustrating and petty when everything else works except Outlook! Is it not made by Microsoft?? All I'm saying is after many years this is still tedious!



    • Edited by iciconnect Sunday, June 16, 2019 4:07 AM
    Sunday, June 16, 2019 4:06 AM
  • Yes! This one worked for me :-) Thank you!
    Friday, October 11, 2019 11:35 AM