Not sleeping due to : \FileSystem\srvnet RRS feed

  • General discussion

  • I found the solution for my sleeping trouble... well... the computer anyways...

    running powercfg -energy

    showed the \FileSystem\srvnet   was preventing sleep -

    I saw the MS folks saying to update the network adapter, and there was an update (wasn't showing up in windows update, just the right click update driver via manager), and that didn't work.

    I even enabled the reg key for the 'allow sleep with remote opens' - and that didn't work..

    Even allowed machine to enter sleep while streaming via the power cpl - didn't work

    Finally went to:
    Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings

    And under media streaming - blocked all - and that did the trick!  I don't know if there's another way to allow streaming and enable sleeping, but for now, beats running all night long after waking for a time update etc... :-)

    Good luck -
    • Changed type Ozark Canuck Saturday, December 12, 2009 5:00 PM
    Saturday, December 12, 2009 4:59 PM

All replies

  • Thank you for sharing the solution. :)
    Monday, December 14, 2009 6:57 AM
  • On Windows 8 did not worked for me:

     I've even left the homegroup, removed all media sharing (blocked), changed the property in power configuration to allow sleep while sharing media, added the powercfg /requestsoverride


    No effect, PC does not sleep automatically. I have to press the sleep button (or choose it from the menu) every time. Super annoying


    Additional info: with Win 7 ultimate everything was fine. I did a fresh W8 installation and now I have the issue




    Tuesday, December 4, 2012 10:07 AM
  • Same thing here. This was working in Win8 (fresh install) and stopped around a week ago. Not sure what happened!
    Friday, December 21, 2012 4:58 PM
  • Same as JakesterPDX...............working until 3 weeks ago.   POWERCFG says AVRNET is keeping it awake.  I cannot get around that.
    Saturday, December 29, 2012 8:29 PM
  • This trick is working fine also for Windows 8 Pro + Media Center PAck

    It's really weird that simply editing the current "Power Plan" to "Allow the computer to sleep" under the node "Multimedia settings" \ "When sharing media" does not the trick ?!

    Valéry Letroye

    Tuesday, January 8, 2013 9:50 PM
  • I was getting the same message and my HTPC was not sleeping when it was supposed to.  The Powercfg -requests mentioned a local device was requesting the system not sleep.  After watching the TCP connections in Resource Monitor, I realized the system was talking to my TV.

    I then remembered I had previously set the system up to be a media server for the TV, which did not work of course.  When I removed it from the TV list of Media Servers, the problem went away.

    Thursday, February 28, 2013 4:23 PM
  • AFAIS, the only way to disable this service is through the services MMC.

    Run services.msc, select "Windows Media Player Network Sharing Service", double click it, and select for Startup type: DISABLED.

    After that, no more \FileSystem\srvnet and Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings\Share media with devices is grayed out.

    Sunday, April 14, 2013 2:28 PM
  • Gentlemen, please see a related topic that contains an automated solution allowing you to check if the srv service is locking your PC from going to sleep and restarting it to remove the lock and let the PC to sleep. Here it is: Windows 8 does not go to sleep - how to identify the device/app preventing sleep

    I quote the automated solution from that topic (all regards must go to the original author, Luke Hamburg):


    Ok, I wanted to post this in case it benefits anyone. After tearing lots of hair out over this for months on end, I never did find any "magical setting" that eliminated the problem for good. For a while the problem disappeared on its own, but then a few weeks ago it mysteriously came back. I was fed up and so I came up with a solution that fixes the problem for me. It's not the most elegant thing in the world but it has worked for me and if you follow the steps below, you should be able to set it up without too much trouble.  Hopefully MS will officially address this (if it's even their bug which remains to be seen) but for now, try this out and let me know if it works for you:

    1. create a batch file, name it "C:\Scripts\restart_srv.cmd" containing the following content:

    @echo off
    set logfile="%TMP%\srvlog.txt"
    if exist %logfile% goto begin
    echo [%date:~4,10% %time%] logfile created>%logfile%

    echo -->>%logfile%
    echo [%date:~4,10% %time%] srvnet check triggered>>%logfile%
    openfiles /Query 2>NUL | FIND /C "INFO: No shared open files found" >NUL
    if errorlevel 1 goto yes_opens
    echo [%date:~4,10% %time%] no open files, proceeding to check for srvnet driver block>>%logfile%
    powercfg -requests | find /C "[DRIVER] \FileSystem\srvnet" >NUL
    if errorlevel 1 goto no_srvnet_block
    echo [%date:~4,10% %time%] **block detected, restarting srv**>>%logfile%
    net stop /y srv >NUL 2>NUL
    goto :eof

    echo [%date:~4,10% %time%] open files detected, not restarting srv>>%logfile%
    goto :eof

    echo [%date:~4,10% %time%] no srvnet block detected, not restarting srv>>%logfile%
    goto :eof

    2. launch Task Scheduler (taskschd.msc)

    3. create a new task called "Restart srv" and set it up like the screenshots below (start at midnight, repeat every hour for 24 hours)

    4. (this step is ** optional ** -- You only need to do this if you want to be able to manually kick off this task easily via a desktop icon)

    create a new shortcut, with the following attributes:
    - target=C:\Windows\System32\schtasks.exe /run /tn "Restart srv"
    - run: minimized
    - icon: %SystemRoot%\system32\SHELL32.dll (red NO)

    5. Fire off the task manually (either by double clicking the shortcut from step 4 or by manually running the Task via right-click: Run from within Task Scheduler) and check the logfile created by the task (open %TMP%\srvlog.txt with notepad) to make sure it's doing its job:

    Good luck and hope this helps some people who are paying needless $$ for their insomniac PCs! :)


    Well this is the world we live in And these are the hands we're given...

    Sunday, April 14, 2013 5:57 PM
  • A solution in another thread worked for me.

    Take all the computers on the network out of the homegroup.  Turn them all off.  Boot your computer and re-create the homegroup.  Add each other computer back in.

    I did this and the "active remote client" hasn't shown up yet.

    BTW I monitored the powercfg requests using the following batch file, run as administrator:

    echo off
    time /t
    powercfg -requests | find " "
    : Delay 30 seconds
    ping -n 1 -w 30000 > nul
    goto fooey
    Monday, August 5, 2013 2:43 AM
  • * THIS MAY WORK !! *    WIN-8

    In the process of setting up a "task" in the "Task Scheduler," as described in this discussion, I noted that there were five or six scheduled "tasks" for backing up and or synchronizing documents, photos, etc. to various drives that were not on my PC. After looking at the script and description for these tasks I noted that they included the word SanDisk, Kingston, Seagate, etc. Disabled them (right side of the Task Scheduler window) and it slept a few times. Do this step with great caution BACKUP FIRST. At least turn on Restore and create a restore point. I then did a word search on the manufactures name of the offending scripts and DELETED them.

    It Worked for me.  

    Some of these thumb drives, and MANY of the USB External HDD's have built-in S/W and I may have tried them. Seagate started just like a CD disk for a program when I plugged it in and that was the worse offender! Somehow it ended up where I do not want it. I KNOW I "un-installed" any thing I did not want BUT some programs do not uninstall nicely from WIN-8.

    I take no responsibility if deleting portions of the registry breaks your PC - Especially if you do not back it up.

    Friday, September 27, 2013 10:39 PM
  • I've been wrestling with this issue for a long time.  I'm running Windows 7 x86.  I received the "active remote client".  I simply removed the computer from the Home Group and all is good.  I still have sharing enabled and it's working.  Thank you all!
    Sunday, January 5, 2014 8:26 PM
  • I wanted to mention something else that could be causing this before you go start changing home groups and sharing settings (because there are a lot.)

    I get this problem from time to time and it's always the 'print spooler'.  I use a laptop and plug it in to my old, laser printer that doesn't have up-to-date drivers (because none are available for Win 7).  Sometimes a document will fail to print and even though I delete it from the print que, the print spooler continues to run.  

    To see if this is your problem, type 'services msc' into the command line in the Windows Menu (7), look for 'Print Spooler', if status is 'running', right-click and choose 'stop'.  Then buy a new printer ....

    Thursday, March 20, 2014 3:10 PM
  • Thanks Btroms. Print spooler is what was causing the problem for me in Win 8.1 as well.
    Wednesday, August 13, 2014 4:42 PM
  • On Win 8.1 Pro, going to 'Change Advanced Sharing Settings' and clicking around seemed to do the trick for me. Thanks Geoff!
    • Edited by scarcrowe4 Tuesday, December 2, 2014 11:27 PM
    Tuesday, December 2, 2014 11:27 PM
  • I tried all the suggestions, using powercfg, device manager, etc., but disabling Windows Media Player Network Sharing Service finally worked.  Days of work to eliminate this issue.  I recently upgraded from 7 to 10 and this is when the issue occurred.
    Wednesday, December 9, 2015 10:38 PM
  • Thank you Geoff,

    I have looked for a solution for many days now.

    I first asked myself what application was continuously active, or on stand by on my pc so to prevent my PC to switch automatically to sleep mode. I then deactivated all automatic actions and selected them as  action on demand, such as defrag, automatic security analysis and kept the security ESet on real time verification, without automatic analysis.

    I especially programmed the media streaming to ''all blocked'' as suggested by you. The combination of those actions worked and my programmed sleep mode via the control panel works just fine.


    I run on win 10 pro. My machine is an old one ( Dell Inspiron 530) and my  new GPU is GeForce 730XT.

    My only concern now is that my PC is highly sensitive to vibrations and pulls my PC out of the sleep mode. What an irony !!


    I Thank you for your great help Geoff


    Sutton, Canada

    Additional comments

    Now i  know why my pc pulls out of the sleep mode. I made sure that in device manager all devices did not have the ''allow this device to pull  out of the sleep mode '' unchecked in the power management button.   ( except for the keyboard and the mouse )Also i realized that Cortana was also on stand by all the time. As far as Cortana, i realized that 4 out of 5 times i would get a wrong answer to a voice request. So i unplugged the microphone and deactivated Cortana. ( not eliminated )

    I also put Skype on hold since i  do not use it very often.

    i just did a test. I started a manual  EsEt security verification ( which takes about an hour and a half to complete) and let it go. The PC went into sleep mode as programed. I have ''awaken'' the pc and realized that the security check had only been put on hold and resumed when the PC was awaken.

    To make it a short story, I realize that i almost forgot how the machine worked. It was thinking for me and not me for the machine. I had my fist computer 35 years ago. It was a Macintosh and i loved it since i was telling the machine what to do and how to do it. Today, the machines are built  to think by themselves.

    Good night all.



    • Edited by MickeySutton Thursday, March 24, 2016 5:37 AM addon to my comments
    Wednesday, March 23, 2016 4:29 PM