After disabling a user mailbox and recreating a fresh mail box ,email are received on a recipient inbox when other staff send emails from OWA, but not for outlook client RRS feed

  • Question

  • Hi

     We use exchange 2007 and outlook 2010
     One of the user left our organisation year ago and have started again now and there are 1000s of mails  on her mail box  and his user name is JSA
     Rather than deleting these emails manually , I disabled his mail box  as shown from the link below and created a fresh mail box.

     Since after creating this mail box I can see some mails have come to this mail box ,  but whatever emails that are in the mail box are the ones that was sent through the distribution groups and this user is member of these distribution group.
     What I observed is if any staff sends an email only to JSA from outlook client, the email doesn’t come to JSA inbox. But if any staff sends from OWA the mail is received on the JSA inbox.

     So not sure what is happening in the background. Please see below the delivery failed message. Is it a good idea to completely delete this account from the AD and create a new account by this name and created a fresh mailbox again and add this user to all distribution group?
     Any help much appreciated.

     Delivery has failed to these recipients or distribution lists:
     James Sanu
     The recipient's e-mail address was not found in the recipient's e-mail system. Microsoft Exchange will not try to redeliver this message for you. Please check the e-mail address and try resending this message, or provide the following diagnostic text to your system administrator.
     Sent by Microsoft Exchange Server 2007
     Diagnostic information for administrators:
     Generating server: HAE.domain.local
     #550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##
     Original message headers:
     Received: from HAE.domain.local ([fe80::d18b:bb7b:a79:46d5]) by
      HAE.domain.local ([fe80::d18b:bb7b:a79:46d5%12]) with mapi; Sun, 17 May 2015
      22:03:03 +0100
     Content-Type: application/ms-tnef; name="winmail.dat"
     Content-Transfer-Encoding: binary
     From: Test Staff <teststaff@School.sch.uk>
     To: James Sanu
     Date: Sun, 17 May 2015 22:03:01 +0100
     Subject: testemail
     Thread-Topic: testemail
     Thread-Index: AdCQ5NFfHZVmatKMTT6q5+rZ+qaeWg==
     Message-ID: <D1A27BDCA2A59E469CDCA836EBF2238D5D7711ABE2@HAE.domain.local>
     Accept-Language: en-US, en-GB
     Content-Language: en-US
     X-MS-TNEF-Correlator: <D1A27BDCA2A59E469CDCA836EBF2238D5D7711ABE2@HAE.domain.local>
     x-vipre-scanned: 8373B685009D7E8373B7D2
     MIME-Version: 1.0

    Sunday, May 17, 2015 11:34 PM

All replies

  • Hi ,

    You need to convert the below mentioned value in to X500 address.


    Reference link :  http://msexchangeguru.com/2012/03/15/x500/

    Thanks & Regards S.Nithyanandham

    Monday, May 18, 2015 6:07 AM
  • Hi ,

    An alternate solution would be to clear the autocomplete cache on the outlook clients but it is not an advisable solution .So please add the x500 address to the newly created mailbox.

    Thanks & Regards S.Nithyanandham

    Monday, May 18, 2015 6:11 AM
  • Hi

    Please post me some tutorials as how to add the x500 address to the newly created mailbox


    Monday, May 18, 2015 7:54 AM
  • Hi ,

    Below is the reference link which would give you a depth understanding about legacyDN .


    Mailbox -->Right Click --->Properties -->EmailAddresses--->Add Custom Address

    Then you will get the below mentioned prompt.

    On the E-mail address please provide the x500 value which you are going to create from NDR and on the E-mail type just give the value as x500

    Thanks & Regards S.Nithyanandham

    Monday, May 18, 2015 8:29 AM
  • Hi,

    I understand you got the NDR 550 5.1.1 RESOLVER.ADR.ExRecipNotFound when sending email to JSA .

    Please  follow below steps to add X500 address on user  "JSA":

    Open Adsiedit.msc -- go to Properties of JSA -- check the attribute “legacyExchangeDN” which is set to “Not Set” -- add the following value: /O=SCHOOL/OU=DOMAIN/cn=Recipients/cn=JSA@school.sch.uk

    Go to properties of JSA in Exchange Management Console -- Select Email Address tab --Add a custom address called “X500” and value for it is /O=SCHOOL/OU=DOMAIN/cn=Recipients/cn=JSA@school.sch.uk

    If it doesn’t work, please try to turn off the cached mode on  JSA’s  outlook and check whether the issue persists.

    Best Regards,


    Monday, May 18, 2015 8:53 AM
  • I went to Get-Mailbox JSA | fl LegacyExchangeDN

    [PS] C:\Windows\system32>Get-Mailbox JSA | fl LegacyExchangeDN
    LegacyExchangeDN : /o=school/ou=Exchange Administrative Group

    [PS] C:\Windows\system32>

    so the Email address i put:  /o=school/ou=Exchange/cn=Recipients/cn=JSA
    E-Mail Type: X500

    If I send the email still it doesn't land in JSA mailbox.

    As per David

    I Opened Adsiedit.msc -- go to Properties of JSA -- check the attribute “legacyExchangeDN” which  was set to the following:

    /o=school/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=JSA

    Do I need to remove the above value and add: /O=SCHOOL/OU=DOMAIN/cn=Recipients/cn=JSA@school.sch.uk


    • Edited by bindu143 Monday, May 18, 2015 9:51 AM
    Monday, May 18, 2015 9:50 AM
  • Hi

    Please post me some tutorials as how to add the x500 address to the newly created mailbox


    Have a look at this if you experience something in the feature: http://www.inthecloud247.com/exchange-error-550-5-1-1-resolver-adr-exrecipnotfound/

    Describes how to convert a IMCEAEX to X500 address

    Thursday, March 2, 2017 3:07 PM