none
Project Server with SharePoint 2010 HTTPS SSL setup issues RRS feed

Answers

  • Turned out Extending the SharePoint Web App (Smith – 80) in my example works fine with the settings in the image above. The issue was actually 2 fold.

     

    1.       The certificate was the wrong one

    2.       The load balancer needed to be reconfigured.

     

    I’d give you more details on how the load balancer needed to be reconfigured, but that was done by the networking guy, so I don’t know much about it.

     

    To clarify Excel services (view excel in web), SSRS integration, and Project Web apps work with no other changes from the SharePoint configuration side.

     

    Thank you for your replies!

    • Marked as answer by SoCalSpAdmin Friday, June 3, 2011 5:08 PM
    Friday, June 3, 2011 5:08 PM

All replies

  • Primafacie looks like AAM mapping issue, however let us know the steps you followed in a little more detailed, and we should be able to give you correct pointers,

    Some time back the same scenario i did posted on my blog, although you have already gone through many articles / blogs but may be it could give you a hint,

    Note : there is a glitch to it is, either you will have to settle down for HTTP mode or HTTPS mode, as web part property cannot be set dynamically

    http://epmxperts.wordpress.com/2011/03/05/extend-same-project-web-app-instance-for-different-protocol-authentication-mechanism/

    Hope this helps


    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com
    Saturday, April 23, 2011 10:46 AM
    Moderator
  • Thanks for the response. Here is what the Web application list looks like in Central Admin

    Central Admin Web Apps

     

    Here are the settings I used to Extend the SharePoint Web App.

     

    Extend Web App Settings

    Update on the configuration. The above settings only allow me access to the root site collection any child collections give a 404 error page, however if in the “Extend Web App” settings I change “Use SSL” to NO and have the public URL as http://smithTest.mycompany.com, then I can navigate to the children site collections and the url will be https://smithTest.mycompany.com.

     

    I can also navigate to the Project web app Home page, but any page in the project web app will error with 404.

     

    Additional settings are that there is a load balancer between my 2 Web Front Ends.

     

    I did read your blog and I thought I missed the step of adding the certificate, but it’s there. Any thoughts or questions?


    • Edited by SoCalSpAdmin Wednesday, April 27, 2011 11:51 PM fix image
    Wednesday, April 27, 2011 11:48 PM
  • Hello,

    If You have created your project site with the URL http://smithTest.mycompany.com and then if you have extended the same URL then it should work

    For enable SSL on your PWA you must EXTEND the PWA web application with SSL enable.
    After you can go to IIS and configure Certificate in the new IIS site for your PWA in SSL.
    If PWA site work fine in SSL you can "Remove SharePoint from IIS Web Site" in Central Admin - Application Management.

    If you need more details see this: http://technet.microsoft.com/en-us/library/cc262668.aspx


    And in the query i found that the provisioned project site URL as a subsite which should be the main site.

     

    Let us know your updates.

    Friday, April 29, 2011 10:31 PM
  • Turned out Extending the SharePoint Web App (Smith – 80) in my example works fine with the settings in the image above. The issue was actually 2 fold.

     

    1.       The certificate was the wrong one

    2.       The load balancer needed to be reconfigured.

     

    I’d give you more details on how the load balancer needed to be reconfigured, but that was done by the networking guy, so I don’t know much about it.

     

    To clarify Excel services (view excel in web), SSRS integration, and Project Web apps work with no other changes from the SharePoint configuration side.

     

    Thank you for your replies!

    • Marked as answer by SoCalSpAdmin Friday, June 3, 2011 5:08 PM
    Friday, June 3, 2011 5:08 PM