locked
Scom 201 R2 - AD Management Pack Operations Manager > AD_General_Response.vbs > failed to start a process RRS feed

  • Question

  • Hi

    i have an issue with SCOM Monitoring Pack for Active Directory Version 6.0.8293.0 on our Windows Server 2012 R2 Domain Controllers:

    Warning:

    Der um 10:15:45 gestartete Prozess wurde wegen eines Fehlers beim
    Zusammenstellen der Ausgabe beendet, der aufgrund des Fehlers '0x80070057 : The
    parameter is incorrect.
    ' aufgetreten ist. Möglicherweise sind einige Daten
    verloren gegangen


    Ausgeführter Befehl:
    "C:\Windows\system32\cscript.exe" //nologo "C:\Program Files\Microsoft
    Monitoring Agent\Agent\Health Service State\Monitoring Host Temporary Files
    216\152329\AD_General_Response.vbs" "DC.fq.dn" 4 false
    {ECB4615B-45A1-5810-81AB-EC034AB2FEA7} true false
    Arbeitsverzeichnis:
    C:\Program Files\Microsoft Monitoring Agent\Agent\Health Service
    State\Monitoring Host Temporary Files 216\152329\


    Mindestens ein
    Workflow ist hiervon betroffen.


    Workflowname:
    Microsoft.Windows.Server.2008.AD.DomainController.LastBindMonitor.Monitor

    Instanzname:
    "DC.FQ.DN"

    Instanz-ID:
    {FC92708F-8C57-DACC-B992-D43EE6EFD331}

    If i run this command on the DC, i receive following Output:

    Command:

    "C:\Windows\system32\cscript.exe" //nologo "C:\Program Files
    \Microsoft Monitoring Agent\Agent\Health Service State\Monitoring Host Temporary
     Files 216\152329\AD_General_Response.vbs" "DC.FQ.DN" 4 false {EC
    B4615B-45A1-5810-81AB-EC034AB2FEA7} true false

    Output:

    <Collection><DataItem type="System.PropertyBagData" time="2014-09-25T11:55:25.00
    17189+04:00" sourceHealthServiceId="B2EF175D-8024-6168-C41B-9A3C0233265F"><Conve
    rsionType>StateData</ConversionType><Property Name="State" VariantType="8">GOOD<
    /Property><Property Name="EventID" VariantType="8">1091</Property></DataItem><Da
    taItem type="System.PropertyBagData" time="2014-09-25T11:55:25.0017189+04:00" so
    urceHealthServiceId="B2EF175D-8024-6168-C41B-9A3C0233265F"><ConversionType>Perfo
    rmanceData</ConversionType><Property Name="StatusInstance" VariantType="8"></Pro
    perty><Property Name="StatusValue" VariantType="8">0.016</Property></DataItem></
    Collection>

    Is there maybe something to set in Region Options - i have allready tried to set Decimal Symbol to "." and Digit Grouping Symbol to "," - but i receive same warning on ou DCs in all Countries.

    Maybe someone can give me some hints

    thx

    Christian

    Thursday, September 25, 2014 8:18 AM

Answers

  • Hi,

    Whether those SCOM agents are manually installed on the Domain Controllers? This issue may be caused by required files missing from the Installation folder.

    Uninstalling the agent and installing the agent using discovery method is one option to resolve this issue.

    Regards,

    Yan Li


    Regards, Yan Li

    • Marked as answer by Yan Li_ Monday, October 6, 2014 2:00 AM
    Friday, September 26, 2014 5:52 AM

All replies

  • Hi,

    Whether those SCOM agents are manually installed on the Domain Controllers? This issue may be caused by required files missing from the Installation folder.

    Uninstalling the agent and installing the agent using discovery method is one option to resolve this issue.

    Regards,

    Yan Li


    Regards, Yan Li

    • Marked as answer by Yan Li_ Monday, October 6, 2014 2:00 AM
    Friday, September 26, 2014 5:52 AM
  • HI,

    SCOM Client was Deployed by SCOM - Folders and Files are existent on the Server, but the users has not enough rights to run the scripts. After adding the AD MP User Account to Domain Admins this Script runs without Errors.

    thx

    Wednesday, October 29, 2014 9:59 AM
  • Greetings,

    I have the exact same issue - except the error message is in Dutch here :)

    It is happening on a brand new SCOM 2012 R2 infrastructure, and the alert is popping on every (RO)DC.

    On our old SCOM 2012 infrastructure, the error didn't happen, and I've never had to configure the AD MP Run As to be in the domain admins or anything.

    Note: the agents on the (RO)DCs have been deployed through the console, using the discovery Wizard and everything went fine.

    Any clue on how to solve this efficiently?


    Bix

    Tuesday, December 2, 2014 11:49 AM
  • Hi,

    We have a similar alert since few weeks on my DCs and can't figure out how to resolve it.

    I don't really want to add the MP runAs account in Domain Admins for security reasons also.

    Does someone already worked out this alert in a proper way ?

    We have SCOM 2012 R2 UR4 / Server 2008 Domain Controllers. MP AD 6.0.8293

    Julien

    Wednesday, March 4, 2015 3:38 PM