none
Exchange 2013 - can not upload apps RRS feed

  • Question

  •  Log in to ECP -> Organiztion -> APPS

     Below error reported after selecting APPS

     Error: The request failed. unable to connect to the remote server.

     Note: Same error reported on other exchange 2013 servers.

    Thursday, June 12, 2014 6:02 PM

Answers

All replies

  • What you briefly described was a problem with Exchange 2013 SP1/CU4 when installed on Window Server 2012 R2 - Fixed in CU5.

    Default apps in Outlook Web App do not work if Exchange is installed in Window Server 2012 R2
    http://support.microsoft.com/kb/2938292


    Martina Miskovic

    Thursday, June 12, 2014 6:45 PM
  •  SP1 CU5 is already installed.

     this is also happening on windows 2012 server.

     I don't have certificate installed. dose apps look for certificate?

     Regards

     Rajesh

    Thursday, June 12, 2014 6:53 PM
  • Yes, https is used and here is one short snip from one of the paths that is used:

    <SourceLocation DefaultValue="https://mail.domain.com/owa/0742d1cc-21b1-4853-b434-f053919b861e%40domain.com/prem/15.0.913.22/ext/def/f60b8ac7-c3e3-4e42-8dad-e4e1f
    ea59ff7/suggestedtasks.html" />

    Get-App -OrganizationApp | fl manifestxml


    Martina Miskovic

    Thursday, June 12, 2014 7:13 PM
  • [PS] C:\Windows\system32>Get-App -OrganizationApp | fl manifestxml
    The request failed. Unable to connect to the remote server
        + CategoryInfo          : InvalidOperation: (:) [Get-App], OwaExtensionOperationException
        + FullyQualifiedErrorId : [Server=EX1CVTEST2013,RequestId=3863aa23-27ae-4c06-a8da-b17a439e9282,TimeStamp=6/12/2014
        7:30:17 PM] [FailureCategory=Cmdlet-OwaExtensionOperationException] 200DEEAE,Microsoft.Exchange.Management.Extens
      ion.GetApp
        + PSComputerName        : XXXXXX.YYYYYY.ZZZZZZZ.com

    Please let me know whether Self SSL will help or not?

    Thursday, June 12, 2014 7:34 PM
  • An Exchange Server should have a certificate that is trusted by the clients installed, Yes.

    Digital Certificates and SSL
    http://technet.microsoft.com/en-us/library/dd351044(v=exchg.150).aspx


    Get-App reads information from one of the Arbitration Mailboxes, so make sure its available in a database that is mounted (Get-Mailbox -arbitration | ft Name, database)


    Martina Miskovic

    Thursday, June 12, 2014 7:53 PM
  •  Thanks!!! will check and get back to you.

    Regards

    Rajesh

    Thursday, June 12, 2014 10:25 PM
  •  I had issue with one of the arbitration mailbox, deleted  ad account, ran adprep and re-created mailbox. 

    Error:

    [PS] D:\RU5>Get-App -OrganizationApp | fl manifestxml
    The request failed. The operation has timed out
        + CategoryInfo          : InvalidOperation: (:) [Get-App], OwaExtensionOperationException
        + FullyQualifiedErrorId : [Server=EX1CVTEST2013,RequestId=4a69f46d-5cc1-4299-a5ae-a7416207181a,TimeStamp=6/12/2014
        10:45:06 PM] [FailureCategory=Cmdlet-OwaExtensionOperationException] B6E4AE10,Microsoft.Exchange.Management.Exten
      sion.GetApp
        + PSComputerName        : WWWWWW.XXXX.YYYYY.com

     Note: Verified all the arbitration mailboxes are acessable

    Arbitration mailboxes:

    FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042
    SystemMailbox{1f05a927-168e-4658-b14f-5353451a82b0}
    SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}
    SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}
    Migration.8f3e7716-2011-43e4-96b1-aba62d229136

    Thursday, June 12, 2014 10:52 PM
  •  Moved all the arbitration mailboxes to one database. Everything looks good now.


    [PS] D:\RU5>Get-App -OrganizationApp | fl manifestxml


    ManifestXml : <OfficeApp xmlns="http://schemas.microsoft.com/office/appforoffice/1.0"
                  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="MailApp">
                    <Id>7A774F0C-7A6F-11E0-85AD-07FB4824019B</Id>
                    <Version>1.0</Version>
                    <ProviderName>Microsoft</ProviderName>
                    <DefaultLocale>en-us</DefaultLocale>
                    <DisplayName DefaultValue="Bing Maps" />
                    <Description DefaultValue="Map addresses found in your email." />
                    <IconUrl 
    Friday, June 13, 2014 1:30 PM