locked
Error while installing certificate on IIS RRS feed

  • Question

  • Hi all, sorry for my poor English.

    I'm battling with renewing ssl certificate on server and stuck at adding crt file to iis manager with this error

    Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

    As I can see It's pretty common error and solution is to set full control to "Administrators" group on folder

    C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys

    But when I'm trying it, I'm getting error:

    Error applying security ... Failed to enumerate objects in the container . Access is denied.

    I'm also tried it on local machine and get same error.

    Also, I tried to install certificate on server just with right click on file ad "Install certificate", but it doesn't show at snippet Personal certificates either. 

    Any advices?

    Tuesday, March 19, 2019 3:05 PM

All replies

  • Hello Rezer02,

    Have you created CSR code on the server you are trying to install certificate ?


    Mark it as answer if your question has solved. MCT Regional Lead. x2 MCSE-MCSA Exchange Server & Windows Server

    Tuesday, March 19, 2019 3:12 PM
  • No, I got .crt file from domain name registrar. Should I create CSR code, then sign it with private key with openssl instead?
    Tuesday, March 19, 2019 4:18 PM
  • in order to install certificates you must download the cert file from the third party CA and import it to the server that you generated the original CSR.

    from there, you can export the certificate and this will include all of the certificate chain and keys required to import to any server thereafter.

    Wednesday, March 20, 2019 5:15 AM
  • I've got the same result. Error 
    Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
    Wednesday, March 20, 2019 9:27 AM
  • Hi Razer02,

    Looks like you still have permissions issues. First, could you check the effective permissions on the C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys folder? Let's see precisely what's going on.

    Also, could you check if there are any signs of UAC (https://docs.microsoft.com/en-us/windows/desktop/uxguide/winenv-uac) kicking in? Some programs can't cope and revert to Access Denied.

    Kind Regards,

    Thursday, March 21, 2019 7:50 AM