none
remote registry service

    Question

  • Hey all,

    How can I enable the remote registry service remotely for all my clients from the server? I have configured the policies for the service; set it on automatic and start. I rebooted a client and went to the services but remote registry is still not running, the startup type automatic (trigger start).

    Thanks 

    Wednesday, December 03, 2014 1:34 PM

All replies

  • Are you sure that your GPO applied to the computers? Run a GPResult to double check.

    Do you see any errors in the System event log saying why the service didn't start?


    If my answer helped you, check out my blog: Deploy Happiness

    Wednesday, December 03, 2014 1:56 PM
  • yes we need to see if you applied this correctly.  gpresult /h c:\report.html -f look at the root of the c:\ and post the report back using one drive or similar
    Wednesday, December 03, 2014 2:13 PM
  • Found this in the event viewer: The remote registry service failed to start die to the following error:

    The account specified for this service is different from the account specified for other services running in the same process

    Wednesday, December 03, 2014 2:23 PM
  • System Services
    Remote Registry (Startup Mode: Automatic)
    Winning GPO remote registry
    Permissions
    Type Name Permission
    Allow BUILTIN\Administrators Full Control
    Allow NT AUTHORITY\SYSTEM Full Control
    Allow NT AUTHORITY\INTERACTIVE Read
    Auditing
    Type Name Access
    Failure Everyone Full Control
    Services
    Service (Name: RemoteRegistry)
    The following settings have applied to this object. Within this category, settings nearest the top of the report are the prevailing settings when resolving conflicts.
    RemoteRegistry
    Winning GPO remote registry
    Result: Success
    General
    Service name RemoteRegistry
    Action Start service
    Startup type: Automatic
    Wait timeout if service is locked: 30 seconds
    Service Account
    Log on service as: No change
    Recovery
    First failure: No change
    Second failure: No change
    Subsequent failures: No change
    remote registry [{21DB2736-E9C7-4D3A-AF78-8FA7EE981C42}]
    Link Location testlab.bunnik.netherlands
    Extensions Configured Group Policy Services
    Security
    Group Policy Infrastructure
    Enforced No
    Disabled None
    Security Filters NT AUTHORITY\Authenticated Users
    Revision AD (10), SYSVOL (10)

    Wednesday, December 03, 2014 2:36 PM
  • > The account specified for this service is different from the account
    > specified for other services running in the same process
     
    By default, remote registry runs as "Local Service" (S-1-5-19). Correct
    that issue and try again.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Wednesday, December 03, 2014 3:00 PM
  • > Type     Name     Permission
    > Allow     BUILTIN\Administrators     Full Control
    > Allow     NT AUTHORITY\SYSTEM     Full Control
    > Allow     NT AUTHORITY\INTERACTIVE     Read
     
    Why on earth are you configuring service permissions?
     
    > Service name     RemoteRegistry
    > Action     Start service
    > Startup type:     Automatic
     
    And why do you change service configuration in two different places?
     
    > *Service Account*
    > Log on service as:     /No change/
     
    Was this "no change" from the very beginning? Since the GP version is
    10, there were quite some changes over time...
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Wednesday, December 03, 2014 3:01 PM
  • I haven't configured the permissions. I only changed action and startup time. No change was default setting
    Wednesday, December 03, 2014 3:33 PM
  • Where do i have to configure to network service? on the client it shows as network service. on the server as local service does that have to be network service?
    Wednesday, December 03, 2014 4:23 PM
  • Local Service
    Thursday, December 04, 2014 11:07 AM
  • its still on trigger start
    Friday, December 05, 2014 10:11 AM