Connect Ubuntu 12.04 VM with Wireless NIC RRS feed

  • Question

  • How can I connect the VM to the internet via my wireless NIC?

    It works just fine when I create a virtual switch from my wired ethernet card, but while Ubuntu can see the connection if it is wireless, it cannot connect to it.

    How can I fix this?

    Hyper-V Manager Version: 6.2.9200.16384
    Host OS: Windows 8 Pro
    Guest OS: Ubuntu 12.04 64-bit
    Wireless NIC: Aethros AR9285

    • Edited by soandos3 Friday, October 5, 2012 8:29 AM
    Friday, October 5, 2012 8:26 AM

All replies

  • Hmm, never done this by now wih Hyper-V but conceptionally I don't think Ubuntu will know that's its a WiFi card since the only 2 NICs supported in guests are the paravirt (hv_net) and emulated (tulip) ethernet cards.

    As the VM gets connected to a virtual switch, which in turn is connected to a physical device - a ethernet or a wifi adapter it's should up to the wifi card on the host side to connect to the wifi network. Once connection is established via the host side, the VM should be able to connect to your network and if yo have a DHCP server in your network, get a IP address.

    At least I have done same with VirtualBox on my Laptop and such thing worked, bt has also been whacky sometimes depending on the network.

    Sunday, October 7, 2012 1:09 PM
  • Its a Hyper-V problem then?
    Sunday, October 7, 2012 4:34 PM
  • I don't understand your question...

    For Ubuntu as guest it will not see any difference to what physical network device it will connect in reality outside of your machine.
    All it sees is a ethernet adapter which is connected to a vSwitch / virtual network.

    It's up to your host to make the WiFi connection, not the guests. I strongly guess the Wifi connection is built up via the parent partition and not the Hyper-V (which in reality is right under your parent partition (your Win 8).

    It may be possible that you have bridge the virtual Switch with your parent partition (your W8) as seen here - this was default back in W2k8, but is not with 2k8R2 (it was a pain back then for other reasons)

    • Edited by koffi2k Thursday, October 11, 2012 12:56 PM
    Thursday, October 11, 2012 12:50 PM
  • I think I understand your problem, and yes, I'm pretty sure it is an issue in Hyper-V.  You've created a virtual switch on a WiFi card and the VM can't get an IP address to connect.  Assign the adapter in the VM a static IP address.  That worked for me when I installed Ubuntu 12.04 on Win8 Hyper-V yesterday.
    Saturday, October 13, 2012 4:44 AM
  • I just installed Ubuntu 12.04 and created virtual switch for my WiFi NIC. When I first connected it, it did not work. I bounced the VM, and it seems to be working just fine now.
    <object height="0" id="plugin0" style=";z-index:1000;" type="application/x-dgnria" width="0"><param name="tabId" value="ff-tab-1" /><param name="counter" value="12" /></object>
    Sunday, December 30, 2012 9:58 PM