none
Wizard.hta blank - The system cannot locate the object specified Control\\TS.XML RRS feed

  • Question

  • Dear TechNet,

    last time my MDT server stoped to work properly. When I boot from PXE and get wizard.hta blank.

    When I capture logs I get:

    <![LOG[Reading \\mdt\DeploymentShare$\Control\\TS.XML]LOG]!><time="11:10:31.000+000" date="12-04-2019" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[File: \\mdt\DeploymentShare$\Control\\TS.XML Line: 0 - The system cannot locate the object specified.
     - ]LOG]!><time="11:10:31.000+000" date="12-04-2019" component="LiteTouch" context="" type="2" thread="" file="LiteTouch">
    <![LOG[FAILURE ( 5495 ): -2146697210  0x800C0006: Create MSXML2.DOMDocument  .ParseErr.ErrCode.]LOG]!><time="11:10:31.000+000" date="12-04-2019" component="LiteTouch" context="" type="3" thread="" file="LiteTouch">
    <![LOG[Event 41002 sent: FAILURE ( 5495 ): -2146697210  0x800C0006: Create MSXML2.DOMDocument  .ParseErr.ErrCode.]LOG]!><time="11:10:33.000+000" date="12-04-2019" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">

    It's strange - I have nothing changed in MDT configuration. Only one thing could happen - Windows Update but there is no info about any KB that breaks MDT... I have Winows Server 2016 x64 1607 and MDT 6.3.8456

    In log i see Control\\TS.XML -looks like path to Task Sequence is not valid. It happens before wizzard with options to choose proper task sequence shows up.



    • Edited by AdTan Thursday, December 5, 2019 10:50 AM
    Wednesday, December 4, 2019 12:04 PM

All replies

  • You have two backslashes after Control?
    Wednesday, December 4, 2019 1:55 PM
  • Yes - in log there are 2 backslashes.
    Wednesday, December 4, 2019 2:04 PM
  • So it appears your TaskSequenceID is null. Probably because the wizard to select one was skipped.

    Check your settings in general and your SkipTaskSequence setting in particular in your .ini files. 

    Per MDT spec: Property value for SkipTaskSequence must specified in UPPER case for deployment scripts to properly read it. I;ve seen the same true for other variables as well. Maybe have you some that inclue lowercase characters


     
    Wednesday, December 4, 2019 9:23 PM
  • I have SkipTaskSequence=NO.

    I had working MDT without problems for months, I have nothing changed on MDT configuration or WDS. Now I tried to import DeploymentShare to new, fresh Windows Server instalation - nothing changed, still broken...


    • Edited by AdTan Thursday, December 5, 2019 9:20 AM
    Thursday, December 5, 2019 8:59 AM
  • I have also created new DeploymentShare, generated boot image and result is the same. After entering credentials wizard.hta is blank.. I have network conectivity, can mount share with used credentials.

    Next thing I  will do is a clean install of windows server without updates.


    • Edited by AdTan Thursday, December 5, 2019 1:50 PM
    Thursday, December 5, 2019 11:02 AM
  • Hi,

    I suffered for one day with this one. I get the very same error trying to use a MDT offline image on a USB disk. The key of the error is:

    \\mdt\DeploymentShare$\Control\\TS.XML

    Normally, between both of you \ should the ID of your task sequence reside. One option that has been explained could be that you set in customsettings.ini a SkipTaskSequence=YES and did not provide the task number (or providing an unexisting one).

    Another option could be because you have errors in XML files (tasksequence.xml, ...) but in that case I would assume that it would be because you edited them by hand. You would need to find a CML validator, like the one integrated in Notepad++ plugins.

    And last, my solution, it could be because your destination disk is not empty. Pretty strange? You need to imagine that, for a reason I cannot completely understand, the install process look for a system partition on your system disk and get trashy results. If you look at the task sequence, you will identify easily that one of them is not formatted. That's the one.

    So to solve: diskpart + list disk (to identify your system disk) + select disk X + clean + exit (for diskpart) + exit (for the cmd windows). At next run: it will magically run smoothly (or you will be stuck with another error :-) )

    Note:

    Cleaning the disk also solve other errors. Try that before anything else.

    Monday, December 16, 2019 6:10 PM
  • +1

    I've seen (and read) of strange things happening if an old MDT install still resides on the destination disk. Good point @Eldertoon.

    Monday, December 16, 2019 6:47 PM
  • As a best practice in the Rules instead to use \\servername\DeploymentShare$\ you should use just %DeployRoot%

    Same when you call a script instead to call \\servername\DeploymentShare$\script\yourscript.bat use better %SCRIPTROOT%\yourscript.bat  

    Wednesday, December 18, 2019 4:45 PM
  • I got same problem. MDT offline boot media causing same error. I found that once I run LTICLEAN AND RUN LITETOUCH it works. But in my case the disk 0 is encrypted so it creates minint on offline USB as temp dir. 

    Is there a way to force minint to be created on x drive or lti clean runs before LITETOUCH script using unattend in PE.


    Desktop Technology Specialist

    Tuesday, September 8, 2020 2:01 PM