none
Cannot paste data into datasheet view RRS feed

  • Question

  • I have a user who is reporting a problem when trying to copy/paste data from Excel 2007 into a MOSS 2007 Datasheet view.  This functionality was working for her previously as recently as last month.  According to the user, she has not had any changes done to her machine recently (same machine, still using IE7, no recent installs).  I tested the copying/pasting feature from my machine and I also cannot paste into the datasheet view.  My colleagues do not have an issue though.  Has anyone run into this problem before?

    My gut reaction is that this is a broswer issue, rather than a SP issue but I am not seeing any browser settings which appear to apply.  Any suggestions?

    Tuesday, April 27, 2010 1:57 PM

Answers

  • All,

    I was able to resolve the issue.  It turned out to be an issue with the Excel file itself.  If we copy/pasted the data in the Excel file to a new worksheet as Values only, we could then copy/paste that into SharePoint.  At some point along the way, the user had made configuration changes to that Excel file.  Once we rebuilt the file from scratch, then both the user & I could paste into SP again.  Many thanks to those of you who proposed solutions.  I've never come across this before and it was a bit perplexing there for a while.

    • Proposed as answer by Paul Lucas Wednesday, April 28, 2010 1:48 AM
    • Marked as answer by Mike Walsh FIN Wednesday, April 28, 2010 3:21 AM
    Tuesday, April 27, 2010 7:50 PM

All replies

  • Sephiro

    On your development environment try creating a new list with the default columns.  From here try editing in datasheet view and copy and paste info into it.  It works for me and it should work for you.  Next is understanding that copying and pasting data in the datasheet view might not work if there are multiple lines of data and the columns from both the source and the destination do not match.


    Kanwal SharePoint Buzz
    Tuesday, April 27, 2010 3:57 PM
  • Kanwal,

    Thank you for the post.  I have tried that and it appears that I still cannot paste into any datasheet view.  Even a newly created standard one with a few basic text columns.  I can also confirm that the columns on the Excel file exactly match the columns in SP.  In my last position, I used to do this all the time and it was never an issue.  I initially thought this might be a browser setting, but the portal site is listed as a trusted site in IE.

    I also tried copying/pasting from Excel 2007 into other applications (Outlook, NotePad, etc...) and that all works fine.  It's just the SharePoint datasheet views which will not allow me to paste information (if I click on a cell in the datasheet twice, so that I can see the cursor, then the paste works but it pastes all of the data into that one cell rather than across the cells).

    Tuesday, April 27, 2010 4:20 PM
  • If Content Approval is enabled on a document library, the datasheet view will always open in Read-Only mode.

    -Mukesh

    Tuesday, April 27, 2010 5:47 PM
  • All,

    I was able to resolve the issue.  It turned out to be an issue with the Excel file itself.  If we copy/pasted the data in the Excel file to a new worksheet as Values only, we could then copy/paste that into SharePoint.  At some point along the way, the user had made configuration changes to that Excel file.  Once we rebuilt the file from scratch, then both the user & I could paste into SP again.  Many thanks to those of you who proposed solutions.  I've never come across this before and it was a bit perplexing there for a while.

    • Proposed as answer by Paul Lucas Wednesday, April 28, 2010 1:48 AM
    • Marked as answer by Mike Walsh FIN Wednesday, April 28, 2010 3:21 AM
    Tuesday, April 27, 2010 7:50 PM
  • Just tried this with a user who has been having the same problems for "ages" no-one found a fix for it - until I read this.

    Thanks.

    Thursday, May 10, 2012 10:44 AM
  • I experienced this issue on a list field that was defined as multiple lines of text where I had 'Enhanced rich text' as the default. Users got a 'read-only' error when attempting to paste data frokm Excel into a record.

    Once I changed the setting in 'Specify the type of text to allow' to 'Plain text', the issue resolved itself.  I hope this infromation helps someone else out there!

    [SharePoint 2010, Excel, paste, read-only, SharePoint list, cannot paste data]






    • Edited by kays day job Friday, July 13, 2012 2:53 PM
    • Proposed as answer by NVGs Wednesday, January 2, 2013 9:04 PM
    • Unproposed as answer by NVGs Wednesday, January 2, 2013 9:04 PM
    • Proposed as answer by NVGs Wednesday, January 2, 2013 9:06 PM
    Friday, July 13, 2012 2:49 PM
  • Also, I have found if you have columns that are pulling Data from another source you will need to remove them as well for this to work.

    Wednesday, January 2, 2013 9:05 PM
  • I know this is an old question, but I found this answer and wanted to add to it:

    1. You cannot paste Multi-Line columns.
    2. You cannot paste Multi-choice checkbox fields.
    3. I removed the calculated fields from my view too. These were a little weird.
    4. Skip the Item Type and Path. (These auto generate)

    Test a couple lines if you are having issues. Also, for fields that are "Choice" fields. You might have to enable "Allow Fill In" if you have any blanks.


    Amber J. Bell Training and Implementation Specialist CAL Business Solutions Inc.

    Saturday, March 29, 2014 5:36 PM
  • Hi All,

    I resolved "datasheet view information cannot be pasted" this issue like the below way.

    1. I copied data from excel and paste into notepad.

    2. Now I copied notepad data and paste into datasheet view. Problem Solved!

    Friday, November 16, 2018 4:06 PM
  • It worked. Many Thanks!
    Thursday, August 22, 2019 6:56 AM