locked
Maybe it's me but I never found anything with Search RRS feed

  • Question

  • Example: I have a test.txt file with the word "computer" inside, into a folder named Text files.

    I open the folder, wite computer in the search field and "No element was found" (more or less, my Windows 7 is in spanish)

    OK, I write content:computer.... nothing

    OK, let's try *.txt content:computer.... nothing

    I ask: this new search works?
    Wednesday, December 23, 2009 8:42 PM

Answers

  • First, I agree with you the Total Commander is very good software, but I still think your Index setting is not correct. You can try the following method to fix your issue. 

    1. Click on the Start Button, type "cmd" (without quotation marks) in the Start Search box. Right-click CMD listed above and click "Run as administrator".
    2. At the command prompt, copy the following command to stop the Search Service:

    net stop wsearch.

    3. Open Registry Editor.
    4. Navigate to the following registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Search

    5. Right click on "Windows Search", click "Export"; please name the file as "RegBackup" (without quotation marks) and then save it to the C:\ drive as a backup. 

    6. If you want to undo the modification, you can double click this RegBackup.reg file to restore the registry key.
    7. Right-click on “Windows Search” and choose Permissions. On the Security tab, verify that Administrator is the owner and has full control of the key.
    8. Within the "Windows Search" registry key, find the SetupCompletedSuccessfully value on the right pane. Double-click SetupCompletedSuccessfully and change its value to 0.
    9. Delete the following registry keys:

    HKLM\Software\Microsoft\Windows Search\Applications\windows
    HKLM\Software\Microsoft\Windows Search\CatalogNames\windows
    HKLM\Software\Microsoft\Windows Search\Databases\windows
    HKLM\Software\Microsoft\Windows Search\Gather\windows
    HKLM\Software\Microsoft\Windows Search\Gathering Manager\Applications\windows
    HKLM\Software\Microsoft\Windows Search\UsnNotifier\windows 

    If the key cannot be deleted, please perform the following steps to take ownership first

    a. Right-click the key and click "Permission"
    b. Click the "Advanced" button.
    c. On the "Owner" tab, verify your account is the current owner. If not, click "Other users or groups" to add your account. Then select your account, check "Replace owner on subcontainers and objects" and click OK on the windows.

    10. Now, run the following command:

    rd %ProgramData%\Microsoft\Search\Data\Applications\Windows /S /Q
    net start wsearch.

    After approximately one minute, check the SetupCompletedSuccessfully registry value and it should now be set to 1 and the Search service should rebuild the index database.

    I hope this would help you.


    John
    • Marked as answer by DrGerry Friday, December 25, 2009 6:30 PM
    Friday, December 25, 2009 8:33 AM

All replies

  • First, I woud like to tell you that this serch function works fine in my english version Windwos 7.

    Can you search for using spainsh?

    In my opinion, your Index setting is incorrect. You can try the following steps to reset the Index setting.

    1. Click on the Start Button, type "Indexing Options" (without quotation marks) in the Start Search box and press Enter.
    2. Click the "Advanced" button.
    3. Change to the "File Types" tab, check "Index Properties and File Contents".
    4. Click on the "Index Settings" tab.
    5. Under Troubleshooting, click the "Rebuild" button.
    6. At last, click OK to close.

    Test if your issue again.

    Good luck!


    John
    Thursday, December 24, 2009 6:10 AM
  • Thanks. One of the reasons I hate the translated versions of the software is this: you never know how the words were translated. I have the spanish version because of the hideous new habit of the software companies: it detect you country and assume you wnat a soft in your language. When I buy W7 I can't get it in english (the windows update let me download the english version, but I can't install it). Even when I am very bad writting in english, I understand it pretty well.

    Anyway, to the topic: finally I  found the "Indexing Options" (opciones de indización) and done what you say. Of course, I can't find the file.

    Don't worry. Luckily I have Total Commander installed and I can search what I want simply. Another bad idea from Microsoft.
    Thursday, December 24, 2009 4:03 PM
  • First, I agree with you the Total Commander is very good software, but I still think your Index setting is not correct. You can try the following method to fix your issue. 

    1. Click on the Start Button, type "cmd" (without quotation marks) in the Start Search box. Right-click CMD listed above and click "Run as administrator".
    2. At the command prompt, copy the following command to stop the Search Service:

    net stop wsearch.

    3. Open Registry Editor.
    4. Navigate to the following registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Search

    5. Right click on "Windows Search", click "Export"; please name the file as "RegBackup" (without quotation marks) and then save it to the C:\ drive as a backup. 

    6. If you want to undo the modification, you can double click this RegBackup.reg file to restore the registry key.
    7. Right-click on “Windows Search” and choose Permissions. On the Security tab, verify that Administrator is the owner and has full control of the key.
    8. Within the "Windows Search" registry key, find the SetupCompletedSuccessfully value on the right pane. Double-click SetupCompletedSuccessfully and change its value to 0.
    9. Delete the following registry keys:

    HKLM\Software\Microsoft\Windows Search\Applications\windows
    HKLM\Software\Microsoft\Windows Search\CatalogNames\windows
    HKLM\Software\Microsoft\Windows Search\Databases\windows
    HKLM\Software\Microsoft\Windows Search\Gather\windows
    HKLM\Software\Microsoft\Windows Search\Gathering Manager\Applications\windows
    HKLM\Software\Microsoft\Windows Search\UsnNotifier\windows 

    If the key cannot be deleted, please perform the following steps to take ownership first

    a. Right-click the key and click "Permission"
    b. Click the "Advanced" button.
    c. On the "Owner" tab, verify your account is the current owner. If not, click "Other users or groups" to add your account. Then select your account, check "Replace owner on subcontainers and objects" and click OK on the windows.

    10. Now, run the following command:

    rd %ProgramData%\Microsoft\Search\Data\Applications\Windows /S /Q
    net start wsearch.

    After approximately one minute, check the SetupCompletedSuccessfully registry value and it should now be set to 1 and the Search service should rebuild the index database.

    I hope this would help you.


    John
    • Marked as answer by DrGerry Friday, December 25, 2009 6:30 PM
    Friday, December 25, 2009 8:33 AM
  • It worked!

    Thanks. It was a lot of work to acquire the permissions for every key, but finally it worked. Thanks. But this is not somethig intuitive or something my mother can do.

    One of the reasons I prefer Windows over Linux is the easy way to do things (not the console, sudo -x ..... to upgrade a program and those always-non-intutive-console-commands in Linux) But if a common user (like my 85 years old mom who uses outlook express and word without trouble) needs to do the process you describe above, I must reconsider my concepts. I don't like a Mac, of course, but this is too much....

    Anyway, thanks. A question: where you found this complicated answer?

    EDITED: if someone wants to do the same, in spanish-language Windows, the command for contents:xxxxx is contenido:xxxxx
    Friday, December 25, 2009 6:37 PM
  • I am glad to hear my suggestions are useful. As your question, I would like to tell you that I found them by myself.
    John
    Monday, December 28, 2009 3:01 AM
  • Great John. You really know your stuff!
    Wednesday, April 15, 2015 3:02 PM