locked
MS Hyper-V Server 2008 on Dell Optiplex 960 RRS feed

  • Question

  • Have a new Dell Opti 960 with e8400 processor. I have the BIOS (A03) settings configured correctly, have install Hyper-V Server 2008 and  installed/updated the drivers for the NIC/Chipset/MassStorage. when I create a VM on the box and go to start it, I get the following error: "The virtual machine could not be started because the hypervisor is not running" 

    The event log shows 2 events:
    1 - Event ID 41: Hyper-V Launch failed; Either VMX not present or not enabled in the BIOS.
    2 - Event ID 32: Hyper-V Launch failed; At least one of the processors in this system does not appear to provide a virtualziation platform supported by Hyper-V.

    I have double checked (triple, actually) the BIOS settings and they are correct. I have hard booted and even unplugged the system.

    Anyone get this working? Any help or recommendations would be appreciated.

    Thanks.
    Thursday, April 2, 2009 2:31 PM

Answers

  • I knew I had seen this recently.  From the comments on my blog in article http://blogs.technet.com/keithcombs/archive/2009/01/22/the-4gb-maximum-laptop-myth.aspx, there is a link to the blog post at http://blogs.technet.com/11/archive/2008/04/23/running-virtual-machine-in-hpyerv-on-dell-755-box-with-e6550-processor.aspx.

    In that article:

    Go into the Bios

    1)under Security  -Execute Disable- set to Off

    2)under Performance -Virtualization- set to Off

    3) under Performance -VT for Direct I/O Access - set to Off

    4) under Performance -Trusted Execution -set to Off

    click on escape select Save and exit option as soon as we select that Hard boot the box off

    turn on the box

    Go into the Bios

    1)under Security  -Execute Disable- set to ON

    2)under Performance -Virtualization- set to ON

    3) under Performance -VT for Direct I/O Access - set to ON

    4) under Performance -Trusted Execution -set to Off

    click on escape select Save and exit option as soon as we select that Hard boot the box off

    no boot up normally and the issue should be resolved


    Keith Combs - Microsoft US IT Pro Evangelist - http://blogs.technet.com/keithcombs
    Friday, April 3, 2009 3:02 AM

All replies

  • "I have the BIOS (A03) settings configured correctly"
    There is actually one setting most people get backwards in the BIOS.  I am looking for that now.
    Keith Combs - Microsoft US IT Pro Evangelist - http://blogs.technet.com/keithcombs
    Thursday, April 2, 2009 9:12 PM
  • Is that the latest bios? All of my Dells are at A07.
    Friday, April 3, 2009 1:14 AM
  • I knew I had seen this recently.  From the comments on my blog in article http://blogs.technet.com/keithcombs/archive/2009/01/22/the-4gb-maximum-laptop-myth.aspx, there is a link to the blog post at http://blogs.technet.com/11/archive/2008/04/23/running-virtual-machine-in-hpyerv-on-dell-755-box-with-e6550-processor.aspx.

    In that article:

    Go into the Bios

    1)under Security  -Execute Disable- set to Off

    2)under Performance -Virtualization- set to Off

    3) under Performance -VT for Direct I/O Access - set to Off

    4) under Performance -Trusted Execution -set to Off

    click on escape select Save and exit option as soon as we select that Hard boot the box off

    turn on the box

    Go into the Bios

    1)under Security  -Execute Disable- set to ON

    2)under Performance -Virtualization- set to ON

    3) under Performance -VT for Direct I/O Access - set to ON

    4) under Performance -Trusted Execution -set to Off

    click on escape select Save and exit option as soon as we select that Hard boot the box off

    no boot up normally and the issue should be resolved


    Keith Combs - Microsoft US IT Pro Evangelist - http://blogs.technet.com/keithcombs
    Friday, April 3, 2009 3:02 AM
  • Keith,

    That did the trick. I guess I didn't have the BIOS settings completely correct. I had the Trusted Execution set to ON. Now it works like a champ.


    Thanks for your help. I owe you a cold beverage...

    Kevin
    • Proposed as answer by Rechar Thursday, May 21, 2009 10:05 AM
    Tuesday, April 7, 2009 1:30 PM
  • In that article:

    Go into the Bios
    1) under Drives->SATA operation select RAID Autodetect /ATA

    2)under Performance -Virtualization- set to ON

    3) under Performance -VT for Direct I/O Access - set to ON

    Thursday, May 21, 2009 10:10 AM
  • having the same optiplex 9600 but with Q9400 processor and bios A04. I have tried those instructions but no luck. I have tried entering in the bios extension for CPU but there is nothing configurable for hyperthreating in there. the events i have in event viewer are 3040 and 3112, any thought?
    Monday, August 17, 2009 8:25 PM
  • having the same optiplex 9600 but with Q9400 processor and bios A04. I have tried those instructions but no luck. I have tried entering in the bios extension for CPU but there is nothing configurable for hyperthreating in there. the events i have in event viewer are 3040 and 3112, any thought?
    Monday, August 17, 2009 8:29 PM
  • in my case the trick was just to disable the trusted write in the virtualization section
    Monday, August 17, 2009 8:45 PM