locked
app-v client 4.6 not supported on SP2 R2 SCCM server RRS feed

  • Question

  • I have a strange error and not sure where to go from here. I'm testiog SCCM and app-v to replace Landesk and manual software installations. Because I will be supporting Windows 7 clients and Windows 2008 R2 RDS sessions I installed the 4.6 client. When I advertise a virtual application the VirtualApp.log file on the client is giving the following errors.

     

    <![LOG[Registering the virtual application package [REA00005] with the AppVirtMgmt client.]LOG]!><time="11:05:59.060+-600" date="04-27-2010" component="VAppRegistration" context="" type="1" thread="3216" file="registrationhandler.cpp:98">

    <![LOG[Loading package properties from the manifest file: C:\WINDOWS\system32\CCM\Cache\REA00005.1.System\Heat_manifest.xml.]LOG]!><time="11:05:59.070+-600" date="04-27-2010" component="VAppRegistration" context="" type="1" thread="3216" file="vapppackageinfo.cpp:68">

    <![LOG[The installed AppVirtMgmt version [4.6] cannot be used with this version of SCCM.]LOG]!><time="11:05:59.080+-600" date="04-27-2010" component="VAppRegistration" context="" type="3" thread="3216" file="vapputils.cpp:224">

    <![LOG[The VirtAppMgmt client was not found on this system or is an unsupported version.]LOG]!><time="11:05:59.080+-600" date="04-27-2010" component="VAppRegistration" context="" type="2" thread="3216" file="vapputils.cpp:230">

    <![LOG[The package cannot be registered. The Application Virtualization Management client is not ready.]LOG]!><time="11:05:59.080+-600" date="04-27-2010" component="VAppRegistration" context="" type="2" thread="3216" file="registrationhandler.cpp:213">

    <![LOG[Raising event:

    [SMS_CodePage(850), SMS_LocaleID(3081)]

    instance of CLIMSG_VIRTUALAPP_ERROR_PACKAGEADD_FAILURE

    {

    AdvertisementId = "REA20004";

    ClientID = "GUID:86BCD6B3-6A58-4D60-BD4E-BAD8DE714ACE";

    DateTime = "20100427010559.090000+000";

    ErrorCode = "";

    ErrorMessage = "The Application Virtualization Management client is not installed or is an unsupported version.";

    MachineName = "REASYDV-00008";

    PackageID = "REA00005";

    ProcessID = 1824;

    SiteCode = "REA";

    ThreadID = 3216;

    VirtualAppPackageGUID = "{0831B09C-4B22-4739-92BB-36E059BE6463}";

    VirtualAppPackageName = "Heat";

    };

    ]LOG]!><time="11:05:59.100+-600" date="04-27-2010" component="VAppRegistration" context="" type="1" thread="3216" file="event.cpp:525">

    <![LOG[Raised ADD PACKAGE Registration Failure event for Ad: REA20004, PackageID: REA00005, Name: Heat, PackageGUID: {0831B09C-4B22-4739-92BB-36E059BE6463}]LOG]!><time="11:05:59.110+-600" date="04-27-2010" component="VAppRegistration" context="" type="1" thread="3216" file="registrationhandler.cpp:2067">

    Now searching shows that this error occurs when SP2 has not been installed but if I look at the properties of my site it shows a version of 4.00.6487.2000 which I understand to be the version number for SP2. So I'm out of ideas and not sure what to do from here.

    thanks

    Eric

    Tuesday, April 27, 2010 2:01 AM

Answers

  • Finally got it sorted. I needed to update the SCCM client on the machine to the SP2 version also. It's running very well now.

     

    Eric

    • Marked as answer by Eric Lawson Wednesday, April 28, 2010 6:55 AM
    Wednesday, April 28, 2010 6:55 AM

All replies

  • Finally got it sorted. I needed to update the SCCM client on the machine to the SP2 version also. It's running very well now.

     

    Eric

    • Marked as answer by Eric Lawson Wednesday, April 28, 2010 6:55 AM
    Wednesday, April 28, 2010 6:55 AM
  • Finally got it sorted. I needed to update the SCCM client on the machine to the SP2 version also. It's running very well now.

     

    Eric

    thanks eric! worked for me :)
    Saturday, June 23, 2012 5:32 AM