locked
RDP not displaying screen on first attempt when display size greater than 100% RRS feed

  • Question

  • Windows 7 Ultimate 64-bit.

    Any ideas what might cause Windows 7 Ultimate to show only the start button and Windows wait cursor on the first RDP connection attempt using both monitors--but only when display is set to Medium (125%)?

    My user can connect to his office computer (the one running Ultimate) via RDP using a single monitor(i.e. with "Use all my monitors for the remote session" unchecked) with no problem. However, when he attempts to connect both monitors (that box checked), only the start button comes up in the remote session. The Windows wait cursor spins for a minute, then stops spinning but stays onscreen.

    At the same time, there is no response to mouse clicks, and remote keystroke combintions such as Alt-F4 and Alt-Ctrl-End do nothing. However, if I then disconnect or minimize the RD session and then reconnect with all displays, all is fine: the desktop appears with all icons, and start button, mouse, and keyboard are all fully functional.

    This is all independent of the client computer; that is, behavior is the same from the user's RD client computer and when I do it from my home office. And it does not change if I change the RD environment settings to, for example, not show the desktop background.

    But, being hesitant to hide behind the all-too-common "just recreate the profile - it must be corrupted", I dug more deeply. I found that he has his desktop display set at "Medium - 125%". Naturally enough, this cannot be changed when logged on via RDP, so I changed the relevant registry entry to set this to "Smaller - 100% (default)", logged off, and it solves the problem. However, I am sure the user (company owner) will not like that answer, so I set it back, and the problem returned.

    At the moment, I am stuck with telling him to connect, disconnect, then reconnect or have me reset his desktop display size. Sure, he can just disconnect when done, and then he will always just be reconnecting. However, this computer does need the occasional reboot, and the user works almost exclusively remotely.

    Any further ideas, short of dropping and re-creating the user's profile, on how to improve the situation?

    Saturday, March 25, 2017 5:57 PM

All replies

  • Hi Brian D. Hart,

    What are the graphic card on the local machine and the remote machine?
    This seems to be a DPI issue. This DPI feature has been improved a lot on Windows 10 and it is been improved further on the coming Windows 10 update creator. You could try the latest Window 10 version.

    For Windows 7, I am afraid we have to log out and log back or try a lower resolution at present.
    Windows scaling issues for high-DPI devices
    https://support.microsoft.com/en-us/help/3025083/windows-scaling-issues-for-high-dpi-devices

    Best regards,
    Joy.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Joy-Qiao Thursday, March 30, 2017 2:34 AM
    • Unproposed as answer by Joy-Qiao Thursday, March 30, 2017 2:35 AM
    Tuesday, March 28, 2017 9:57 AM
  • I am not sure about the specific graphics cards, since the host machine is 50 miles away from me and the client machine is 1000 miles away. I do know that the client computer is an Intel NUC mini-computer and so likely just has a basic built-in Intel graphics card, and that is not likely to change. I do not have access right now, since the user is logged on locally, but things work fine locally at the host machine, so this is purely an RDP-related issue and only when using dual monitors remotely.

    I know I could have the customer just replace both computers with Windows 10 computers, or I could just have the user change the text/icon size from 125% to 100%, but my question is whether there is a workaround, aside from disconnecting and reconnecting, within the Windows 7 environment, such as some other setting. It is not critical, since I at least figured out that the connect/disconnect/reconnect works. But it still makes no sense to me that it can work correctly on reconnect but never on first connection.

    Tuesday, March 28, 2017 3:39 PM
  • Hi Brian D. Hart,

    Display scaling is a deceptively complex problem. There is no magic bullet or single fix to resolve all DPI Scaling problems. Different versions of Windows and application development models have different display scaling capabilities and limitations. This issue is a limitation of Windows 7. For Windows 7 DPI issue, I am afraid the only work around is to log out and log back or try a lower resolution at present.
                                                                                                                                                                            
    Best regards,
    Joy.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Joy-Qiao Tuesday, April 11, 2017 2:34 AM
    • Unproposed as answer by Brian D. Hart Tuesday, April 11, 2017 5:33 AM
    Friday, March 31, 2017 9:47 AM