none
CU4 installation failed on SQL Server 2008 R2 SP1 x64 RRS feed

  • Question

  • Good day

    Installing CU4 onto SQL Server 2008 R2 x64 won't install.
    The server is Win 2008 SP2 standard x64
    The server is NOT clustered

    Get this error text:

    MSI (s) (C0:DC) [13:09:56:081]: SELMGR: ComponentId '{B89DB734-98B8-4A9C-B527-A40699A6D2A9}' is registered to feature 'SQL_Engine_Core_Inst', but is not present in the Component table.  Removal of components from a feature is not supported!
    MSI (s) (C0:DC) [13:09:56:081]: Note: 1: 2771 2: SQL_Engine_Core_Inst
    DEBUG: Error 2771:  Upgrade of feature SQL_Engine_Core_Inst has a missing component.
    MSI (s) (C0:DC) [13:10:16:010]: Product: SQL Server 2008 R2 SP1 Database Engine Services -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2771. The arguments are: SQL_Engine_Core_Inst, ,

    The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2771. The arguments are: SQL_Engine_Core_Inst, ,

    somebody can explaint it?

    thanx!

    P.S. on new server with clean installation of win2008 R2 SP1 with clean installation of sql server 2008 R2 CANT install SP1. I've did slipstream distrib and i have good installation. No updates can install on sql R2. Any ideas?

    Wednesday, February 22, 2012 9:57 AM

All replies

  •  

    Hello,

    Please download the cumulative again and try to apply it.

    If this CU is listed as installed on Control Panel or a previous CU for SQL Server 2008 R2 SP1, please uninstall the CU, and try to apply CU4 again.

    Hope this helps.


    Regards,

    Alberto Morillo
    SQLCoffee.com

    Wednesday, February 22, 2012 12:14 PM
    Moderator
  • i've downloaded it about 5 times - the same error

    in PROGRAMS panel i see CU's version of hotfix... but query "select @@version" tells me that version is R2 SP1 (10.50.2500)

    Monday, February 27, 2012 7:04 AM
  • Hi Demonfb,

    Where did you download CU4? Could you provide the download link?

    Regarding to the SQL Server version you provided is R2 SP1, if you want to download Cumulative update package 4 for SQL Server 2008 R2 Service Pack 1 please try to download from here.

    If you have any error please post for further troubleshooting.

    Regards, Amber zhang

    • Proposed as answer by AbeG123 Tuesday, May 8, 2012 6:36 PM
    Monday, February 27, 2012 7:57 AM
    Moderator
  • I was having the same problem trying to install CU4 as a pre-requisite to installing SCCM 2012 an the link that amber provided worked for me. 

    For anyone else who doesn't have much of a SQL background like myself, I learned the hard way that there are cumulative updates for just about every variation of SQL that you can think of and they don't seem to be cross-compatible.  A SQL 2008 SP1 CU4 won't install on SQL 2008 R2 SP1.  It's easy to overlook a  few letters, at least that was the issue in my case.  I've also read other forum posts where people have run into issues with installing x86 updates on their x64 installation and have their x64 CU4 error out while trying to update the updates that were installed with an x86 installer.

    Tuesday, May 8, 2012 6:41 PM
  • helo Demonfb

    I remember that there's exist a comment that CU4 does miss some MSI package included in CU3.

    could either try to install CU3 first and than CU4 - or just install CU5.


    Please use Mark as Answer if my post solved your problem and use Vote As Helpful if a post was useful.

    Tuesday, May 8, 2012 7:11 PM

  • Good afternoon.
    I also faced a similar problem, difference only in the SQL version not R2, and 2008 standard.

    SELMGR: ComponentId '{ B89DB734-98B8-4A9C-B527-A40699A6D2A9 }' is registered to feature 'SQL_Engine_Core_Inst', but is not present in the Component table. Removal of components from a feature is not supported!

    At the SP installation which has no value - the mistake everywhere is identical

    All components are updated, except Database Engine.

    Deleted all updatings. Did restoration by means of the adjusting disk SQL.

    The mistake is all the same shown. The same. OS Windows server standard 2008 R2.

    Probably you found a solution?
    Sunday, October 14, 2012 11:07 PM
  • Would you please share/upload SQL server setup to file sharing/storage service like SkyDrive.com

    To find locate SQL Server setup logs check-out

    http://msdn.microsoft.com/en-us/library/ms143702(v=sql.100).aspx


    Regards,
    Ahmed Ibrahim
    SQL Server Setup Team
    My Blog
    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you.
    This can be beneficial to other community members reading the thread.
    View Ahmed Ibrahim's profile on LinkedIn

    Sunday, October 14, 2012 11:26 PM
    Moderator
  • https://skydrive.live.com/redir?resid=D0DFDDC5DDE7B13C!105&authkey=!AGd51Jt8C4WYco8
    Monday, October 15, 2012 8:16 AM