Set "Use MAPI rich text format" to NEVER for all mail contacts RRS feed

  • Question

  • Some of our (external) mail contacts cannot open or even receive attachments.

    So far, I have resolved many (if not all) these incidents by setting the "Use MAPI rich text format" parameter to NEVER for these recipients (in the properties for the mail contacts in question).

    So, yes, we're managing on a case by case basis, reacting once we learn that the recipient is having problems, and not proactively.

    It should be easy enough (with Powershell in the EMS) to change this setting for all recipients and resolve the problem once and for all (?).

    But would that mean, for example, that the text of the body would be in plain text, and thus eliminate any possibility to use formatting such as bold. italics, underline and bullets?

    Íf that were the case, I'm not sure, then, that we woudl want to eliminate MAPI rich text format across the board (for everyone).

    How are other Exchange admins dealing with this?

    Sunday, March 20, 2011 8:51 PM

All replies

  • Hi,

    When you say the external recipients cannot open or received attachments what do you mean by that? Do you mean the recipients receive the attachments as winmail.dat?

    Do you mean what they are using over on their end?

    Sunday, March 20, 2011 10:52 PM
  • Yes, that's one scenario. The message is received but instead of the real attachment, you have the winmail.dat file. In other cases, the user claims they do not receive the mail at all.
    Sunday, March 20, 2011 11:52 PM
  • Have you tried sending a test email with the attachments to a web account and see what happens. Can you check to see when it leave your network if the attachment is intact?

    I would suggest try to put a delivery and read receipts on emails as a test. If you receive the delivery receipts then it arrived on their end.

    Monday, March 21, 2011 12:27 AM
  • Yes, I sent it to a gmail account and the attachment displays without a problem. That, and the fact that most recipients DO receive (and can open) the attachments, leads me to believe it has something to do with the recipient's client. But we can't force them all to use Outlook or OWA.


    Monday, March 21, 2011 12:24 PM
  • Hi,

    From your description, you should understand the following information:

    1. If you send emails to the internal contacts, can they receive and open the attachments?

    2. If the email formats are changed to html or plain text, is the issue absolutely solved?

    3. Which email clients are the receivers, Outlook, OWA or others?

    About winmail.dat attachments, when an email contains TNEF information, if the email is accepted by the clients not understanding TNEF, it is normal phenomenon that the winmail.dat attachments occur. So when you send emails to those clients not supporting TNEF, make sure to turn TNEF off .

    Please refer to the article about using TNEF: http://support.microsoft.com/kb/197066


    Tuesday, March 22, 2011 9:55 AM
  • 1. Yes. But all our internal clients use either Outlook or access their email via OWA, so that is not a problem.

    2. It was for 5 out of 5 users encountering problems most recently and has worked before.

    3. I only know what our employees use, at work and sometimes at home. For the other recipients, I can only guess.

    Thank you for the link.

    Tuesday, March 22, 2011 11:06 PM
  • I would suggest to find out what mail server the recipient's end is using. This will at least narrow it down a little. Also, test with sending an email in plain text with attachment and then html with attachment.
    Thursday, March 24, 2011 6:45 AM
  • This is a pretty old post but still relevant in my case with on-premise E2013.

    Messages composed in html and sent to External Contacts were being converted to plain text before being handed off to the remote system. As you found, David, setting the UseMapiRichText attribute to 'Never' stops this from happening. We had it set to 'UseDefaultSettings.'

    You were asking about setting the attribute to 'Never' for all of your contacts. I believe that doing so means no format conversion so all messages leave in whatever format they were composed in. In general, this is what's best for my external contacts.


    Friday, November 11, 2016 7:36 PM