locked
Screensaver, powersaving and screen dimming not working on RC7100. RRS feed

  • Question

  • Running the RC 7100 (32bit) on an MSI wind, fresh install fully updated. All runs fine except that when the screensaver starts to dim the screen, it gets to black, and then it just instantly comes back up. This means none of the other power saving is working so it won't power down at all when on battery, only way to sleep/hibante is from start menu/power button, and it was working fine on XP!

    Read other advice about HID controller update, but installed all the offered updates and this wasn't one of them. Installing the touchpad drivers (vista32) made no diffrence.

    Any ideas?
    Tuesday, May 12, 2009 11:31 AM

All replies

  • I'm having exactly the same problem on an MSI Wind U100+. I have installed the WinXP Sentelic driver v8.3.3.2 (http://forums.msiwind.net/internal-hardware/sentelic-driver-download-here-t6327.html). I haven't seen anything about HID controller updates for RC7100. Do you still have the link to them?

    The lack of power saving on a portable device is a major drawback.

    I too would appreciate any advice on how to fix it as I have spent quite a while trawling the web for a solution.
    Wednesday, May 13, 2009 2:22 AM
  • it goes to black, initially,  because the screen saver is basic, not aero.

    It wakes back up because something, like devices / networking, is active and not set to not wake it up.

    Kris
    Wednesday, May 13, 2009 4:18 AM
  • Well, I think its is aero, I get transparent window edges, and win-tab does the whole 3d-ness, which on vista is aero, but I'm not that familar with 7 so maybe aero does even more!
    The screen fades to black, then immediately comes back up, so I know its not a jittery touchpad or something as this would stop it ever getting there. Like you say KrisM I assume its a device stopping powersaving, but I've been though device manager and nothing is allow to wake it up (LAN, WiFi and USB Hubs are the only things that give an option though). Is there anything I could use, a monitoring tool, to record what device is sending the 'don't you dare go to sleep' command?

    Cheers, Richard.
    Wednesday, May 13, 2009 12:04 PM
  • No, I'm baffled - if it were me the next thing I would do is unplug all my USB devices and see if that does anything.

    I do not know of any monitoring tool.  When I have had that problem myself, I just beat my head against a wall until I inadvertantly stumble into it. and I checked my notes and I apparently didn't note anything down, which is unusual for me, but there it is...

    Probably some piece of software doing monitoring or poling or writing to log.  I think one time I found UPSMON as a guilty party though it seems fine now.  But it was logging every second or so and would wake it up.  But apparently not now as I set scrsaver to 1 min to test for this and it went dutifly into ss after a minute.  Dunno!

    Good luck with it.

    Kris
    Wednesday, May 13, 2009 2:38 PM
  • Well, nothing USB is plugged in (externally). But I belive the built-in webcam is usb, and possible the bluetooth could be. I tried turning them off (via keyboard fn shortcuts) and that does actually make the camera disappear from device manager, but the only way I can find to turn off wifi/BT is to just disable it. Maybe I'll try removing the mini PCI-E card they're on. 

    But disabling everything I could didn't make any diffrence. I've almost no software installed, and nothing that runs at startup, so I'm kinda stuck. May actually have to go back to XP which would be a shame as 7 seems really nice, but powersaving is a must have on that machine.

    Cheers, Richard.
    Thursday, May 14, 2009 11:49 AM
  • yes, webcam and bluetooth are certainly USB.

    Kris
    Thursday, May 14, 2009 2:47 PM
  • I have the same problem. Screen goes black and immediately turns on. I have installed System Control Manager from MSI website, but it didn't help. Funny thing is, that screensaver works good.
    Saturday, May 16, 2009 2:38 PM
  • Well I've been using it without the power settings for a while, but decided the make a big push to fix it recently.

    First thing I done was to completely reinstalled it (Fully wiped the HD and a reinstall), still had the same issue. As with Enterek's system, the screen saver is actually working fine, but as soon as the laptop trys to power off the screen, this stops the screensaver, and we're back at the full power state!

    So I went through the diffrent settings on by one to find out what is actually stopping it.

    Screen Saver: Works fine.
    Dim The Display: Doesn't work (although the adjust brightness does, which is odd). But doesn't matter if this is on or not as to if other things work.
    Turn Off The Display: Doesn't work, and breaks any power settings that have a longer delay.
    Put The Computer To Sleep: Works fine.

    So basically on the standard plan it trys to Dim the display after 2 mins (which doesn't work, but doesn't stop anything else), then turn it off after 5, but this 'resets' the timer/counter and so it never even trys to go to sleep after the planned 10mins.

    Which all in all means I can just use a combination of Blank Screen Saver and Sleep mode to get resonable power saving, but still not ideal.

    Any ideas? 


    Thursday, June 25, 2009 4:43 PM
  • ricx-uk,

    I'm afraid you may need to wait for the final release of Windows 7 - the RC has, as you're no doubt aware, some noted issues with sleep, hibernation, et al., and while I'm personally impressed that you've gotten as far as you have, these bugs should all be gone by the RTM.
    -Alex
    Thursday, June 25, 2009 6:25 PM
  • I have the same issue in RTM, but my screensaver works.
    Tried numerous drivers, and settings, but it simply doesn't work.


    Ivan
    Tuesday, September 15, 2009 7:20 AM
  • So? Any fix yet? I'm encountering this problem, and to be honest, it's kinda bothering me.. i mean, for mobility issues, this feature are a mandatory.

    UPDATE!!!
    I'm using MSI Wind netbook. I've finally come up with a solution. The problem is not with the windows 7. It's with the hardware. Turns out that an upgrade in your bios is necessary anyway. Therefore I've flashed my MSI Wind netbook with the latest, 1.10e version of bios, and everthing is working FLAWLESSLY.
    • Proposed as answer by LostSouls Friday, November 6, 2009 6:06 AM
    Thursday, November 5, 2009 10:22 AM
  • Nice one LostSouls. Just updated mine to 1.10E and all is well in the universe.

    For anybody else who comes across this:

    Download the BIOS from here: http://www.msi.com/index.php?func=downloaddetail&type=bios&maincat_no=135&prod_no=1784

    Use this utility to prepare a USB stick to do the update: http://forum-en.msi.com/index.php?topic=116721.0
    (you will need to register - free).
    Friday, November 6, 2009 11:38 AM
  • here is a fix :  http://forum-en.msi.com/index.php?topic=133394.msg1003522#msg1003522



    "open "Control Panel\All Control Panel Items\Display\Screen Resolution" and then "Advanced Settings", then "Monitor - Properties - Driver - Disable". Don't be afraid the monitor will continue to work"
    Monday, December 14, 2009 6:32 AM