none
Windows 8.1 with IE 11.0.2 - WPAD issue RRS feed

  • Question

  • Hi there,

    I am working on an 8.1 SOE and have an issue whereby the wpad.dat file does not seem to apply and there is a 10 second delay every time IE 11 loads, before our intranet page is displayed (seems almost identical to the 10 second delay described here - http://technet.microsoft.com/en-us/library/cc302643.aspx).  Once loaded all sites work so it's just the startup delay I need to sort out.  Chrome loads instantly but we have apps that rely on IE.  Here are some things I've checked so far:

    - Our current Windows 7 SOE with IE8 loads the wpad.dat and there is no delay, I can see this with wireshark and the WPAD registry entries exist under HKCU, wpad.dat exists in temporary files folder

    - I cannot see any reference to dns query for wpad or http get for wpad.dat on Windows 8.1 with IE 11 in wireshark, the wpad registry key exists but no data appears under it once IE has loaded, cannot see any wpad.dat in the cache

    - when I load chrome I can see the dns query and http get for wpad.dat which all happens within one second (hence at this stage I'm assuming this is a bug in IE11)

    - there are entries loaded into DefaultConnectionSettings and SavedLegacySettings, but they dont seem to reference any host (on my win7 machine I can see the correct path to the wpad):

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections]
    "SavedLegacySettings"=hex:46,00,00,00,09,00,00,00,09,00,00,00,00,00,00,00,00,\
      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
      00,00,00,00,00,00,00,00,00,00,00,00,00,00
    "DefaultConnectionSettings"=hex:46,00,00,00,03,00,00,00,09,00,00,00,00,00,00,\
      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00

    - I've tried removing the patch to 11.0.1 and 11 with same results

    - disabled AV, IPv6, all sorts of other stuff without any success

    Appreciate any ideas :)

    Thanks,

    Simon


    • Edited by S1m0nB Monday, December 23, 2013 6:33 PM updated
    • Moved by 暁北 Friday, December 27, 2013 5:34 AM
    Monday, December 23, 2013 3:53 AM

Answers

  • To anyone that has the issue we were experiencing, the issue came down to DNS requests to a host 'dummy'.  This then has to time out before IE kicks in.  So our fix was to add a DNS A record for dummy (we pointed it to one of the gateway IPs).  Therefore the DNS query to 'dummy' responds and IE now behaves normally.

    Not sure if I quantify that as resolved but I'm happy with the workaround! :)

    • Marked as answer by S1m0nB Thursday, April 3, 2014 10:14 PM
    Thursday, April 3, 2014 10:12 PM

All replies

  • Hi,

    We need to take some time to test this in windows 8.1 and we will update our result once we complete test.

    Thank you for your support and patience.

    Best Regards

    Quan Gu

    Friday, December 27, 2013 6:31 AM
    Moderator
  • Hi Quan

    I'll be very interested to see the results of this as I am experiencing the same problem.

    Win 8.1 + IE11 + WPAD causing long delays and making IE unusable.

    • If I configure IE11 to connect directly to the proxy then the issue goes away
    • Using Firefox with WPAD on same machine has no issues
    • Monitoring connection with NetMon i don't see any WPAD connections with IE 11.  Switching to Firefox, regular WPAD traffic can be seen.
    • I have a Win 8.0 + IE10 + WPAD machine sitting right next to this one with no issues at all.  Further more the WPAD has been used on Win 7 and XP SOE's for many years.

    Similar to Simon's experience above this appears to be a bug so I will appreciate any other feedback on this forum.

    Cheers Dan

    Wednesday, January 8, 2014 12:13 AM
  • Hi Quan,

    Any progress on this?  I have logged a case for this now as well.

    Cheers,

    Simon

    Monday, February 3, 2014 8:41 PM
  • Looks like this issue will never die. It started in IE6/XP and it is still in Win 8.1 and IE11!!! LOL

    I am currently dealing with the 10 second delay on and trying to fix for XP/SP3 and IE8. Ours only occurs when on wireless.

    Either way, wired, wireless, XP, 8.1, IE8, IE11... this core issue looks like it will never die.

    Wednesday, February 12, 2014 8:05 PM
  • Since Windows 8 the 'WinHTTP Web Proxy Auto-Discovery Service' will cache WPAD information, hence we do not see any lookup when IE loads, but do with other browsers which still use the legacy WPAD method.  If you disable this service IE returns to previous behaviour, however in our case the delay occurs regardless.  Currently sending process dumps to MS who can see IE 'stopping' for several seconds during load in netmon and procmon files.  Hopefully the dumps will get to the bottom of this for us... I'll post again (hopefully soon) when it is resolved.

    Cheers, Simon

    Wednesday, February 19, 2014 12:21 AM
  • I am also seeing this issue with Win8.1 and IE11. Although it is not always every single opening of IE when the delay happens. Definitely the first opening of IE following a restart for example.

    Also same scenario as Simon mentions, wpad key within the registry is there but nothing underneath it and no wpad.dat in the internet cache.

    Despite this though wpad is working and the device can access the internet through the designated proxy specified in the wpad.dat.

    I am currently in the process of rolling out wpad across our infrastructure with the particular goal of overcoming mobile device issues with a proxy set but then unable to access the internet from home, but until the delay issues are resolved I will have to put the rollout on hold.

    Thursday, February 20, 2014 3:52 PM
  • Yes same for us the delay was not every time.  Out of interest try stop and disable the WinHTTP Proxy service.  Once I have done this it happens every time IE loads, presumably because it cant used the WinHTTP cached info so goes through standard wpad auto-detect each time. 
    Thursday, February 20, 2014 9:02 PM
  • Yes, disabling the WinHTTP Proxy service causes the delay with IE every time it is opened. Something seems inherently broken with WPAD on Win8.1. Works perfectly fine with Win7.
    Friday, February 21, 2014 9:29 AM
  • Anyone had any progress with this yet? Seems it may never get fixed, which is a shame because it works well with older OS's
    Tuesday, March 11, 2014 1:39 PM
  • The latest thing we tried working with MS was to remove any wildcard entries from the MakeNames function part of WPAD, however the issue remains after this change.  So it is back in MS court.  I will update with any developments.

    Cheers, Simon

    Wednesday, March 12, 2014 12:42 AM
  • Hi, I have gone back to a very simple wpad.dat as below:

    BackupRoute="DIRECT";
    UseDirectForLocal=true;
    ConvertUrlToLowerCase=false;
    function FindProxyForURL(url,host)
     {                  
     return "PROXY ipaddress:port";
     }

    With this file the issue is resolved, so it is definitely something to do with the wpad content.  Are you able to confirm in your environment?

    Cheers, Simon

    Wednesday, March 12, 2014 2:10 AM
  • Hi Simon,

    Yes, I can confirm that using a simple WPAD resolves the delay with WPAD discovery. As a result I have been doing some testing with our WPAD script, removing sections of it and testing after every change. The main functions we use are:

    isInNet(myIpAddress()  to set the proxy ON for IP's within our local ranges
    shExpMatch(url,) to set URLs to bypass the proxy and go DIRECT

    Removing all entries using the above functions made no difference.

    We also have a function

    isInNet(host,) where if destination addresses are within our local subnets, go DIRECT.

    It was upon removing these entries that the delay went away, and it seems with every use of this function extends the delay.

    I suppose I will need to look at rewriting our WPAD to not use this function.

    Regards

    Phil

    Wednesday, March 12, 2014 10:12 AM
  • Nice work!  I have forwarded your post to the MS tech assigned to our case.  Maybe we'll see a patch soon that resolves this issue.

    Cheers, Simon

    Wednesday, March 12, 2014 11:42 AM
  • As it happens I came across a website proxypacfiles.com under the lessons learned section it seems to indicate caution when using the IsInNet function as well as others. I did notice that websites did load slightly slower when using WPAD compared to using a set proxy. However since removing the IsInNet functions from my script I have not noticed any speed or delay problems.


    Phil

    Wednesday, March 12, 2014 11:53 AM
  • Hi guys,

    I've had the same issue on IE11 and its related with a new implementation to determine if the .pac file was downloaded successfully.

    I don't know if you are facing exactly the same issue but if you run wireshark you'll have a lot of dns lookups for dummy host.

    To fix the issue you can test this function:


                    function FindProxyForURL(url, host)
    {

                    // Workaround for IE11
                    if (shExpMatch(url, "http://dummy/"))
                       return "DIRECT";

    VA
    • Edited by anjosva Friday, March 21, 2014 2:18 PM
    Friday, March 21, 2014 2:17 PM
  • Hi,

    Yes in our situation there are many dummy DNS queries as well which are related to the delay.  I am not sure where to put the code above, can you confirm?  Here is the current function - where would I insert the  workaround?

    function FindProxyForURL(url, host){
     pfDnsResolve = DnsResolve;
     pfMyIpAddress = MyIpAddress;
     pfIsInNet = IsInNet;
     return ImplementFindProxyForURL(url, host);
    }

    Thanks, Simon

    Sunday, March 23, 2014 10:02 PM
  • To anyone that has the issue we were experiencing, the issue came down to DNS requests to a host 'dummy'.  This then has to time out before IE kicks in.  So our fix was to add a DNS A record for dummy (we pointed it to one of the gateway IPs).  Therefore the DNS query to 'dummy' responds and IE now behaves normally.

    Not sure if I quantify that as resolved but I'm happy with the workaround! :)

    • Marked as answer by S1m0nB Thursday, April 3, 2014 10:14 PM
    Thursday, April 3, 2014 10:12 PM