locked
Logical disk fragmentation level is high RRS feed

  • Question

  • Hi,

     

    I am running System Center Operations Manager 2007 R2 6.1.7221.0 and the Management Pack "Windows Server 2003 Operating System 6.0.6794.0".

    On a lot of our Windows 2003 servers I have a very high disk fragmentation level (85-99%) on some of the harddisk drives on the servers.

    The servers are a mix of MS 2003 Exchange 2003 servers, MSSQL 2005 servers and a single Oracle database server.

     

    Some of the are VMware virtual servers and some of them are physical servers.

     

    I have tried to run a disk fragmentation task on the drives, but this has not solved the issue.

     

    I know that I can disable the monitor, so I do not get these warnings, but I would like to hear if anyone have another solution to this problem?

     

    Do you just override the monitor or did you purchase a 3.party program to solve this issue? (and if so, did it solve the problem?)

     

    Kind regards,

    Carl-Marius

    Thursday, June 16, 2011 8:18 AM

Answers

  • i've overridden the value to 25% default for all my drives. But some disks will always have high fragmentation (e.g. transaction log disk from exchange/sql), so it is kind of useless to monitor those...
    Rob Korving
    http://jama00.wordpress.com/
    • Marked as answer by Carl-Marius Thursday, June 23, 2011 12:45 PM
    Thursday, June 16, 2011 8:25 AM
  • The servers are a mix of MS 2003 Exchange 2003 servers, MSSQL 2005 servers and a single Oracle database server.

    For those systems, it is not uncommon to have only a few (very) large files taking up the disk space. Causing the % to be very high with only a few files on the system. Defragmentation of these files will only occur if you stop the services (SQL, Exchange) AND have enough space to perform the defragmentation.

    For these servers it looks better to disable the monitor for the disks affected, cause you probably will never be able to defrag the disk.


    Regards,
    Marc Klaver
    http://jama00.wordpress.com/
    • Marked as answer by Carl-Marius Thursday, June 23, 2011 12:45 PM
    Thursday, June 16, 2011 1:09 PM
  • We disabled this rule across the board because it's utter crap. We don't miss it.
    "Fear disturbs your concentration"
    • Marked as answer by Carl-Marius Thursday, June 23, 2011 12:45 PM
    Thursday, June 16, 2011 3:04 PM

All replies

  • i've overridden the value to 25% default for all my drives. But some disks will always have high fragmentation (e.g. transaction log disk from exchange/sql), so it is kind of useless to monitor those...
    Rob Korving
    http://jama00.wordpress.com/
    • Marked as answer by Carl-Marius Thursday, June 23, 2011 12:45 PM
    Thursday, June 16, 2011 8:25 AM
  • The servers are a mix of MS 2003 Exchange 2003 servers, MSSQL 2005 servers and a single Oracle database server.

    For those systems, it is not uncommon to have only a few (very) large files taking up the disk space. Causing the % to be very high with only a few files on the system. Defragmentation of these files will only occur if you stop the services (SQL, Exchange) AND have enough space to perform the defragmentation.

    For these servers it looks better to disable the monitor for the disks affected, cause you probably will never be able to defrag the disk.


    Regards,
    Marc Klaver
    http://jama00.wordpress.com/
    • Marked as answer by Carl-Marius Thursday, June 23, 2011 12:45 PM
    Thursday, June 16, 2011 1:09 PM
  • We disabled this rule across the board because it's utter crap. We don't miss it.
    "Fear disturbs your concentration"
    • Marked as answer by Carl-Marius Thursday, June 23, 2011 12:45 PM
    Thursday, June 16, 2011 3:04 PM
  • Hi all,

     

    Thank you very much for your responses!

     

    I have chosen to disable the Logical disk fragmentation on the SQL, Exchange and Oracle disk drives... There is no way that I can take them offline and perform a disk fragmentation anyway :).

     

    Kind regards,

    Carl-Marius

    Thursday, June 23, 2011 12:45 PM