locked
Windows 2008 R2 - Printer "Offline" SNMP issue. RRS feed

  • Question

  • The issue:

    Not unique from what I have read in these forums and elsewhere around the globe.  But essentially, I have printers that go "offline" and only come back into life if I disable SNMP per printer port and therefore lose any "real" status messages.

    Some Environmental Information:

    - The printers and the print server are on the same logical subnet

    - There is no filtering/Firewall between the printers and the print server and not relevant given they are on the same logical subnet.

    - The firewall is disabled on the Print Server

    - The SNMP community string(s) configured on the printer matches that of the print server port

    - The manufacturing model of the printer varies.  Various print vendor makes and models, of the 5-6 affected devices, all of them are different.

    The following information relates to the newest printer a Ricoh Aficio MP C4501, manufactured and released in 2011 which is one of the models that has the issue

    - The Printer's NIC firmware is up to date (applied myself as I work for this particular print vendor) and is fully compliant with SNMP V1, V2 and V3 and supports all relevant MIBs

    - When the issue occurs, I can access the printer's web configuration page

    - When the issue occurs, I can ping the printer device showing "offline" on the print server

    - When the issue occurs, I can interrogate the printer device using an SNMP browser (many different types) on SNMP V1, V2 and V3 without issue

    - When the issue occurs, I can monitor the device and get detailed status updates using SNMP V1, V2 and V3 in the print vendors own device management application as well as Spiceworks without issue

     

    Note:

    I am quite confident that there is not a communication issue with SNMP to/from the device.

    I am quite confident that there is not an issue with the printers NIC in terms of firmware

    I can get around this by disabling SNMP per port, but this is _NOT_ a fix because "actual" status' other than "online" are never reported.

     

    Summary:

    I'm going out on a limb here and suspecting that the root cause is not the device, firmware or print driver, but in fact something within Windows Server Print Subsystem.  To that end and given there has been a huge amount of discussion on this issue, is there any progress or even acknowledgement that this _MIGHT_ be a problem that Microsoft need to address?

     


    --------------------------- ASE, CNE, CCNP, CLP, MCSE --------------------------
    Monday, September 5, 2011 12:10 PM

Answers

  • At this point no one has opened a support case for this issue.  Yes, I'd love to determine where the problem resides.  From your previous post I assume the SNMP community name is not "public". 

    Are you using static addresses or DHCP?

    I am not MS support, if you want to create a support case you would need to go through whatever path there is for that.

    Ricoh has print driver delevopers in Redmond.  Do you have anyway to contact this group?


    Alan Morris Windows Printing Team
    Tuesday, September 6, 2011 4:42 PM
    Answerer

All replies

  • If it wasn't obvious from the subject, I am seeing this on Windows 2008 R2 x64 SP1.  Putting it rather bluntly and without wishing to sound rude, is there a fix planned for this or time set aside to "considerably" investigate the issue??


    --------------------------- ASE, CNE, CCNP, CLP, MCSE --------------------------
    Monday, September 5, 2011 9:26 PM
  • At this point no one has opened a support case for this issue.  Yes, I'd love to determine where the problem resides.  From your previous post I assume the SNMP community name is not "public". 

    Are you using static addresses or DHCP?

    I am not MS support, if you want to create a support case you would need to go through whatever path there is for that.

    Ricoh has print driver delevopers in Redmond.  Do you have anyway to contact this group?


    Alan Morris Windows Printing Team
    Tuesday, September 6, 2011 4:42 PM
    Answerer
  • I've only seen this problem with one vendor, which I'd consider a corner case.  Zebra ZM400's while adding the TCP/IP port to the print server is unable to detect the network card (it reverts to generic) and disables SNMP.  Yet, after the printer has been created, if you go and re-enable SNMP for that very same printer on the print server, then it DOES report the status messages just fine.  snmp read community is: public.

    Otherwise, all other printers we have in use on our 2008 R2 SP1 server do not exhibit the issue you're describing. We've got various HP, Xerox, Ricoh, and Intermec printers in use.

    Tuesday, September 6, 2011 7:16 PM
  • Thanks for getting my back on this BSOD2600 but I've seen this request a couple times too often.  In your environment and my environment, it all works as expected.   There is some configuration where the ports are getting knocked to Offline.

    For the Zebra issue, most likely the network card is not in \windows\system32\tcpmon.ini AND does not support autoconfig from an SNMP query. 

    I'll add Canon and Lexmark to the list of devices that have not experinced this issue in the MS corp network environment.


    Alan Morris Windows Printing Team
    Tuesday, September 6, 2011 9:10 PM
    Answerer
  • Hi Alan

    Thanks for your response.  In this particular case, the SNMP string is not public and the IP address is statically assigned. I this particular case, there are more than one of this model of Ricoh MFP, both of which are defined on the same Print Server, both of which have the same level of firmware throughout and both of which are on the same subnet.  Only one of which displays the issue.

    Understood regarding the need for opening a support case.  I don't have access to our team in Redmond, largely because I'm at the bottom of the food chain in that regard, but I have escalated the issue internally for somebody to pick up on it (open a support case accordingly) and do more investigative work in general.

    Cheers :)


    --------------------------- ASE, CNE, CCNP, CLP, MCSE --------------------------
    Wednesday, September 7, 2011 4:27 AM
  • can you send the port configuration on the server?

    cscript C:\Windows\System32\Printing_Admin_Scripts\en-US\prnport.vbs -l > portlist.txt

     

     


    Alan Morris Windows Printing Team
    Wednesday, September 7, 2011 9:38 PM
    Answerer
  • This is caused by the SNMP Status Enabled option under the port configuration in windows, you'll need to either disable SNMP on the  port or correct the configuration to do this -

    Go to the ports tab in the printer properties and click configure port.

    Either untick the SNMP Status Enabled option or correct the community name.

     

    Cheers,

     

    Tim

     

    • Proposed as answer by Aza Rainey Friday, November 9, 2012 7:32 PM
    Thursday, September 29, 2011 4:34 AM
  • Hi Mrfixit7, recently we had to change our public string to something else and we started to face the same problem exaclty you explain. Restarting printer or putting snmp tick off and on again solved some of the devices' offline problem but I am still looking for a solution
    Friday, January 27, 2012 1:31 PM
  • Hi,

    try this one:

    In the  print server Registry go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print

    add a new DWORD "SNMPLegacy" with the value "1"

    Restart Spooler

    Done

    • Proposed as answer by 234egr25 Wednesday, January 22, 2014 4:23 PM
    Wednesday, July 18, 2012 11:19 AM
  • Has anyone had any luck with this issue yet?  We are having the same problem with printers showing offline and the patch that Mr. Morris gave did NOT fix the problem.  I even went through all our queues (almost 300 of them) and disabled SNMP and still no dice. 
    Tuesday, October 23, 2012 1:58 PM
  • I did not point to a patch in this post.  If the Offline state is seen when on the server, then something is impeding the SNMP response from the device.  If the device does not support SNMP or the SNMP community name is not public, unchecking the SNMP configuration will immediately place the printers on the server back to Ready state since the Standard TCP/IP Port monitor will no longer changed printer status from the SNMP device status.  If you are using HP's network port (or another vendor)  I have no context for their software.

    If you only see Offline from the clients, that's a different issue completely unrelated to SNMP network traffic.


    Alan Morris Windows Printing Team

    Tuesday, October 23, 2012 4:01 PM
    Answerer
  • I did not point to a patch in this post.  If the Offline state is seen when on the server, then something is impeding the SNMP response from the device.  If the device does not support SNMP or the SNMP community name is not public, unchecking the SNMP configuration will immediately place the printers on the server back to Ready state since the Standard TCP/IP Port monitor will no longer changed printer status from the SNMP device status.  If you are using HP's network port (or another vendor)  I have no context for their software.

    If you only see Offline from the clients, that's a different issue completely unrelated to SNMP network traffic.


    Alan Morris Windows Printing Team


    I'm sorry Allen I have been looking at so many threads.  on another thread you pointed to the patch for KB2713128.  I tried this to no avail.  The offline status is seen only on the client PCs which are connected to the 2008 r2 print server.  Only windows 7 devices are effected.  We are not using HP's network port its just stright up tcp/ip.   Any help would be GREAT as I have been banging my head on this for a long time now.  :)

    Tuesday, October 23, 2012 4:15 PM
  • That is the client side update which is supposed to fix the clients marking the print server into an Offline state that they cannot loop out of.   Make sure the clients have this version of the file

    \windows\system32\Win32spl.dll

       6.1.7601.21993

    Configure the Standard TCP/IP Ports for your SNMP compliant devices back to SNMP enabled.  If all your devices support SNMP, open a powershell window and set them in one pass.

    $ports = get-wmiobject win32_tcpipprinterport
    foreach ($port in $ports)
    {
    cscript C:\Windows\System32\Printing_Admin_Scripts\en-US\prnport.vbs -t -r $port.name -me
    }

    You can also change community name.  prnport.vbs /?


    Alan Morris Windows Printing Team

    Tuesday, October 23, 2012 5:00 PM
    Answerer
  • That is the client side update which is supposed to fix the clients marking the print server into an Offline state that they cannot loop out of.   Make sure the clients have this version of the file

    \windows\system32\Win32spl.dll

       6.1.7601.21993

    Configure the Standard TCP/IP Ports for your SNMP compliant devices back to SNMP enabled.  If all your devices support SNMP, open a powershell window and set them in one pass.

    $ports = get-wmiobject win32_tcpipprinterport
    foreach ($port in $ports)
    {
    cscript C:\Windows\System32\Printing_Admin_Scripts\en-US\prnport.vbs -t -r $port.name -me
    }

    You can also change community name.  prnport.vbs /?


    Alan Morris Windows Printing Team

    Allen thank you for your response.  I have checked multiple workstations and the version of win32spl.dll is 6.1.7601.17514.  So just so I'm clear (before I apply this to 4,000 devices) KB2713128 will correct the dll version and then I need to run the script to enable SMNP on the print server, then printers will start showing online? 

    Sorry for asking the obvious but I like to make sure about mass patches before i go forward - I'm sure you understand.  I will be conducting tests on a smaller group of users (30 or 40) before I deploy it go to the masses.

    I'm sure this would also explain why some users are complaining of slow printer response times.  Am I right with that assumption?

    One more question, if this is a known issue then why hasn't this patch been released to the masses via windows update?

    Thanks again for your help.
    Wednesday, October 24, 2012 3:03 PM
  • I'd say setup your ports with the proper SNMP configuration now since it has nothing to do with this client side issue.

    Verification is always important.  It allows you to better understand the impact of the patch (reboot required by the patch) so your customers are not getting a surprise reboot while completing an assignment.  (My computer ate my homework).  As well as manage the roll out since I assume you do not have hands on on all the machines. 

    I normally do not associated this issue with slow printing but since I have never seen the problem, I'm not sure.  If this cleans up that issue please let me know.

    I have no idea why the thread token gets set in the wrong context for some customers but in general it's not happening everywhere so I assume the KB distribution.  Windows Update is typically for security exploits and driver updates


    Alan Morris Windows Printing Team


    Wednesday, October 24, 2012 4:50 PM
    Answerer
  • I'd say setup you ports with the proper SNMP configuration now since it has nothing to do with this client side issue.

    Verification is always important.  I allows you to better understand the impact of the patch (reboot required by the patch) so your customers are not getting a surprise reboot while completing an assignment.  (My computer ate my homework).  As well as manage the roll out since I assume you do not have hands on on all the machines. 

    I normally do not associated this issue with slow printing but since I have never seen the problem, I'm not sure.  If this cleans up that issue please let me know.

    I have no idea why the thread token gets set in the wrong context for some customers but in general it's not happening everywhere so I assume the KB distribution.  Windows Update is typically for security exploits and driver updates


    Alan Morris Windows Printing Team


    Alan,  I'm sorry to report that users that received the patch are still having printers show offline.  :(  
    It does appear that they do eventually come back online after 5 mins or so, then their print jobs run. 
    Thursday, October 25, 2012 12:43 PM
  • Hi Sheriff Andy Taylor,

    so your printers went offline even with bidirectional support disabled and SNMP status at port settings unchecked?

    Thursday, October 25, 2012 1:46 PM
  • Hi Sheriff Andy Taylor,

    so your printers went offline even with bidirectional support disabled and SNMP status at port settings unchecked?

    Hi Sergey,

    Yes went through all the printers and unchecked the boxes for both bidirectional support and SNMP.  It made no impact with printers going offline.

    I'm so frustrated.  This is impacting roughly 5,000 users.  To add to that my test group of windows 7 users that I applied KB2713128 which updates win32spl.dll had no impact on the users.

    Thursday, October 25, 2012 2:25 PM
  • well, in this case it is rarely SNMP issue :)

    As for me it seems like RPC calls are failing.

    I'd try:

    1. Add 'Domain computers' to the queue's ACL. Check it

    2. Disable async RPC calls by adding HKLM\Software\Policies\Microsoft\Windows NT\Printers\EnabledProtocols
    Type: DWORD
    Data: 6

    + restart spooler

    Thursday, October 25, 2012 3:55 PM
  • well, in this case it is rarely SNMP issue :)

    As for me it seems like RPC calls are failing.

    I'd try:

    1. Add 'Domain computers' to the queue's ACL. Check it

    2. Disable async RPC calls by adding HKLM\Software\Policies\Microsoft\Windows NT\Printers\EnabledProtocols
    Type: DWORD
    Data: 6

    + restart spooler

    I'm assuming that the regedit needs to be done on the clients right?
    Friday, October 26, 2012 1:15 PM
  • 1. at printserver of cause :)

    2. yes, at the client which affected


    Friday, October 26, 2012 1:40 PM
  • I was killing SNMP as part of locking down the printers and my Savin/Ricoh MFPs stopped printing.  I thought Windows just used port 9100 for printing so couldn't figure out what was going on.  I had to re-enable SNMPv1 stuff to get it to work again.  Then I saw Jibbajabba's post and it worked PERFECTLY.  Disable SNMP on the stupid port and then I could go back to locking down the printers.

    Thanks, man!  I pity the foo' who doesn't accept your post as an answer!

    Monday, March 25, 2013 3:14 PM
  • I was asked to check into a smaller office where printers were intermittently going "offline", HP LaserJet 4250's. It's been an ongoing issues but seems to come and go, the symptoms do align almost exactly with Mr Fix It's post, however the office was not running R2.   SNMP was in fact the cause and disabling it is a great workaround, however, this does remove that communication between the printers and servers.   I know this post is old, but it is still helpful.  I second that Jibbajabba's post is incredibly helpful.  
    Thursday, March 28, 2013 2:23 PM
  • We have Dell printers at our office and we experience the exact same issue with just about every one of them. Oddly enough, I brought one home and on my home network, it does the exact same thing. We get by via Group Policy Preferences Printer Deployment with SNMP disabled, but it's a major problem for us.
    Monday, May 13, 2013 1:54 PM
  • I guess nothing ever came of this? I have seen this issue for quite some time, and would like to point out that it is not just 2008R2, I have the same issue with 2008. Additionally, I see this issue just pop up after the printers have been up and operational for long periods of time, all of a sudden they go offline and as soon as I uncheck the SNMP checkbox, they come online. This is for any printer manufacturer: HP, Dell, Canon, ETC. 
    Wednesday, May 7, 2014 2:18 PM
  • Hi Alan,

    Lately I experienced this "printer-offline-problem" on my Windows Server 2008 R2 Standard, Service Pack 1 . I found this thread on the internet and probably tried out everthing mentioned here. But nothing helped in my case. When I deleted and recreated this printer, it was in status Ready and was working as long there was no restart of the print spooler service. Then it switched to offline and stopped working.

    So I did open a support case at Microsoft as recommended by you.
    It didn't help to install the latest hot fixes or to delete third party language monitors from the registry. What did help, I found out two weeks ago and I want to share it here for other people having the same problem.

    1. Delete the "Offline"-printer and its port.
    2. Search the Registry for the printer name. You might find these keys:
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Hardware Profiles\0001\System\CurrentControlSet\Control\Print\Printers\***problemprinter***]
    "PrinterOnLine"=dword:00000000
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Hardware Profiles\Current\System\CurrentControlSet\Control\Print\Printers\***problemprinter***]"PrinterOnLine"=dword:00000000
    3. Recreate this printer - done!
    4. Test it by restarting the print spooler service - if you like.

    If you cannot delete the printer, because you don't want to lose the print jobs in the queue, try to find the above mentioned registry keys and delete them. Then restart the print spooler service. The printer will switch to Ready and start printing.

    Microsoft then confirmed they have comparable cases like this in their database, but no information why there are these registry keys and why they arouse this problem.

    Friday, May 16, 2014 11:59 AM
  • I've been searching this topic and yet to find the answer I'm looking for. I'm experincing this issue on Win 7 sp1 while creating a local TCPIP port. The default behavior is to create a port with the SNMP Status Enabled, but the Community name blank.

    Not only does this result in the printer showing offline continuosly, it doesnt even seem to be a supported configuration. If you open the advanced tab and close it without making any changes, you get a warning box that the Community name is invalid. Why then did Windows help me out and create the port using these settings?

    If I change the community name to public to match the printer setup, all is fine. I'd like to find a default setting somewhere and set it to public, so all new ports are created with the name set to Public, and the problem goes away. Is there such a setting?

    Monday, August 11, 2014 4:02 PM