locked
Code 22 not resolved by enabling RRS feed

  • Question

  • Hey guys,

    I bought the 1TB WD external HDD a couple of months ago and it has been working like a charm.  Today, however, it seemed to have stopped working.  I believe it is more of a software issue than a hardware one because the HDD boots up when connected and sounds to be spinning and everything it usually does.  When I heard some bad clicking, probably skipping between files on the HDD, I checked the partition for errors.  Windows said it found and corrected all of them.  I then rebooted my computer, but then the HDD didn't show up on "My Computer".  It was nowhere to be found on Disk Managment as well.  I know how to find hidden drives and ones without letter but this one didn't show up anywhere.

    In Device Manager, it was under Disk Drives.  So i checked it out.  Apparently, the drive was disabled.  Naturally, I tried to enable it.  I tried by clicking on the enable button in the "General" tab and the "Driver" tab.  Neither did the job.  Windows told be that it could not enable the drive... but didn't specify why.

    I have all the most recent drivers for this HDD, but for some reason, enabling the drive doesn't work.  I assume there is some error in my HDD, but no the Western Digital Diagnostics tool does not even see the HDD there... because it is disabled.  The problem is simple, how do I enable a disabled drive?

    Thanks for the help in advance, and I will check back often if there are any clarifications needed, which doubtless there will be.  :D

    EDIT: Vista 32bit, Sony Vaio, 2.1 GHz Core 2 Duo, 3gb RAM, 1 year old.
    Tuesday, August 25, 2009 2:30 AM