locked
Icons not being displayed on desktop RRS feed

  • Question

  • I have some icons that are not being displayed on the desktop. If I open an explorer window and navigate to the desktop in explorer, I can see all the icons. But some aren't displayed on the actual desktop. Of the icons that aren't displayed, some are files, others are shortcuts and others are folders. If I try dragging an icon that isn't being displayed from explorer to the desktop I get a message saying "Move File: The source and destination file names are the same" so the desktop thinks they are there, it just won't display them. The computer is a generic I7, new install, running W7/64. I do have 2 monitors hooked up and I have extended the desktop onto the 2nd monitor. I can drag an icon (that is being displayed) from the primary monitor to the secondary with no problem. If I try to drag an icon that I can't see from explorer to the secondary monitor I get the same "source and destination" error. If I set the monitors to "duplicate these displays" then all icons are dispalyed on both monitors, so I only seem to be having the problem when I use "extend these displays".

    Any suggestions as to what is causing this?

    Sunday, September 19, 2010 5:12 AM

Answers

  • Hi,

     

    If the icons is either of Computer, Network, Recycle Bin and User’s Files, you can right click Desktop, click Personalize, click Change Desktop icons and select the icons you want to display on desktop. If the icons are related to programs, I would recommend you to go to the folder: %userprofile%\Desktop, delete program icons and recreate new ones from the installation directory of the program, then drag the newly created icons to the %userprofile%\Desktop folder.

     

    If the issue persists, please rebuild the icons to see if it works:

     

    ·          

    1. Click the Start button, and click Computer .

    2. On the Tool bar, click Organize and choose Folder and Search Options .

    3. Click the View tab, and check to select the Show hidden files and folders option , and click OK .

    4. Then, enter the following directory:

     

    %USERPROFILE%\AppData\Local

     

    5. Find the IconCache.db file, and rename it as IconCache.db.old.

    6. Close the window, and restart the computer.

     

    Meanwhile, you can create a new user profile and login to see if the issue occurs the same.

     

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Dale Qiao Friday, September 24, 2010 6:34 AM
    Tuesday, September 21, 2010 6:03 AM

All replies

  • Hi,

     

    If the icons is either of Computer, Network, Recycle Bin and User’s Files, you can right click Desktop, click Personalize, click Change Desktop icons and select the icons you want to display on desktop. If the icons are related to programs, I would recommend you to go to the folder: %userprofile%\Desktop, delete program icons and recreate new ones from the installation directory of the program, then drag the newly created icons to the %userprofile%\Desktop folder.

     

    If the issue persists, please rebuild the icons to see if it works:

     

    ·          

    1. Click the Start button, and click Computer .

    2. On the Tool bar, click Organize and choose Folder and Search Options .

    3. Click the View tab, and check to select the Show hidden files and folders option , and click OK .

    4. Then, enter the following directory:

     

    %USERPROFILE%\AppData\Local

     

    5. Find the IconCache.db file, and rename it as IconCache.db.old.

    6. Close the window, and restart the computer.

     

    Meanwhile, you can create a new user profile and login to see if the issue occurs the same.

     

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Dale Qiao Friday, September 24, 2010 6:34 AM
    Tuesday, September 21, 2010 6:03 AM
  • Dale,

    Thanks for your reply.

    There was no problem with the Computer, Network, Recyle bin, etc, I could make them appear or disappear using the Change Desktop icons option. I also tried rebuilding the the icons by deleting the IconCache.db file but that didn't work. I then tried your suggestion of deleting the icons I couldn't see and remaking them. So far this seems to have worked but it would be nice to know why the problem is occurring in the first place as it may keep happening.

    regards

    Peter

    Saturday, September 25, 2010 9:33 AM