none
Unable to send emails from Relay Connector

    Question

  • Hello Team,

    We deployed an new Exchange 2013 server CU8 , On the CAS Server Created an receive connector for Relay and enabled anonymous only and also added the AD permission for the receive connector "Ms-Exch-SMTP-Accept-Any-Recipient", Still I am unable to send emails from the application , We can able to telnet but Emails getting failed when sending from application, Below is the collected information from the receiver Connector logs "504 5.7.4 unrecognized authentication type"

    Receive connector settings - On the security enabled TLS and anonymous

    Regards

    Mohammed Eliyas


    Sunday, March 20, 2016 1:58 PM

Answers

All replies

  • your application is trying to use an authentication mechanism that is not anonymous
    Sunday, March 20, 2016 3:28 PM
  • Hi,

    According to the error message, it seems like authentication problem. Firstly, please use get-receiveconnector -identity | fl command to check its settings.

    Then, please try to enable basic authentication on Receive Connector Security settings for test.

    Note, please restart the Transport Service after the settings was modified.

    Please also enable Exchange Servers in Permission Group for test if above method doesn’t help.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, March 21, 2016 10:30 AM
  • Hello Roger,

    Thanks for the response, I did try enabling basic authentication, result is same. When I tried with user name and password on the application instead of anonymous, I received the below error from logs

    inbound authentication failed because the client does not have submit permission.

    As far as I know Authenticated users has ms-Exch-SMTP-Submit permission by default, let me know if I am wrong.

    Regards

    Mohammed Eliyas

    Monday, March 21, 2016 2:16 PM
  • Thanks Guys, I had to recreate the connector all over again, it resolved the issue.
    • Marked as answer by eliyas.khan Tuesday, March 22, 2016 6:33 PM
    Tuesday, March 22, 2016 6:33 PM